Quantcast Avisynth: Asharp Problem - digitalFAQ.com Forums [Archives]
  #1  
04-19-2005, 01:22 PM
towerblocks towerblocks is offline
Free Member
 
Join Date: Jul 2004
Location: uk
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Hi

I have run into a problem, This is the following script im using.

LoadPlugin("C:\Program Files\AviSynth 2.5\plugins\asharp.dll")
DirectShowSource("c:\sample.mpg", fps=29.970)
BicubicResize(352,240)
asharp(1,4)

Now after adding asharp i get this http://img.villagephotos.com/p/2005-2/955649/pic.JPG ,Half the picture is normal and the other half is purple,Does anyone know what the problem could be.

Thanks
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
04-19-2005, 02:04 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Are you sure your script contains just that ? And not a "Scripclip" line somewhere ?

BTW, the solution to your problem is to add a "ConvertToYV12()" just after the Directshowsource.
Reply With Quote
  #3  
04-21-2005, 10:51 AM
towerblocks towerblocks is offline
Free Member
 
Join Date: Jul 2004
Location: uk
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
No thats the full script,I did try ConvertToYV12 but added it at the end of the script ,Added it just after source worked perfect,Thanks
Reply With Quote
  #4  
04-21-2005, 11:24 AM
towerblocks towerblocks is offline
Free Member
 
Join Date: Jul 2004
Location: uk
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Instead of starting a new thread,I've another problem with asharp http://img.villagephotos.com/p/2005-...49/picture.JPG,On some sources i seem to get bright lines around the edge of the picture,Any thoughts?
Reply With Quote
  #5  
04-21-2005, 01:04 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Perhaps a matter with dimensions not divisible by 4 (or 16 ? I don't remember. read the doc).

Note: FYI I personally NEVER use any sharpener filter. You see why...
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Avisynth: Sse mmx problem? SlowlyGoingInsane Avisynth Scripting 0 02-22-2004 11:45 PM
Avisynth: Interesting ASharp phenomenon... audioslave Avisynth Scripting 12 10-23-2003 06:36 AM
Where do I find Asharp.dll and Undot.dll? nicksteel Avisynth Scripting 1 06-10-2003 12:52 PM
Avisynth: Motion Adaptive Asharp? ovg64 Avisynth Scripting 0 06-07-2003 04:07 PM
Avisynth: Problem with Avisynth - MPEG2DEC.dll? Mario Avisynth Scripting 6 06-10-2002 08:18 AM

Thread Tools



 
All times are GMT -5. The time now is 06:03 AM  —  vBulletin Jelsoft Enterprises Ltd