Quantcast Sansgrip Filters: Nomosmooth - digitalFAQ.com Forums [Archives]
  #1  
11-13-2002, 05:38 PM
edmund edmund is offline
Free Member
 
Join Date: Oct 2002
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
hey where can i get this dll file from???
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
11-13-2002, 05:40 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by edmund
hey where can i get this dll file from???
See my sig .
Reply With Quote
  #3  
11-13-2002, 10:49 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
While watching The Amazing Race I had a very good idea to improve motion detection: temporal smooth before the detector runs, instead of after. This way you eliminate noise first and can use a lower motion_threshold before getting false hits.

Some brief experiments show I can drop motion_threshold down to 30 before I get a similar number of false hits as before at 40. It might be the case that 30 is too sensitive, and that spatial smoothing would occur in areas where motion is not pronounced enough.

Anyway, that's the status right now: I'm trying to figure out an efficient way of temporally smoothing before detection. In theory it shouldn't be too much slower than the old method.
Reply With Quote
  #4  
11-13-2002, 10:53 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Hi SansGrip,

Would this imply a change on your default settings on the NoMoSmooth filter?

-kwag
Reply With Quote
  #5  
11-13-2002, 11:51 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by kwag
Would this imply a change on your default settings on the NoMoSmooth filter?
I'm not sure. I'll think about defaults when the code works .
Reply With Quote
  #6  
11-16-2002, 04:29 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Here's NoMoSmooth 0.1a for y'all to try, as well as the source for y'all to look at should y'all so desire.

It's a total rewrite with a number of algorithmic improvements, so it should now be faster. Brief tests indicate it might even be slightly quicker than Convolution3D(preset="movieHQ"), at least on my system.

I added a simplistic "noise detector" which seems to help reduce temporal smoothing of important and very-noticible-if-missing details such as in skin tones.

This is the first official release, though I'm still classifying it as alpha until it gets more testing and I get more feedback.

Hope this works as good for y'all as it does for me .
Reply With Quote
  #7  
11-16-2002, 04:34 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by kwag
Would this imply a change on your default settings on the NoMoSmooth filter?
In the end I didn't keep this change to the motion detector, since tests revealed it was both 2-3 times slower and destroyed slightly more details than the old version.

Some of the defaults did change for 0.1:

motion_threshold=40
temporal_radius=1
temporal_threshold=6
spatial_radius=1
spatial_threshold=3

These seem fairly suitable for relatively clean DVD sources.
Reply With Quote
  #8  
11-16-2002, 04:59 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Hi SansGrip,

Thanks
Giving it a try right now.

-kwag
Reply With Quote
  #9  
11-16-2002, 06:29 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by kwag
Giving it a try right now.
Just got a bug report on Doom9 that it crashes if height > 462. I'm looking into that now.
Reply With Quote
  #10  
11-16-2002, 06:33 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SansGrip
Quote:
Originally Posted by kwag
Giving it a try right now.
Just got a bug report on Doom9 that it crashes if height > 462. I'm looking into that now.
I was testing at 352x240 with the LBR. No problems there.

-kwag
Reply With Quote
  #11  
11-16-2002, 07:14 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
I just uploaded the bugfix and edited my previous message to reflect the new filename.
Reply With Quote
  #12  
11-16-2002, 08:28 PM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SansGrip
I just uploaded the bugfix and edited my previous message to reflect the new filename.
hey SansGrip,the link don't work!
Reply With Quote
  #13  
11-16-2002, 09:01 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jorel
hey SansGrip,the link don't work!
This one works for me...?
Reply With Quote
  #14  
11-17-2002, 01:58 AM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SansGrip
Quote:
Originally Posted by jorel
hey SansGrip,the link don't work!
This one works for me...?
sorry friend,this not work too!
waiting.......click in every minut....no work.
Reply With Quote
  #15  
11-17-2002, 02:02 AM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jorel
Quote:
Originally Posted by SansGrip
Quote:
Originally Posted by jorel
hey SansGrip,the link don't work!
This one works for me...?
sorry friend,this not work too!
waiting.......click in every minut....no work.
Hi jorel,

It works for me. Maybe the route to SansGrip from your provider is down. Go here: http://www.webwarper.net and from there, access his link. It's a web based anonymous proxy

-kwag
Reply With Quote
  #16  
11-17-2002, 02:19 AM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by kwag
Quote:
Originally Posted by jorel
Quote:
Originally Posted by SansGrip
Quote:
Originally Posted by jorel
hey SansGrip,the link don't work!
This one works for me...?
sorry friend,this not work too!
waiting.......click in every minut....no work.
Hi jorel,

It works for me. Maybe the route to SansGrip from your provider is down. Go here: http://www.webwarper.net and from there, access his link. It's a web based anonymous proxy


i am in the page,but can't download.(i see all but nothing came)


-kwag
Reply With Quote
  #17  
11-18-2002, 05:57 PM
black prince black prince is offline
Free Member
 
Join Date: Jul 2002
Posts: 1,224
Thanks: 0
Thanked 0 Times in 0 Posts
Hi SansGrip,

SansGrip wrote:
Quote:
SansGrip Joined: 09 Nov 2002
Posts: 59
Location: Ontario, Canada
Posted: Sat Nov 16, 2002 5:34 pm Post subject:

--------------------------------------------------------------------------------

kwag wrote:
Would this imply a change on your default settings on the NoMoSmooth filter?


In the end I didn't keep this change to the motion detector, since tests revealed it was both 2-3 times slower and destroyed slightly more details than the old version.

Some of the defaults did change for 0.1:

motion_threshold=40
temporal_radius=1
temporal_threshold=6
spatial_radius=1
spatial_threshold=3

These seem fairly suitable for relatively clean DVD sources.
_________________
Regards,
SansGrip
Are these the default settings for NoMoSmooth() or should we use
NoMoSmooth(40,1,6,1,3) NoMoSmooth is very slow. My encode
went from 6hrs to 17hrs. Is this due to the old default settings

Thanks

-black prince
Reply With Quote
  #18  
11-18-2002, 06:03 PM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by black_prince
Are these the default settings for NoMoSmooth()
Yep, those are the values used if you don't specify any parameters.

Quote:
Originally Posted by black_prince
NoMoSmooth is very slow. My encode
went from 6hrs to 17hrs. Is this due to the old default settings
You might find the new defaults a little faster (because of the lower radii), but it is very slow. You might find FluxSmooth performs better because it's simpler, but neither of them have any assembler/MMX/SSE optimizations yet, mainly because I need to learn it first .
Reply With Quote
  #19  
11-19-2002, 12:12 AM
black prince black prince is offline
Free Member
 
Join Date: Jul 2002
Posts: 1,224
Thanks: 0
Thanked 0 Times in 0 Posts
Hi SansGrip,

Kwag uses both NoMoSmooth and FluxSmooth. Is this the best way
or should I replace flux with NoMo. It's getting confusing and changes
are comming quicker than I can keep up with. I changed my
avs scripts more than 15 times with NoMo, flux and blockbuster and
I'm still not sure what's the latest and the best settings I'm
going to wait awhile until the testing settles down and there are
some final settings to work with.

-black prince
Reply With Quote
  #20  
11-19-2002, 12:41 AM
SansGrip SansGrip is offline
Free Member
 
Join Date: Nov 2002
Location: Ontario, Canada
Posts: 1,135
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by black prince
Kwag uses both NoMoSmooth and FluxSmooth. Is this the best way or should I replace flux with NoMo.
Technically Flux is (sort of) NoMo without motion detection. I'd have to think about how they would interact with each other.

Quote:
Originally Posted by black prince
I'm going to wait awhile until the testing settles down and there are some final settings to work with.
Is anything ever final in this hobby?
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
SansGrip Filters: NoMoSmooth for AviSynth v2.5 jorel Avisynth Scripting 0 09-15-2003 08:43 PM
SansGrip Filters: Merits of NoMoSmooth?? Reno Avisynth Scripting 7 07-03-2003 08:26 AM
SansGrip Filters: FluxSmooth AND NomoSmooth ? Jellygoose Avisynth Scripting 4 11-24-2002 05:12 PM
KVCD: Lastest script for blockbuster and nomosmooth filters? syk2c11 Video Encoding and Conversion 9 11-21-2002 06:37 PM
SansGrip Filters: Blockbuster + Nomosmooth filters syk2c11 Avisynth Scripting 2 11-18-2002 02:29 PM

Thread Tools



 
All times are GMT -5. The time now is 11:33 PM  —  vBulletin Jelsoft Enterprises Ltd