Quantcast Bye Bye Avisynth 2.5 - digitalFAQ.com Forums [Archives]
  #1  
04-11-2003, 06:05 PM
jamesp jamesp is offline
Free Member
 
Join Date: Jul 2002
Location: Chelmsford, UK
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Well today i finally did it - i uninstalled Avisynth 2.5 and went back to trusty old 2.0.7. I tried and tried to use Avisynth 2.5, and it was certainly much, much faster. However, it continually buggered up my machine. These were the following problems i've had;

*) System just locks up at random points during the encode. After going back to 2.0.7 my machine hasn't locked once.
*) Blue Screen with Device Error. This never happened with 2.0.7.
*) Memory leaks. Occasionally, my hard drive would go mad and my machine became very unresponsive, and Windows would tell me I didn't have enough virtual memory. Back to 2.0.7 where i have never had this problem.

After going back to 2.0.7, i stressed tested my PC and my machine has been encoding constantly (tv captures) for a day and a half. Not a single problem yet. These same captures caused all sorts of probs with 2.5.
I think the work the avisynth team does is wonderful, but 2.5 is only a beta and hopefully these issues will get sorted.

Anyone else had problems with 2.5

Jim
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
04-11-2003, 06:09 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Jim,

Ditto on all your comments. I'm using 2.08 without any problems now. Guess we need to led avisynth 2.5x thaw for a while

-kwag
Reply With Quote
  #3  
04-12-2003, 05:28 AM
jamesp jamesp is offline
Free Member
 
Join Date: Jul 2002
Location: Chelmsford, UK
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Nice to know i'm not the only one!

I'm under no illusions that it is probably PC related. I posted this message at Doom9

http://forum.doom9.org/showthread.ph...threadid=49394

And they suggested trying a tool that stress tests your machine. Mine reports a problem during the test, but doesn't hang my machine. However, i've tried the same test on all my friends and families machines and every single one reports a problem at some stage during the stress test. I imagine the latest version of avisynth is written using Assembler where ever possible and any problem can cause a machine to hang, rather than crash gracefully!

Jim

Quote:
Originally Posted by kwag
Hi Jim,

Ditto on all your comments. I'm using 2.08 without any problems now. Guess we need to led avisynth 2.5x thaw for a while

-kwag
[/url]
Reply With Quote
  #4  
04-12-2003, 12:37 PM
vico1 vico1 is offline
Free Member
 
Join Date: Sep 2002
Location: USA
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
I`ve run into somewhat similar probs using v2.5x on my machine.
(P4@1.7ghz 512MB)

I went to v2.08....no probs. (stick with "the devil you know", I guess)



*********************************
The Devil....is in the Details
Reply With Quote
  #5  
04-23-2003, 08:28 AM
sh0dan sh0dan is offline
Free Member
 
Join Date: Mar 2003
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Your choice - you should however have check your hardware with Prime96, as it is most likely unstable.

2.5 is soon leaving beta stage, and there will be no more updates of 2.0 after that - from me anyway.
__________________
Regards, sh0dan // VoxPod
Reply With Quote
  #6  
04-23-2003, 08:48 AM
jamesp jamesp is offline
Free Member
 
Join Date: Jul 2002
Location: Chelmsford, UK
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
As i said, i've no doubt its related to my PC, as Prime95 says i get some sort of floating point error very quickly into the test. However, its amazing that i have never once had the crash using Avisynth 2.0.8. Eg, over the Easter Weekend i captured and encoded 10 Films - not one problem. Installed Avisynth 2.5 - it hung my machine at 10% on the first film.

However, I have since found out that the problem only occurs when i use AviSource combined with ConvertToYV12(). I can encode DVD rips with no problems in avisynth 2.5 (in the YV12 colour space). So maybe there is a bug lingering in there somewhere when converting from YUY2 to YV12?

Jim

Quote:
Originally Posted by sh0dan
Your choice - you should however have check your hardware with Prime96, as it is most likely unstable.

2.5 is soon leaving beta stage, and there will be no more updates of 2.0 after that - from me anyway.
Reply With Quote
  #7  
04-23-2003, 09:53 AM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by sh0dan

2.5 is soon leaving beta stage, and there will be no more updates of 2.0 after that - from me anyway.
Hi sh0dan,

Does this mean that 2.5 will be considered "stable", just as stable as the 2.0x branch ?

-kwag
Reply With Quote
  #8  
04-24-2003, 11:25 AM
sh0dan sh0dan is offline
Free Member
 
Join Date: Mar 2003
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
There is still a few issues with some internal filters, that should be fixed before it can happend (temporalsoften, some audio plugins come to mind), but the core appears very stable.

Also a solution to the "caching issue", where we were working on rewriting the cache, should preferably be finished, but we have been unable to find a good solution so far - even though we are still working on it.

All (serious) bugs found in 2.5 have also been fixed in 2.0, so of course 2.0 is still the most stable, if you only need that functionality. However the YV12 colorspace opens many possibilities for optimizations and filters.
Conditional filtering is a whole other issue, where we are only scratching the surface for now, which will bring loads of power to the users.
__________________
Regards, sh0dan // VoxPod
Reply With Quote
  #9  
04-24-2003, 11:41 AM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
That's great sh0dan.
Will keep a close eye on your development

-kwag
Reply With Quote
  #10  
04-27-2003, 03:24 PM
Jellygoose Jellygoose is offline
Free Member
 
Join Date: Jun 2002
Location: Germany
Posts: 1,288
Thanks: 0
Thanked 0 Times in 0 Posts
Where can I get Prime96 to check my hardware?
__________________
j3llyG0053
Reply With Quote
  #11  
04-27-2003, 09:16 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Try here Jellygoose http://www.mersenne.org/freesoft.htm

-kwag
Reply With Quote
Reply




Thread Tools



 
All times are GMT -5. The time now is 11:44 AM  —  vBulletin Jelsoft Enterprises Ltd