digitalFAQ.com Forums [Archives]

digitalFAQ.com Forums [Archives] (http://www.digitalfaq.com/archives/)
-   Avisynth Scripting (http://www.digitalfaq.com/archives/avisynth/)
-   -   Reinstalled XP and now Avisynth output is upside down (http://www.digitalfaq.com/archives/avisynth/4030-reinstalled-xp-avisynth.html)

Fiz 06-17-2003 06:00 AM

Reinstalled XP and now Avisynth output is upside down
 
Hey guys,

I decided to rebuild my XP install with a clean image (if there is such a thing with XP :wink: ). I installed Avisynth 2.52 and tried a test encode. The problem I'm getting is that the AVS script is playing back upside down! I have tried with no filters and just the Mpeg2Source line. Regardless of which player I try (mplayer classic, zoomplayer, media player) it always shows the image rotated. If I use FlipVertical() it shows normal but I get an access violation if I scroll through the movie.

The stranger thing is that if I load the script into TMpeg it shows correctly :? and encodes normally!

Reading the help on FlipVertical() it says that it is used to correct broken codecs. Is it something to do with a codec? It's probably something very trivial and someone may have come across this issue already. Any ideas?

My source is a PAL DVD and I am using the latest script for 2.52 with MPEG2DEC3. It happens regardless of which source I use and without any filters.

Cheers.

Krassi 06-17-2003 07:20 AM

Hi Fiz,

have you tried reinstalling the codecs? It seems to be a codec issue. Mpeg1 or Mpeg2?

A handstand-codec :D

Fiz 06-17-2003 07:29 AM

Quote:

Originally Posted by Krassi
Hi Fiz,

have you tried reinstalling the codecs? It seems to be a codec issue. Mpeg1 oder Mpeg2?

A handstand-codec :D

Hey Krassi thanks for the info.

I wasn't sure I needed to install any other codecs... I have powerdvd installed and I thought that would be enough for MPEG2, or not?

If I play the d2v file in media player classic, it plays fine without rotating so I'm figuring something is playing up when its frameserved through avisynth.

Actually thinking about it I did install ffdshow and maybe thats interfering with it. The only other codecs I installed were Divx and Xvid but they should not affect dvd sources. If TMPeg can see it properly I am sure its a problem with direct show playback and maybe the ffdshow filter is causing it. I'll give it a try.

Thanks, Fiz.

Krassi 06-17-2003 07:39 AM

Quote:

Originally Posted by Fiz
If I play the d2v file in media player classic, it plays fine without rotating so I'm figuring something is playing up when its frameserved through avisynth.

Then its not codec related.
Quote:

Actually thinking about it I did install ffdshow and maybe thats interfering with it. The only other codecs I installed were Divx and Xvid but they should not affect dvd sources. If TMPeg can see it properly I am sure its a problem with direct show playback and maybe the ffdshow filter is causing it. I'll give it a try.
Maybe. I guess a complete reinstall (of Avisynth with ffdshow) could help.

Fiz 06-17-2003 08:59 AM

Ok, I got it working. The problem was the ffvfw filter installed as part of avisynth 2.5. With my cavalier approach of installing filters and codecs I must have screwed the settings or something. I uninstalled ffvfw and the picture was no longer rotated.

After re-installing ffvfw with Avisynth 2.52 it is no longer a problem. As a side note I had also uninstalled ffdshow and this had not helped. Seeing as I don't really need it I think I'll leave it off for now.

Thanks for you help Krassi :D


All times are GMT -5. The time now is 10:49 AM  —  vBulletin Jelsoft Enterprises Ltd

Site design, images and content © 2002-2022 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2022 Jelsoft Enterprises Ltd.