Quantcast TOK Lädt AVS Script Nicht - digitalFAQ.com Forums [Archives]
  #1  
01-05-2004, 06:14 AM
jason1 jason1 is offline
Free Member
 
Join Date: Dec 2003
Location: Die Matrix
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Hey,

Ich hab mal ne Frage und zwar:
Ich habe mir hier ein Script geladen und es mit meinen Pfadangaben
geändert, wenn ich es jetzt mit Tok laden will, kommt immer die
Fehler meldung "Invalid floating Point Operation"!
Wenn ich dann im Log Fenster nachschaue dann zeigt er mir an:
Resolution 0,0 fps also als wäre kein Film vorhanden.
Das Script das ich benutze ist dieses: ## DLL Section ##
#
LoadPlugin("C:\Programme\AviSynth 2.5\plugins\MPEG2Dec3.dll")
LoadPlugin("C:\Programme\AviSynth 2.5\plugins\GripFit_YV12.dll")
LoadPlugin("C:\Programme\AviSynth 2.5\plugins\STMedianFilter.dll")
LoadPlugin("C:\Programme\AviSynth 2.5\plugins\asharp.dll")
LoadPlugin("C:\Programme\AviSynth 2.5\plugins\undot.dll")
#
####

## Defined Variables and Constants ##
#
MaxTreshold = 1.50
scd_trigger = 30 # Scene change trigger value.
nf = 0 # Current frame.
#
####

## Main section and static filters ###
#
AviSource("D:\Xvid\kb.avi")
#
undot()
Limiter()
asharp(2, 4)
GripCrop(352, 288, source_anamorphic=false)
GripSize(resizer="BicubicResize")
STMedianFilter(8, 32, 0, 0 )
MergeChroma(blur(MaxTreshold))
MergeLuma(blur(0.2))
#
#

## Dynamic Linear Adaptive Filtering and Scene Change Detection ##
#
# ( Portions from AviSynth's manual ) - This will apply temporalsoften to
# very static scenes, and apply variable blur on moving scenes.
# We also assign a variable - and this is why a line break is inserted:

ScriptClip("nf = YDifferenceToNext()"+chr(13)+ "nf > 2.5 ? asharp( -(fmin((nf/30), 1)), 0 ) : \
TemporalSoften(2,7,7,3,2) ")

#
# Scene change detection ( kwag ) - If a scene change is detected, we
# blur heavily. This affects the scene before and the one after the
# scene change, thus providing a softer transition for the encoder instead
# of a sharp "spike".
# If it's not a scene change, then we just blur dynamically, depending on
# the action.

ScriptClip("nf > scd_trigger ? asharp( -2,0) : asharp(0,0) ")

#
#
#

GripBorders()
#LetterBox( Your_Values_Here ) # Depends on situation. Use MovieStacker!
Limiter()

#
#
## Functions ###

function fmin(float f1, float f2) {
return (f1<f2) ? f1 : f2
}

#
####

Wenn mir da einer helfen würde wäre echt super.
Im voraus schon mal THX
__________________
Kontrolle gibt es keine denn man weiß nie was im nächsten Augenblick passiert!
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
01-05-2004, 06:20 AM
incredible incredible is offline
Free Member
 
Join Date: May 2003
Location: Germany
Posts: 3,189
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to incredible
a) benutzt du eine URALTE Version des MA Scriptes! Bitte lade dir unter "Optimal Scripts" und dann unter "LAtest Scripts" die neueste Version herunter!

b) Kann es sein, dass die bei TOK beiliegende "Sampler.dll" nicht mit avisynth 2.5x kompatibel ist. Und ich nehme mal schwer an, dass du Avisynth 2.5x benutzt, laut deiner Filter-Pfade.

Lösche die alte Sampler.dll und nehme DIESE HIER:

www.incredible.de.tf/Downloads/Sampler-2.5.rar

c) Wenn dann immer noch jener Fehler auftaucht, solltest du TOK komplett neu installieren.

d) Ist die Prediction Methode von TOK in ihren StandardSettings veraltet, daher entweder auf CQMatic umsteigen oder die Prediction manuell spezifisch einstellen (und das ist immer Filmabhängig, man kann also nicht eine generelle Settings-Empfehlung abgeben)
Reply With Quote
  #3  
01-05-2004, 07:13 AM
jason1 jason1 is offline
Free Member
 
Join Date: Dec 2003
Location: Die Matrix
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
a) benutzt du eine URALTE Version des MA Scriptes! Bitte lade dir unter "Optimal Scripts" und dann unter "LAtest Scripts" die neueste Version herunter!

Werde ich tun,

) Kann es sein, dass die bei TOK beiliegende "Sampler.dll" nicht mit avisynth 2.5x kompatibel ist. Und ich nehme mal schwer an, dass du Avisynth 2.5x benutzt, laut deiner Filter-Pfade.

Die Sampler.dll ist die für AviSynth 2.5,

Ich werde es nochmal probieren und mich dann evtl. nocheinmal melden!

Jason
__________________
Kontrolle gibt es keine denn man weiß nie was im nächsten Augenblick passiert!
Reply With Quote
  #4  
01-05-2004, 07:41 AM
jason1 jason1 is offline
Free Member
 
Join Date: Dec 2003
Location: Die Matrix
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Ich habe das ganze jetzt mit dem neuen MA-Script gemacht,
aber immer noch das gleiche Prob..
ToK nimmt einfach nicht das Script an. Wie meinst Du das mit
dem ich sollte ToK deinstallieren?
Bei mir wird das Programm aus dem Ordner heraus gestartet.
Gibt es da noch andere Versionen, ich habe die 0.0.5.3

Bei CQmatic brauche ich gar kein Script oder? Da kann man doch
gleich die Avi(Mpeg)Source aufrufen.

jason
__________________
Kontrolle gibt es keine denn man weiß nie was im nächsten Augenblick passiert!
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Warum MVCD, und nicht KVCD chokn Video Konvertierung und Encodieren (Deutsch) 4 09-04-2003 12:32 PM
CQMatic funktioniert bei mir Nicht wer kann mir helfen Corey Video Konvertierung und Encodieren (Deutsch) 5 08-29-2003 01:07 AM
Avisynth: Difference between MA script and optimal script? mistermickster Avisynth Scripting 2 08-01-2003 09:36 AM
Avisynth öffnet .d2v nicht egotubes Video Konvertierung und Encodieren (Deutsch) 2 07-18-2003 05:08 PM
MA-Part im Optimalen Script nicht anwählbar!!!!! Avalon Video Konvertierung und Encodieren (Deutsch) 1 07-18-2003 04:31 PM

Thread Tools



 
All times are GMT -5. The time now is 12:06 PM  —  vBulletin © Jelsoft Enterprises Ltd