Quantcast Mencoder a/v Sync Problem + Transcode Tutorial ? [Solved] - digitalFAQ.com Forums [Archives]
  #1  
09-12-2006, 01:40 AM
le_barbu le_barbu is offline
Free Member
 
Join Date: Sep 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
hi, I use mencoder 1.08pre (and Mandriva 2006) to backup a DVD, but I have audio desynchronisation while playing my KSVCD (at the beginning the audio is sync). Here's my command line:

Code:
mencoder dvd://1 -aid 129 -ovc lavc -oac lavc -lavcopts acodec=mp2:abitrate=224:vcodec=mpeg2video:trell:keyint=24:vstrict=-1:vrc_eq=(tex/avgTex+1)^0.5:vmax_b_frames=2:dia=2:dc=8:mbd=2:vrc_buf_size=917:vbitrate=1000:vrc_maxrate=2520:mv0:psnr:inter_matrix=$kvcd_matrix:intra_matrix=$kvcd_matrix -srate 44100 -af lavcresample=44100,volnorm=1 -vf scale=352:432,expand=352:576,harddup,hqdn3d=2:1:2,pp=hb/vb/dr/al/lb -of mpeg -mpegopts vaspect=4/3:format=xsvcd -fps 25000/1000 -ofps 25 -o movie.mpeg
And does someone have a transcode tutorial since I've read the manpage but... it's so complicated!

thx.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
09-12-2006, 02:54 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Mencoder is considered as not reliable so we frozen the forum where we were speaking about it. Moreover we do not use to encode audio at the same time as video, so it's not sure that you would have an answer.

As a workarround you should encode video first, then see if length in minutes of the encoded video matches the length au the source. Then encode the audio with something else (besweetGUI for instance) and see if all has the same length. Else I guess that you have a framerate issue somewhere (is the source PAL or NTSC ?).

About transcode, I don't know it, can you give a link to it ?
Reply With Quote
  #3  
09-12-2006, 05:09 AM
le_barbu le_barbu is offline
Free Member
 
Join Date: Sep 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
[Edit]

The problem came from the "lavc" audio codec !
I was encoding my video with the lavc codec for the video and the audio streams...

So, I've tried with: lavc for the video stream and twolame for the audio one: It worked !

I have no more synchronisation problem !!!!!!!!!!!!!!!!!!!

PS: the "twolame" codec is present in the Linux/Unix version of mplayer but (by default) is not present in the windows one.
So Linux Users: Let's go enccoding !!!!!!!!!!!!!!!!

[/Edit]

Ok, I'll try to encode Audio and Video separately...

for transcode, here's the url: http://www.transcoding.org/cgi-bin/transcode
it is another unix "swiss knife" video tool, and it's often used for converting videos... like in the "tovid" scripts.

thx.

PS: for the framerate issue, I don't think: my video source is 25fps (I think because it is PAL) and my target video is 25fps PAL
Reply With Quote
  #4  
09-12-2006, 06:20 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Great. People often look for unix/linux tool to handle their video
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Mencoder: Audio/Video sync problem rhino Video Encoding and Conversion 0 06-16-2004 08:52 AM
Audio Sync Problem ? letmein Video Encoding and Conversion 8 01-20-2004 04:09 PM
HeadAC3he: Whats's my problem and how should it be solved? Wolfi Audio Conversion 10 11-22-2003 06:16 PM
ntsc to pal causes lip sync problem Mr8ond Video Encoding and Conversion 1 07-29-2003 10:08 AM
KVCD: Audio sync problem? Wolfi Video Encoding and Conversion 24 04-16-2003 06:44 AM

Thread Tools



 
All times are GMT -5. The time now is 09:09 AM  —  vBulletin Jelsoft Enterprises Ltd