Quantcast FFmpeg: use only Some Subtitles? - digitalFAQ.com Forums [Archives]
  #1  
10-02-2003, 04:27 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
I've got a movie in which some ppl speak japanese for 10 sec (happens more than 1 time)
This part of the movie has "hard" subtitles... even if I don't have subs enabled on my dvd player, he displays them...
As these subs are quite important I'd like to hardcode them into the picture... but ONLY these "always display" subs...

Any idea how to do that
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-02-2003, 05:09 AM
el_mozo el_mozo is offline
Free Member
 
Join Date: Sep 2003
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Hmmm I don't know how these subtitles work, maybe they are in a differenct sid (subtitles id channel), where the only text is in this scenes. Play the movie with mplayer -v and look at the logs, it will tell you the subtitle channels numbers. Then try "mplayer -sid 1 (args)", "mplayer -sid 2 (args)" and all the different subtitle channels, and maybe you'll find an id with subtitles only in those scenes..

Once you have the id, then you can hardcode them into the movie as other subtitles.

Cheers.
Reply With Quote
  #3  
10-11-2003, 11:21 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
nope... only one sid... and in this sid, there are normal subs... including the ones always displayed
Reply With Quote
  #4  
10-12-2003, 02:51 AM
buildid buildid is offline
Free Member
 
Join Date: Sep 2003
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to buildid
so ill guess that they are already hardcoded into the movie ....

so what happens if you delete "those subs " from the subfile ?

And have a look again on the movie ....
Reply With Quote
  #5  
10-12-2003, 07:16 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
nope... they aren't hardcoded...
VLC and mplayer don't play them if I don't tell them to play subs...
Reply With Quote
  #6  
10-23-2003, 02:55 PM
J-Wo J-Wo is offline
Free Member
 
Join Date: Nov 2002
Location: Toronto, Canada
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
I was wondering the same thing with the movie Black Hawk Down, in which some characters speak Bosnian (I think) during some scenes. Have you tried asking in the other forums? I've never used ffmpeg before, I thought it was for ac3 encoding...? no?
Reply With Quote
  #7  
10-24-2003, 08:21 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
no... not only ac3 encoding...
Now I got the Problem again...
This time: "Lord of the Rings 2 Towers" :-/
Reply With Quote
  #8  
11-04-2003, 02:30 AM
buildid buildid is offline
Free Member
 
Join Date: Sep 2003
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to buildid
so what happens if you save only the video with a tool like "avidemux2" or a another aplication . are the subs still on that file ?

i ment reencode again , audio and video .

if subs are gone , you can made a subtitle and add it to your new movie .

hope you understand my simple english
Reply With Quote
  #9  
11-04-2003, 05:42 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
I think I got the message

But these subtitles AREN'T hardcoded in the video!
They are regular subtitles with an "always show" feature... You can do this e.g. with dvdmaestro... but I don't know how to filter ONLY these "always show" subs
Reply With Quote
  #10  
11-05-2003, 03:37 PM
buildid buildid is offline
Free Member
 
Join Date: Sep 2003
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to buildid
try to convert the avi/divx or whatever again wit avidemux2 .

only video no sound and have a look at what happens .

you can probaly just rencode the frames where the subs are shown .

anyway what is the name of the movie , ill try to download the file , like to see the problem . if possible .
Reply With Quote
  #11  
11-05-2003, 04:03 PM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
My Problems occured BOTH with DVD Material (Tanguy + Lord of the Rings: 2 towers)...

In Tanguy it's Japanses
In LOTR it's orcish
Reply With Quote
  #12  
11-06-2003, 10:29 AM
buildid buildid is offline
Free Member
 
Join Date: Sep 2003
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to buildid
so , you ment you have both dvd at home , downing an avi is no option for me .If the problem come with the dvd.

otherwise i would have done a search for the movie with japanese subs .
Reply With Quote
  #13  
11-06-2003, 12:44 PM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
no... with avis I would have no problem as it is either ALL hardcoded or everything in an external file
Reply With Quote
  #14  
11-07-2003, 07:38 AM
japie japie is offline
Free Member
 
Join Date: Jul 2003
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
What info does lsdvd -s show you?
__________________
Groetjes Japie
Reply With Quote
  #15  
11-07-2003, 08:51 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
nothing yet *g*
I'll reinstall Linux later this day (From SUSE back to Knoppix)
then I'll be able to tell you
Reply With Quote
  #16  
11-07-2003, 12:53 PM
japie japie is offline
Free Member
 
Join Date: Jul 2003
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
You told mplayer didn't show the "hidden" subs if you didn't load ANY subs, only when you load whatever kind of sub stream, but your hardware dvd does show them even when no subs selected. (puff)
What do windblows players do and what does xine do?
If all linux apps. (mplayer,xine and lsdvd) don't show the "hidden" sub stream it's probebly a libdvdread problem, wonder if windblows apps. show it.
__________________
Groetjes Japie
Reply With Quote
  #17  
11-08-2003, 07:45 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Damn... just crashed my Knoppix (Seems as if I can't get 3d Support running on any Linux... And I thougt a GF2TI would be supportet by any OS)

These subs arent "hidden"... they are part of the normal subtitle track (there is only one on the DVD)!

I know from "DVD Maestro" that you can tell to "always show" some subpictures... I guess I'll have to rip the whole sub to a text format and select the "always show" parts manually and merge them into a new file :-/
Reply With Quote
  #18  
11-09-2003, 08:06 AM
japie japie is offline
Free Member
 
Join Date: Jul 2003
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Razorblade2000
Seems as if I can't get 3d Support running on any Linux...
Try the Nvidia detonator driver for linux, works great (but is closed source, yust like the windowz onez)
Quote:
Originally Posted by Razorblade2000
These subs arent "hidden"... they are part of the normal subtitle track (there is only one on the DVD)!
They must be somewhere, have you searched every vob for it's contens?
__________________
Groetjes Japie
Reply With Quote
  #19  
11-09-2003, 08:17 AM
Razorblade2000 Razorblade2000 is offline
Free Member
 
Join Date: Aug 2002
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
There is only one Subtitle stream!
This stream includes ALL the (german) subtitles for the movie
And in this stream, some subpictures (e.g. 20 out of 500) are marked as "show always" (or sth like that)
--> the "show always" subs and the normal subs are embedded in the same subtitle-stream.


p.s.
I tried the Detonator for Linux on Suse and on Knoppix... never worked... always gave me some problem :-/
Reply With Quote
  #20  
11-10-2003, 06:03 AM
japie japie is offline
Free Member
 
Join Date: Jul 2003
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Razorblade2000
And in this stream, some subpictures (e.g. 20 out of 500) are marked as "show always" (or sth like that)
So it's a mplayer/mencoder subreading problem, maybe worth posting a bugreport.
Quote:
Originally Posted by Razorblade2000
p.s.
I tried the Detonator for Linux on Suse and on Knoppix... never worked... always gave me some problem :-/
No problems on my linux from scratch here, what was that same problem?
__________________
Groetjes Japie
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Subtitles: Adding .srt subtitles to a KVCD movie xpronic Subtitles 13 06-12-2004 09:33 PM
FFMPEG: Do ffvfw and mencoder/ffmpeg give the same results? Razorblade2000 Video Encoding and Conversion 4 02-06-2004 04:23 PM
FFMPEG: FFMPEG status on MPEG-2 encoding bilu Video Encoding and Conversion 3 01-31-2004 06:18 AM
FFMPEG: Ffmpeg and inter/intra matrices vidar Video Encoding and Conversion 4 10-31-2003 08:48 PM
FFMPEG: Encoding Audio: toolame,mp2enc or ffmpeg Razorblade2000 Video Encoding and Conversion 0 10-18-2003 03:04 PM

Thread Tools



 
All times are GMT -5. The time now is 12:22 PM  —  vBulletin Jelsoft Enterprises Ltd