Quantcast Filesize Prediction - Always End up with a CQ of 90? - digitalFAQ.com Forums [Archives]
  #1  
10-21-2003, 07:15 PM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Im trying to use the V3 script with ToK,but since Ive upgraded to avisynth 2.5 I cant get Tok to do any file size prediction.It just runs the test on black screens so I always end up with a CQ of 90.Anyone help me as I want to use the script on my avi files??

I cant make head nor tail of CQmatic and would like to carry on using ToK which has always predicted fine with moviestacker scripts. Any tips would be gratefully accepted.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-21-2003, 07:23 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Did you DL the 2.5 version of all the plugins that are in the script ?

Does the script load into wmp without any error ?
Reply With Quote
  #3  
10-21-2003, 07:59 PM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Thanx for the quick response.

Yes I have all the 2.5 versions of the filters and I can set a CQ in ToK and encode with no probs,only thing is I have no way of doing a prediction to find the best CQ to use as all the sample frames are black. The only way I have been able to use it is to encode 10% of the movie and see what the file size is like and adjust the CQ either up or down next time I do it til I get the right file size.Although this method works pretty well it is far from ideal as it takes a while to do 10%encode.

Seems all the filters are working fine,just the prediction in ToK that isnt. It has always worked fine using moviestacker scripts and just thought Id get up to date and try some new scripts.
Reply With Quote
  #4  
10-21-2003, 08:13 PM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Heres my ToK log,not much use I agree.But U can see the full avi is there but it doesnt use it in the prediction


================================================== ===========
ToK Log: C:\Documents and Settings\Desktop\aviscript.avs
================================================== ===========

Resolution (fps):352x240 (25.000 fps)
Total Frames: 107687
Total Time : 01:11:47
-------------------------------------------------------------

Audio Size: 86,140,000
Required Video Size: 725,729,400

Factor: 60.000
Desired Sample Size: 12,095,491

-------------------------------------------------------------
New Faster Prediction
-------------------------------------------------------------

Full Sample
Next CQ: 70.000. Sample Size: 405,479
Small Sample
Next CQ: 70.000. Sample Size: 405,479
Predicting...
NextCQ: 2,088.109 >=90, so check is needed
Next CQ: 90.000
Sample Size: 405,479


Final CQ: 90.000
Total Time For Predicition: 00:01:27

Total Time (all operations): 00:01:27

Finished
Reply With Quote
  #5  
10-21-2003, 09:47 PM
muhali3 muhali3 is offline
Free Member
 
Join Date: Sep 2003
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
Make sure you don't have sampler in you're already made AVS file, because then ToK would be making a sample of a sample.
Reply With Quote
  #6  
10-22-2003, 03:52 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Can you post your original avs script and the one generated by Tok when it makes its samples (it is called "video.avs") ?
Reply With Quote
  #7  
10-22-2003, 08:37 AM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Heres my avs script-

AviSource("C:\myavi.avi",false)
BlindPP(cpu=4)
SwapUV()
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
GripCrop(352, 240, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()

And heres the cript that tok generates(video.avs)

AviSource("C:\myavi.avi",false)
BlindPP(cpu=4)
SwapUV()
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
GripCrop(352, 240, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()
AssumeFPS(25.000)
LoadPlugin("C:\Documents and Settings\Desktop\kvcdstuff\ToK_0.0.5.3\ToK_0.0.5.3 \ToK_EXTRAS\ToK_EXTRAS\Sampler\Sampler.dll")
oldfps = framerate
interval = round((FrameCount/25)/60.000)/10
nFrames = round(25)
SelectRangeEvery( (round(framecount/interval)),nFrames)

Hope this helps!
Reply With Quote
  #8  
10-22-2003, 08:47 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by shibumi
Settings\Desktop\kvcdstuff\ToK_0.0.5.3\ToK_0.0.5.3\ToK_EXTRAS\ToK_EXTRAS\Sampler\Sampler.dll")
These part are strange ! Can you check on your hard disc if that is really two times each one ? Else I guess you should correct this in Tok settings (don't remember well).
Reply With Quote
  #9  
10-22-2003, 09:17 AM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
yup,that really is the path to sampler.dll,strange I know,but its just where I installed everything.Im wondering now if its a codec problem.All the strange things started when I installed ffvfw with avisynth.Will avisynth 2.5 still work without ffwfw?Apart from this Im clutching at straws.
Reply With Quote
  #10  
10-22-2003, 09:47 AM
Jellygoose Jellygoose is offline
Free Member
 
Join Date: Jun 2002
Location: Germany
Posts: 1,288
Thanks: 0
Thanked 0 Times in 0 Posts
You have to point ToK to the Sampler-2.5.dll if you're using AviSynth 2.5... Otherwise it will not work...
__________________
j3llyG0053
Reply With Quote
  #11  
10-22-2003, 10:28 AM
shibumi shibumi is offline
Free Member
 
Join Date: Sep 2003
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Thanx for all the help,that solved the problem! Somehow missed changing to sampler 2.5dll in all the help files.Thanx to all for helping
Reply With Quote
  #12  
11-19-2003, 10:17 PM
EvilDave EvilDave is offline
Free Member
 
Join Date: Sep 2003
Location: US
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
I'm having the same problem to. The path to my Sampler-2.5.dll is correct.
Yet every time I run the avs script I get a cq of 90. I've even tried the optimal script which I've used in the past with avi sources and had no problem with, and thats coming back with a cq of 90 to.

Here is my tok_log

================================================== ===========
ToK Log: C:\WINDOWS\Desktop\kvcd\NewScript.avs
================================================== ===========

Resolution (fps):352x240 (23.976 fps)
Total Frames: 149200
Total Time : 01:43:43
-------------------------------------------------------------

Audio Size: 149,352,000
Required Video Size: 663,149,520

Factor: 59.940
Desired Sample Size: 11,063,556

-------------------------------------------------------------
New Faster Prediction
-------------------------------------------------------------

Full Sample
Next CQ: 70.000. Sample Size: 5,532,387
Small Sample
Next CQ: 70.000. Sample Size: 518,706
Predicting...
NextCQ: 139.985 >=90, so check is needed
Next CQ: 90.000
Sample Size: 8,947,314


Final CQ: 90.000
Total Time For Predicition: 00:17:22

Total Time (all operations): 00:17:22

Finished

==========================================

Here is the video.avs


LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\MPEG2Dec3.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\blockbuster.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\Convolution3DYV12.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\GripFit_YV12.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\undot.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\DctFilter.dll")
#
AviSource("C:my_source.avi",false)
AssumeFPS(23.976, true)
ConvertToYV12()
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(352, 240, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()
AssumeFPS(23.976)
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\Sampler-2.5.dll")
oldfps = framerate
interval = round((FrameCount/24)/59.940)/10
nFrames = round(24)
SelectRangeEvery( (round(framecount/interval)),nFrames)

===============================================

I haven't had a problem till now. I use the optimal script for dvd clean sources, on my avi files. I just add blockbuster to it. Does anyone have any ideas why the cq is stuck at 90 ???

thanks for you help.
Reply With Quote
  #13  
11-20-2003, 04:18 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Look at the video encoded by Tok till its end and see if you don't have an "avisynth caught en error" message that appears.

Sometimes the encoding starts correctly but failed in the middle and you obtain a very small video that makes Tok to fail.
Reply With Quote
  #14  
11-20-2003, 10:02 AM
EvilDave EvilDave is offline
Free Member
 
Join Date: Sep 2003
Location: US
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
I've watched the video.. No access violations. I've tried different avi files and they all come back with a cq of 90. I've encoded about 15 movies so far with no problems until I tried this script. The funny thing is that my old avs script I used to use is also coming back with a cq of 90 now.

It's has to be some thing I'm doing wrong. I keep getting this line in the tok log....

NextCQ: 346.590 >=90, so check is needed

I'm at a loss.
Reply With Quote
  #15  
11-20-2003, 10:11 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Look at the size of the sample in the log : it is around 5 MB where Tok expect a 11Mb one ! You must find why the sample is so short.

Is the video file generated really 5MB long ?

What values do you have for min and max video bitrate ?
Reply With Quote
  #16  
11-21-2003, 09:50 AM
EvilDave EvilDave is offline
Free Member
 
Join Date: Sep 2003
Location: US
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
My min. bitrate 300 / max. bitrate 2500 I've always encoded with thoes values.

I did a prediction with a movie I had on cd from a while back. It went through but still had that line in it.

This is the log.

================================================== ===========
ToK Log: C:\WINDOWS\Desktop\kvcd\NewScript.avs
================================================== ===========

Resolution (fps):352x240 (23.976 fps)
Total Frames: 135110
Total Time : 01:33:55
-------------------------------------------------------------

Audio Size: 90,160,000
Required Video Size: 721,749,600

Factor: 59.940
Desired Sample Size: 12,041,201

-------------------------------------------------------------
New Faster Prediction
-------------------------------------------------------------

Full Sample
Next CQ: 70.000. Sample Size: 8,482,451
Small Sample
Next CQ: 70.000. Sample Size: 879,698
Predicting...
NextCQ: 99.368 >=90, so check is needed
Next CQ: 90.000
Sample Size: 15,970,282

Next CQ: 67.858. Sample Size: 8,335,423
Next CQ: 78.767. Sample Size: 10,830,226
Next CQ: 82.898. Sample Size: 15,056,264
Next CQ: 80.392. Sample Size: 13,027,163
Next CQ: 79.621. Sample Size: 12,098,874

Exit Condition: 1.000 % reached ! yahoo !
Tries : 6


Final CQ: 79.621
Total Time For Predicition: 00:17:31

Total Time (all operations): 00:17:32

Finished

************************************************** ********

The video avs

LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\MPEG2Dec3.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\blockbuster.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\Convolution3DYV12.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\GripFit_YV12.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\undot.dll")
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\DctFilter.dll")
#
AviSource("C:my_source.avi",false)
ConvertToYV12()
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(352, 240, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()
AssumeFPS(23.976)
LoadPlugin("C:\My Documents\Tools\VCD-Tools\KVCD\AviSynth 2.5\filters25\Sampler-2.5.dll")
oldfps = framerate
interval = round((FrameCount/24)/59.940)/10
nFrames = round(24)
SelectRangeEvery( (round(framecount/interval)),nFrames)

************************************************** ***********

This video file was 23.976 fps I didn't have to add the AssumeFPS(23.976, true) line to it. Could that be the problem ?

I appreciate all the help you have given me.
Reply With Quote
  #17  
11-21-2003, 10:02 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by EvilDave
This video file was 23.976 fps I didn't have to add the AssumeFPS(23.976, true) line to it. Could that be the problem ?
Yeah. I also wondered about that the last time but I assumed that this line was always added by Tok.

Does your problematic movie have a non standard framerate ?
Reply With Quote
  #18  
11-21-2003, 02:21 PM
EvilDave EvilDave is offline
Free Member
 
Join Date: Sep 2003
Location: US
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
The problem file is 25 fps. If I dont put that line in tok wont predict the right cq. Right ? How else would you do it ? I'm going to do a defrag tonight my pc needs it. Maybe that will fix things.....
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Ping-pong prediction vs Long-short prediction Abond Avisynth Scripting 136 07-05-2005 02:13 PM
Bitrates: Filesize way too big? Jellygoose Video Encoding and Conversion 12 09-12-2003 08:34 AM
SKVCD filesize prediction Wizzkid007 Avisynth Scripting 2 09-07-2003 01:50 PM
KDVD: Filesize prediction assistance? trillium Video Encoding and Conversion 1 07-01-2003 09:31 AM
Avisynth: predicting the filesize miksmith Avisynth Scripting 16 12-05-2002 08:08 PM

Thread Tools



 
All times are GMT -5. The time now is 08:51 AM  —  vBulletin Jelsoft Enterprises Ltd