Quantcast No Audio Decompressor Could be Found to Decompress the Source Audio Format? - digitalFAQ.com Forums [Archives]
  #1  
10-29-2003, 03:42 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
I'm trying to follow black prince's guide to converting divx to kvcd (http://www.kvcd.net/forum/viewtopic....avi+conversion), but I'm having some trouble with virtualdub. When I try to save the file as a .wav, I get the error message "no audio decompressor could be found to decompress the source audio format."

I just went and installed the divx codecs (5.05) which allowed me to open the file, but now I have this new error. Any help is appreciated, and tia. Heres file info from vd:

480x360, 29.970 fps
188177 frames
DivX Pro 5.0.5 Codec
759 key frames
2239/12459/29229 min/avg/max key frame size
8/3218/45262 delta frame size
781 kbps

44100Hz
2 channel stereo
Compression "Unknown (tag 0055)"
Layout 340 chunks
Length 100218618 samples (Is this the length in seconds I'm guessing?)
532/554/7982 frame size
128 kbps 4.15% overhead

Thanks again.

Bah, problem fixed itself. Never underestimate a reboot. I'll let you know if I run into any more idiot problems.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-29-2003, 04:21 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
You missed the appropriate audio codec for this avi. Probably an ogg audio format. To be sure you can use tolsl like Gspot to see what are the codec needed.
Reply With Quote
  #3  
10-29-2003, 04:29 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the quick reply.
Reply With Quote
  #4  
10-29-2003, 04:31 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
You probably used "Direct Copy" and not "Full processing" for the audio stream in Vdub and so, even if the extension is "wav", the content isn't at all a wav.

You must select "full processing mode" and then, in compression, select "no compression" before to do "save the wav".
Reply With Quote
  #5  
10-29-2003, 04:50 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks again for responding so fast. I thought I had the problem figured out so I edited my post, but not before you saw it. :P

I checked out the settings in vd, and both options you mentioned were selected. Even tried converting it again and got the same result, I'm pretty sure I'm doing it right, but not conviced. heheh.

See, when I tried to open the wav to play it, I get a message telling me I needed another codec for Mp3 acm. So I was thinking that would be the solution. But now that you mention it, I'm thinking I shouldn't need some special codec to open a simple wav file.

Now I'm trying to figure out where I should go from here, I guess back to vd to make a real wav file.

Hmm... I'm back to the original error again. Now I'm getting it when I try to play the file in vd. I guess I'm gonna reboot again. I should be able to play the sound in vd, right? ugh, going to reboot...
Reply With Quote
  #6  
10-29-2003, 05:00 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Still getting the "No audio decompressor could be found..." error when trying to save as wav. Ugh, I don't get this at all, it was working before, now I'm taking steps backwards? The sound on the video plays fine, so how could this be? Gonna go back and check out gspot.
Reply With Quote
  #7  
10-29-2003, 05:04 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
For audio it says "0x0055(MP3) ID'd as MPEG-1 Layer 3" "Codec is installed."
Reply With Quote
  #8  
10-29-2003, 05:18 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Ok, your solution worked. I just downloaded another codec so it shows 2 compatible and so far no errors in vd. Thanks for your help.
Reply With Quote
  #9  
10-29-2003, 05:27 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Note: a valid wav file for a 1h30 movie takes near 1 Gigabytes !

But I see that now all is okay. Good luck.
Reply With Quote
  #10  
10-29-2003, 07:11 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
1.03 gig even. That's ok, though, I have lots of room on my hard drive.

I've run into another problem. When I start ToK with the recommended script, it starts a loop of opening and closing a program. I think it's tmpg but I can't really tell because it disappears so fast. Anyone know what might be wrong here?

Thanks for all your help, Dialhot. You've helped me alot.
Reply With Quote
  #11  
10-29-2003, 07:37 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
You surely had a problem in your script; open it directly in wmp or go to the video tab of tok to see a preview and check if there is an error reported.
Reply With Quote
  #12  
10-29-2003, 07:58 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
It says "there is no function called LegalClip()"
Reply With Quote
  #13  
10-29-2003, 08:21 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Wich version of avisynth ?

Did you load all the plugins corresponding to the filter you have in your script or did you just install avisynth ?

Plugins are here :

http://www.avisynth.org/~warpenterprises/
Reply With Quote
  #14  
10-29-2003, 08:42 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
I'm using 2.08 as it was recommended in the thread, and the script I'm using is this one:

LegalClip()

unfilter(50,50)
GripCrop( X, Y )
GripSize(resizer="BicubicResize")
STMedianFilter(8, 32, 0, 0, 8, 32)
# SpaceDust() # Optional - for some "not so clean" DVDs.
temporalsmoother(1,2)
mergechroma(blur(1.50))
mergeluma(blur(0.2))
# Convolution3d or DCTFilter for extreme worse cases.
GripBorders()
LegalClip()

That site doesn't list the function LegalClip() as part of any of those packages, I'm gonna try to figure out what I need to get that to work.

Ok, I got the filters, starting to get the hang of it, thanks. How do I determine what would be a good setting for gripcrop?
Reply With Quote
  #15  
10-29-2003, 09:13 PM
royalewitcheez royalewitcheez is offline
Free Member
 
Join Date: Oct 2003
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Also, I still have a problem with ToK. When I click the start button, it just opens and closes TMPGEnc over and over again. I can't find any info on how to fix this anywhere.

The video is fine now that I have the right filters in, though. I just don't know what size to set gripcrop at.
Reply With Quote
  #16  
10-29-2003, 09:31 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Without the size, no valid script !

No need to go to tok until the script do not go under wmp.

Use Moviestacker for the value to put into gripcrop.
(see the forum with the same name)
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Avisynth: No suitable decompressor could be found. (Error=80040255) scrappy Avisynth Scripting 3 10-10-2005 03:09 AM
BBMpeg: Found two audio frame headers oxycotton420 Video Encoding and Conversion 13 07-10-2004 07:49 PM
Avi Source: Could not decompress frame 0 daemon Conversão e Codificação de Vídeo (Português) 2 05-22-2004 03:34 PM
Couldn't locate decompressor for format 'YV12' (unknown) ? latsilva Conversão e Codificação de Vídeo (Português) 1 04-26-2004 06:50 AM
KVCD, avisynth - decompress the audio? samot4 Video Encoding and Conversion 0 10-07-2003 06:51 AM

Thread Tools



 
All times are GMT -5. The time now is 03:42 PM  —  vBulletin © Jelsoft Enterprises Ltd