digitalFAQ.com Forums [Archives]

digitalFAQ.com Forums [Archives] (http://www.digitalfaq.com/archives/)
-   Video Encoding and Conversion (http://www.digitalfaq.com/archives/encode/)
-   -   Audio out of sync when muxed with 3:2 pulldown MPEG-1 (http://www.digitalfaq.com/archives/encode/653-audio-sync-muxed.html)

gvarney 07-17-2002 11:03 AM

Audio out of sync when muxed with 3:2 pulldown MPEG-1
 
Hi,
In reading another thread Kwag noted that pulldown.exe does indeed work on MPEG-1 video streams. So, since my Apex 1100W doesn't like 24fps MPEG-1 I tried it. It *does* work, no more skipping and audio pauses :D However, now I have a problem with the audio being out of synch, or even the wrong "rate".

After I pulldown the MPEG-1 video stream and mux it with the audio (just the mpa that DVD2AVI created) it is out of synch immediately, and may be more so as the movie plays. As a test, I tried (using bbMPEG for this) muxing the same audio with the original MPEG-1 that I had encoded with TMPGEnc, audio was in synch. The original and the pulled-down MPEG files are exactly the same size, of course, but the latter appears as being 29.97fps. The original movie was a capture that was IVTCed when encoded in TMPGEnc.

How to I go about fixing the audio so it will match up with the pulled-down video? I have messed with setting up TMPGEnc to 30fps and encoding audio only to get a new mp2 file, and also the same with 24fps. The size and frames are the same, so not sure that makes any difference. Not home to run test clips anyway.

From one challenge to another with this stuff :roll:

Thanks,
Geoff

kwag 07-17-2002 12:42 PM

Re: Audio out of synch when muxed with 3:2 pulldown(ed) MPEG
 
Quote:

Originally Posted by gvarney
Hi,
In reading another thread Kwag noted that pulldown.exe does indeed work on MPEG-1 video streams. So, since my Apex 1100W doesn't like 24fps MPEG-1 I tried it. It *does* work, no more skipping and audio pauses :D However, now I have a problem with the audio being out of synch, or even the wrong "rate".

After I pulldown the MPEG-1 video stream and mux it with the audio (just the mpa that DVD2AVI created) it is out of synch immediately, and may be more so as the movie plays. As a test, I tried (using bbMPEG for this) muxing the same audio with the original MPEG-1 that I had encoded with TMPGEnc, audio was in synch. The original and the pulled-down MPEG files are exactly the same size, of course, but the latter appears as being 29.97fps. The original movie was a capture that was IVTCed when encoded in TMPGEnc.

How to I go about fixing the audio so it will match up with the pulled-down video? I have messed with setting up TMPGEnc to 30fps and encoding audio only to get a new mp2 file, and also the same with 24fps. The size and frames are the same, so not sure that makes any difference. Not home to run test clips anyway.

From one challenge to another with this stuff :roll:

Thanks,
Geoff

Hi Geoff:

Give this a try:
Mux with BBmpeg, but instead of muxing as MPEG-1 VBR, mux as MPEG-2 VBR.
When you check MPEG-2, the option "pulldown" will not be grayed out anymore. Then select 3:2 in the pulldown.
Give that a shot.
That should keep everything in sync. 8)

-kwag

gvarney 07-18-2002 10:19 PM

Re: Audio out of synch when muxed with 3:2 pulldown(ed) MPEG
 
Quote:

Originally Posted by kwag

Hi Geoff:

Give this a try:
Mux with BBmpeg, but instead of muxing as MPEG-1 VBR, mux as MPEG-2 VBR.
When you check MPEG-2, the option "pulldown" will not be grayed out anymore. Then select 3:2 in the pulldown.
Give that a shot.
That should keep everything in sync. 8)

-kwag

Well, that worked for the synch (mux as SVCD, not MPEG-2), except now when I burn the CD as SVCD the video slows down periodically, every couple of seconds, but audio is unaffected. Burning as VCD doesn't play at all. Oh well, I guess maybe there really isn't a way around this with the Apex, but I was hoping.... Back to 30fps, I guess :(

Thanks,
Geoff

Dano 07-25-2003 09:51 AM

Hooray
 
Kwag you are awesome. I never knew that you could add pulldown using BBMpeg, I just thought that dialog box was to specify what type of pulldown was in your mpeg stream. Anyways, to make a long story short I have been doing mpeg-2 encodes and anything over 90 minutes I would do a 2 cd encode since mpeg-2 does indeed not compress as well as mpeg-1 at low bitrates. So I just did a test encode mpeg-1 at 23.976 and muxed as SVCD in BBMpeg (the irony is I have been using this all along but using dopulldown.exe) and checked 2:3 pulldown (not 3:2 pulldown like you said, maybe a typo?) and burnt it in Nero and it plays flawlessly on my Apex AD-5131. I had tried adding a pulldown flag to mpeg-1 in the past but gave up when BBMpeg did not detect it when using Auto under the dialog box. This really is a big deal to me because the fact that I can now do high quality 1 cd encodes is just so sweet and I'm sure many others will feel the same way.
:D

-Dano


All times are GMT -5. The time now is 07:03 AM  —  vBulletin Jelsoft Enterprises Ltd

Site design, images and content © 2002-2022 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2022 Jelsoft Enterprises Ltd.