Quantcast MovieStacker: AVS Script Making Video in TMPGEnc Incorrect - digitalFAQ.com Forums [Archives]
  #1  
11-27-2003, 09:47 AM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
Hi,

Ive been using Red-M's excellent KVCD guide to make my first kvcd. However, once I make my .avs script in MovieStacker and then load it into TMPGEnc, the image has a sort of grey filter over it, and is all distorted.

Heres a screenshot of how its coming out



Heres my .avs script (using KVCD_LBR presets)

Code:
LoadPlugin("C:\Program Files\MovieStacker\Filters\MPEG2Dec.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\GripFit_preview.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\BlockBuster.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\LegalClip.dll")

Mpeg2Source("C:\Documents and Settings\Lee Purches\My Documents\KVCD\DVD Rips\Star Wars 2\Star Wars 2.d2v")
LegalClip()
GripCrop(352, 288, overscan=1)
GripSize(resizer="BilinearResize")
TemporalSmoother(1, 2)
MergeChroma(blur(1.58))
MergeLuma(blur(0.2))
BlockBuster(method="noise", detail_max=7, variance=0.8, seed=1)
GripBorders()
LegalClip()
Any ideas people?

Thanks in advance,
Lee.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
11-27-2003, 09:54 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Go in "Environnemental Settings" of tmgenc, tab "VFAPI". Uncheck "Direct Show Multimedia File". And tell me what happens.
Reply With Quote
  #3  
11-27-2003, 09:58 AM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
Stays the same

Lee.
Reply With Quote
  #4  
11-27-2003, 10:26 AM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
Think ive sorted it out. We shall see. Installed avisynth 2.5 instead of 2.0

Will get back and see how it goes!

Lee.
Reply With Quote
  #5  
11-27-2003, 10:32 AM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
Ok, that doesnt work either.

With DirectShow off i just get a thin line of interference instead of an image.

With it on i just get a video which says the following message:

'Plugin C:\Program Files\Moviestacker\Filters\MPEG2Dec.dll in not an avisynth 2.5 plugin.'

Gonna have a go with different filters, see what happens.

Lee.
Reply With Quote
  #6  
11-27-2003, 10:44 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
The new message you obtain is normal because as you guessed, changing avs version involve to change also all the plugins.

It's possible your problem comes with the usage of MPEG2DEC.dll and not MPEG2DEC3.dll

BTW, you're problem will perhaps be solved when you will have the last release of MPEG2DEC3 plugin for avs2.5
Reply With Quote
  #7  
11-27-2003, 01:56 PM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
Oh im really stumped by this

Ive tried the latest plugs, 2.5 version, etc...

Whatever I do I cannot get it to work, tried different avisynth versions (2.5.X and 2.0.X).

Ah well, another project failed.

Thanks for your help anyway.

Lee.
Reply With Quote
  #8  
11-28-2003, 02:16 AM
dazedconfused dazedconfused is offline
Free Member
 
Join Date: Nov 2002
Posts: 316
Thanks: 0
Thanked 0 Times in 0 Posts
Don't give up so easily sleeky! KVCD-ing is very easy once you get the hang of it, and believe it or not, you're on the right track.

A couple simple things to ask since this is your first KVCD:

1) Are you sure that the "video source" you are trying to open in TMPG when you click on the "browse" button is actually your .AVS script, and_NOT_your .d2v file? Because that strange grey screen of dots is what you would normally see if you try opening a .d2v file directly in TMPG. Also look at the screenshots in Sansgrip's old sticky thread about "Recommended TMPG Settings"(or something like that) over in the TMPG Forum to see if you've got the VFAPI Plugin settings configured ideally for .d2v sources. Also, the pathname to your .d2v file is way too long!...this is not recommended as it can lead to problems (maybe not in this circumstance, but certainly later with CQMatic)...so shorten it up.

2) Which version of DVD2AVI were you using with avs 2.0.x? With 2.0.x, you need to use version 1.76. The grey pixelated screen you saw in TMPG can sometimes be caused by specifying an incorrect iDCT_Algorithm in your .d2v project file. For example, if anyone opens a .d2v file with notepad and changes the iDCT_Algorithm line to some unrecognized number, they'll see the same grey screen as you when they view their .AVS file. So perhaps something strange was going on because of the particular version of dvd2avi you are/were using.


I hope one of those things might help you along your way. Don't give up pal....we were all new once.

-d&c
Reply With Quote
  #9  
12-02-2003, 09:48 AM
sleeky sleeky is offline
Free Member
 
Join Date: Nov 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to sleeky
I think ive just had a brainwave, i encoded the .dv2 file with DVD2AVI 1.76 but at the time i had Avisynth 2.5 installed.

Lets give it another shot and hopefully thats it

Lee.
Reply With Quote
  #10  
12-02-2003, 12:02 PM
Abond Abond is offline
Free Member
 
Join Date: Mar 2003
Posts: 243
Thanks: 0
Thanked 0 Times in 0 Posts
Hi, sleeky
Try to open the avs in VirtualDub or a media player. At least this will show you were it failed - in AviSynth or in TMPG.
Reply With Quote
  #11  
02-14-2004, 04:07 PM
ezysk ezysk is offline
Free Member
 
Join Date: Apr 2003
Posts: 197
Thanks: 0
Thanked 0 Times in 0 Posts
Does anybody know of a another option besides Movie Stacker that can make avs scripts compatible with TEMPGecn? I'm not even sure anymore if I can ever use updated AVS versions like 2.5.4 for making kvcd movies.
Reply With Quote
  #12  
02-14-2004, 04:52 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Hi ezysk

I don't understand what you are asking

all you have to do is copy the optimal script in notepad and then open moviestacker and ignore the error ,get your resized line and save as avs file and everything should work perfect as long as you have all the filters
Reply With Quote
  #13  
02-20-2004, 01:22 AM
caish5 caish5 is offline
Free Member
 
Join Date: Nov 2002
Location: Brisbane .AU
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to caish5
I haven't done a KVCD in about 6 months. Well anyway I just reinstalled everything again to do a new one and now i have this problem too.
The problem is the same when you open the .AVS with virtualdub, so I guess the problem is with AVIsynth.

Sleeky - did you find a solution
Reply With Quote
  #14  
02-20-2004, 01:34 AM
caish5 caish5 is offline
Free Member
 
Join Date: Nov 2002
Location: Brisbane .AU
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to caish5
Actually i just fixed it, here is the scrript...
Quote:
LoadPlugin("C:\Program Files\MovieStacker\Filters\MPEG2Dec2.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\STMedianFilter.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\UnFilter.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\LegalClip.dll")
LoadPlugin("C:\Program Files\MovieStacker\Filters\Sampler.dll")

Mpeg2Source("C:\Documents and Settings\Andy\My Documents\human\vts_01.d2v")
LegalClip()
BilinearResize(496, 398, 1, 0, 718, 576)
STMedianFilter(10, 50, 0, 0, 10, 50)
UnFilter(50, 50)
TemporalSmoother(1, 2)
MergeChroma(blur(1.5)
MergeLuma(blur(0.3))
AddBorders(16, 89, 16, 89)
LegalClip()
It was changing to mpeg2dec2 that fixed it, but don't try mpeg2dec3 because that causes a whole new error!!
Reply With Quote
  #15  
02-20-2004, 08:33 AM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
HI this thread is getting confusing ,are you guys trying to use avisynth 2.52 or higher or still using version 2.08.

mpeg2dec3 is used for version 2.52(and higher) but your script is for version 2.08
Reply With Quote
  #16  
02-20-2004, 08:37 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
he uses mpeg2dec2
Reply With Quote
  #17  
02-20-2004, 08:58 AM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Thats my point

Quote:
It was changing to mpeg2dec2 that fixed it, but don't try mpeg2dec3 because that causes a whole new error!!
He puts this line in which is saying to me anyway that he doesn't know the difference between the 2 versions

Thats why i said this thread is getting confusing
Reply With Quote
  #18  
02-20-2004, 02:00 PM
caish5 caish5 is offline
Free Member
 
Join Date: Nov 2002
Location: Brisbane .AU
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to caish5
Oh, so thats what that does!
and yeah I'm using 2.08
Reply With Quote
  #19  
02-20-2004, 02:15 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
hi caish5,have you tried updating to the newer version of avisynth.

It gives way better results and i doubt there will be anymore updates to anything to do with 2.08(scripts and so forth)
Reply With Quote
  #20  
02-21-2004, 01:32 AM
caish5 caish5 is offline
Free Member
 
Join Date: Nov 2002
Location: Brisbane .AU
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to caish5
Well i haven't yet. But i might just give it a go with my next kvcd. I did however think that the quality as is was fine for 528x576 res squeezed on a single CD. Perhaps it's time for a trip to blockbuster for some experimentation.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
KDVD: Problem making a script for this encode TBO Video Encoding and Conversion 4 03-16-2006 09:46 AM
Avisynth: Need help making script!!! kvcdexplorer Avisynth Scripting 17 06-16-2005 11:21 PM
Cuttermaran software for making cuts to video? jorel Video Encoding and Conversion 15 06-25-2004 09:34 AM
Making a video/audio website - ideas? glent2k3 Off-topic Lounge 0 03-25-2004 04:18 PM
Avisynth: Incorrect screen format using MA script!! mistermickster Avisynth Scripting 12 12-03-2003 10:00 AM

Thread Tools



 
All times are GMT -5. The time now is 07:05 PM  —  vBulletin Jelsoft Enterprises Ltd