Quantcast Audio Out of Sync Converting MPEG to KVCD? - digitalFAQ.com Forums [Archives]
  #1  
01-22-2004, 05:10 PM
jim620 jim620 is offline
Free Member
 
Join Date: Dec 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
I am trying to convert an MPG to KVCD but the audio is out of sync. I have tried to demux the audio out of the original MPG, using Goldwave to extract the audio to wav-->mp2, and using the original MPG as the audio source in TMPGenc while encoding. Any ideas? Here's my script.


LoadPlugin("e:\kvcd\filters\atc.dll")
LoadPlugin("e:\kvcd\filters\blockbuster.dll")
LoadPlugin("e:\kvcd\filters\convolution3dyv12.dll" )
LoadPlugin("e:\kvcd\filters\dctfilter.dll")
LoadPlugin("e:\kvcd\filters\deen.dll")
LoadPlugin("e:\kvcd\filters\MPEG2Dec3.dll")
LoadPlugin("e:\kvcd\filters\Grip.dll")
LoadPlugin("e:\kvcd\filters\undot.dll")
LoadPlugin("e:\kvcd\filters\mpegdecoder.dll")



directshowsource("e:\kvcd\movie.mpg").killaudio()
converttoyv12()
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(352, 240, source_anamorphic=false, dest_anamorphic=false )
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
01-22-2004, 05:13 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Convert using tmpgenc the mpg in huffyuvavi. Do not use virtualdub for that.
The avi shuold be in synch and you can use it as source in a script.
Reply With Quote
  #3  
01-22-2004, 05:20 PM
jim620 jim620 is offline
Free Member
 
Join Date: Dec 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks will give it a try. It's kinda strange that the demux audio from the original MPG file would not be in sync with the KVCD m1v file.
Reply With Quote
  #4  
01-22-2004, 05:35 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
I had that a lot when I used to frameserve mpeg1 from vdub to tmpgenc and I never find the reason.
Reply With Quote
  #5  
01-22-2004, 05:41 PM
incredible incredible is offline
Free Member
 
Join Date: May 2003
Location: Germany
Posts: 3,189
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to incredible
Maybe you did already tried that, but as Directshowsource does not seem to be that intelligend (I don't know how to explain in other words) you should add a fps=25 or something like that as mybe that import command confuses a bit the fps of the source?!
Reply With Quote
  #6  
01-22-2004, 05:44 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by incredible
you should add a fps=25 or something like that as mybe that import command confuses a bit the fps of the source?!
According to the resolution used it should be 23.976 I guess. But that is a good suggestion you had incredible !
Reply With Quote
  #7  
01-23-2004, 10:20 AM
jim620 jim620 is offline
Free Member
 
Join Date: Dec 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Haven't been able to try the Huffyu yet but I'll also try and add the fps command and see if that works. By the way it is 23.976fps.
Reply With Quote
  #8  
01-23-2004, 11:32 AM
incredible incredible is offline
Free Member
 
Join Date: May 2003
Location: Germany
Posts: 3,189
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to incredible
First do try the FPS Parameter in Directshowsource()!

DirectShowSource("e:\kvcd\movie.mpg", fps=23.976)

Maybe its just that what helps!

And if not, do still the way to demux first, and load the m1v with directshowsource where the mp2 will be convertet to mp2 again (if other Audiobitrate or Samplerate is needed) using besweet
Reply With Quote
  #9  
01-26-2004, 12:37 PM
jim620 jim620 is offline
Free Member
 
Join Date: Dec 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Adding the line fps=29.97 did the trick. Audio in synch with video. Thanks for the help.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio out of sync when muxed with 3:2 pulldown MPEG-1 gvarney Video Encoding and Conversion 3 07-25-2003 09:51 AM
KVCD: converting 23fps to 29.976fps causes audio sync errors? pixeldotz Video Encoding and Conversion 2 05-18-2003 09:54 AM
Guide for converting Mpg/mpeg to kvcd? whhaatt Video Encoding and Conversion 3 03-14-2003 07:58 AM
MPEG Mediator: Audio sync problems Yoda Video Encoding and Conversion 17 08-19-2002 02:56 PM
MPEG Mediator: DVD audio/video out of sync kwag Video Encoding and Conversion 13 07-30-2002 12:56 PM

Thread Tools



 
All times are GMT -5. The time now is 09:05 PM  —  vBulletin Jelsoft Enterprises Ltd