Quantcast MencodeME: a Newbie Oriented GUI - 0.23 is Out! - Page 14 - digitalFAQ.com Forums [Archives]
  #261  
04-25-2004, 11:22 AM
black prince black prince is offline
Free Member
 
Join Date: Jul 2002
Posts: 1,224
Thanks: 0
Thanked 0 Times in 0 Posts
@Abond,

Abond wrote:
Quote:
Not always. It seems these errors are conected with Notch matrix. If you use the default matrix there aren't such errors. Maybe this is the way in which mencoder calculate the dct coefficients regarding the matrix. Well, I can be completely wrong here...
Good idea!! Notch-Matrix was fine tuned for Tmpgenc, but MEncoder
may not respond the same way, just as the avisynth avs motion
adaptive script is effecting MEncoder's vbitrate. My file size are
almost perfect when I don't use MA. Now what is MEncoder default
matrix Guess I'll have to look around Oh! DRPEnc has
the default matric and notch-matrix, stay tuned


-BP
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #262  
04-25-2004, 11:33 AM
Abond Abond is offline
Free Member
 
Join Date: Mar 2003
Posts: 243
Thanks: 0
Thanked 0 Times in 0 Posts
Huh, I have read in the man_page something as H.263 quantizers are default, there might be a default matrix, but I have no idea which.
  #263  
04-25-2004, 11:40 AM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Abond
Quote:
Originally Posted by vmesquita
MEncoder always shows this messages when encoding mpeg1... I have no idea what it means.
Not always. It seems these errors are conected with Notch matrix.
Nope. They're connected to the size of the VBV buffer on MPEG-1 encodes.
Try selecting a KSVCD preset, and encode at the same resolution you tried before, and you shouldn't see the errors.
Try compiling from the command line, with a larger VBV value, if you want MPEG-1.

@vmesquta,

I succesfully encoded a movie (The Big Hit) with Mencode-ME 0.22 MPEG-2 @528x480, and the result is just great
Encoded directly from VOB, using "DVD" filter option in your program.

I'm encoding the audio now. When I get done, I'll post a little sample clip.

-kwag
  #264  
04-25-2004, 11:47 AM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
I'll make the VBV buffer selection automatic for the next release, this should end this issues.

@kwag
It's great to hear that it's working for you Please make sure you used Field Operation: None and Framerate 23.976, otherwise there will be synch issues.
  #265  
04-25-2004, 12:14 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
I'll make the VBV buffer selection automatic for the next release, this should end this issues.

Quote:

@kwag
It's great to hear that it's working for you Please make sure you used Field Operation: None and Framerate 23.976, otherwise there will be synch issues.
Already found that out the hard way
Thank God I had only encoded a small clip, and not the complete movie

-kwag
  #266  
04-25-2004, 01:23 PM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
When encoding from avi, combo no filter, half vertical (576-->28 results.
When trying from avi, combo AVI, mencodeme hang up. (Error mesagge in log, error stack file create.
When previewing from avi, combo AVI, image not centered, but left sliced to much, in high resolutions only a stretch column of video is showed.
  #267  
04-25-2004, 01:36 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
@Prodater64
Could you please explain it better... I didn't understood your post very well.
  #268  
04-25-2004, 01:48 PM
black prince black prince is offline
Free Member
 
Join Date: Jul 2002
Posts: 1,224
Thanks: 0
Thanked 0 Times in 0 Posts
@vmesquita,

black prince wrote:
Quote:
Good idea!! Notch-Matrix was fine tuned for Tmpgenc, but MEncoder
may not respond the same way, just as the avisynth avs motion
adaptive script is effecting MEncoder's vbitrate. My file size are
almost perfect when I don't use MA. Now what is MEncoder default
matrix Guess I'll have to look around Oh! DRPEnc has
the default matric and notch-matrix, stay tuned
This was completely wrong I overlooked this message from
MEncoder as follows:

[mpeg1video@ 0x9403380] MPEG1/2 doesnt support 2997/125 fps, there may be AV sync issues

I changed temp.conf -ofps from 23.976 to 24 and the message disappeared,
but a new message appeared many times 1 dup frame found.
Is it possible MEncoder has no support for MPEG-1 23.976 or 23.970 fps
at resolution 352x240. Also, using Notch-Matrix improved the picture
quality and with MEncoder's default matrix, it was worse. I'm begining to believe
MEncoder can not successfully encode mpeg-1, low resolutions, videos
with frame rates other than 25fps (PAL). Oh well, it's back to Tmpgenc and
CQTester for me

-BP
  #269  
04-25-2004, 02:17 PM
audioslave audioslave is offline
Free Member
 
Join Date: Mar 2003
Location: Sweden
Posts: 725
Thanks: 0
Thanked 0 Times in 0 Posts
I also have problems with 2 pass encoding. Only 1st pass is encoded . Here's my log:
Code:
Mencoder.exe -include temp.conf -lavcopts vbitrate=990:vpass=1 "D:\DVDRip\Gothika - Slicer.avi" -o "D:\DVDRip\Gothika - Slicer.mpv" MEncoder dev-CVS-040423-00:19-3.3.1 (C) 2000-2004 MPlayer Team
 
 CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1676 MHz (Family: 6, Stepping: 2)
Can't open '/cygdrive/c/.mplayer/codecs.conf': No such file or directory
 Detected cache-line size is 64 bytes
Can't open 'mplayer//codecs.conf': No such file or directory
 CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
File not found: 'frameno.avi'
 Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
Failed to open frameno.avi
 
: No such file or directory
 Reading /cygdrive/c/.mplayer/codecs.conf: Reading mplayer//codecs.conf: Using built-in default codecs.conf.
 Reading config file /cygdrive/c/.mplayer/mencoderReading config file temp.conf
 font: can't open file: /cygdrive/c/.mplayer/font/font.desc
 font: can't open file: /usr/local/share/mplayer/font/font.desc
 success: format: 0  data: 0x0 - 0x14600
 AVI file format detected.
 AVI_NI: No audio stream found -> no sound.
[mpeg2video @ 0x940380]MPEG1/2 doesnt support 2997/125 fps, there may be AV sync issues
 VIDEO:  [AVIS]  480x480  16bpp  23.976 fps    0.8 kbps ( 0.1 kbyte/s)
 [V] filefmt:3  fourcc:0x53495641  size:480x480  fps:23.98  ftime:=0.0417
 input fps will be interpreted as 23.98 instead
 Opening video filter: [expand osd=1]
 Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
 ==========================================================================
 Opening video decoder: [vfw] Win32/VfW video codecs
 Loaded DLL driver ffvfw
 VDec: vo config request - 480 x 480 (preferred csp: Packed YUY2)
 [PP] Using codec's postprocessing, max q = 9.
 VDec: using Planar YV12 as output csp (no 0)
 Movie-Aspect is undefined - no prescaling applied.
 videocodec: libavcodec (480x480 fourcc=3267706d [mpg2])
 Selected video codec: [makeavis] vfm:vfw (FFvfw makeavis)
 ==========================================================================
 Writing AVI header...
New_Face failed. Maybe the font path is wrong.
 Pos:   0.0s      1f ( 0%)   0fps Trem:   0min   0mb  A-V:0.000 [0:0]Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
 Pos:   0.1s      3f ( 0%)   0fps Trem:   0min   0mb  A-V:0.000 [0:0][mpeg2video @ 0x940380]rc buffer underflow
 Pos: 118.1s   2832f (99%)   6fps Trem:   0min  11mb  A-V:0.000 [830:0] 
 Writing AVI index...
 Fixing AVI header...
 
 Video stream:  830.523 kbit/s  (103815 bps)  size: 12262476 bytes  118.118 secs  2832 frames
Am I missing something
__________________
AudioSlave
  #270  
04-25-2004, 02:46 PM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
@Prodater64
Could you please explain it better... I didn't understood your post very well.
I encoded a mpeg1 from avi file. In combo selection box I selected "NO FILTER". Final resolution was 528*288, but I had select 528*576.
After this I tryed change the combo selection box to AVI. (I suppose it should be when I begin from an avi file). When press encode, mencodeme hang up (it do nothing, just graying encode and preview buttons). Mesagge error in log, related to stack... An error satck file is created in working folder.
If I want to preview with this last settings, image is not centered, but left sliced to much, in high resolutions only a stretch column of video is showed. (like a column of, perhaps, 64 pixels of video at the left, remaining preview screen black)

See you.
  #271  
04-25-2004, 03:07 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Hi i am having the same problem as Audioslave had 2 pass checked but after 1st pass it just stopped and no 2nd pass
  #272  
04-25-2004, 03:53 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
@bigggt and audioslave
Maybe preview srewed-up 2pass, I have to check.

@Prodater64
By "Final resolution was 528*288", you probably mean the resized resolution, right? This is probably correct for a 1:2.35 movie. Actually changing the combo selection to AVI/No filters only change the filters being applied, not the resize process at all.
Are you sure you were not using cropping? Because the crop values does not work in the same way avisynth does. To crop from 720x480 to 704x480, you would have to use Crop width=704 height=0 or =480. Please check this.
Also this configuration is making mencoder dies ("the stackdump"), but this must be related to the video resolution ("the near 64 pixels column).
Please make sure your crop settings are ok.
  #273  
04-25-2004, 05:06 PM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
@Prodater64
I understand your idea, but unfortunatelly, I have no control over the frames being shown by mplayer. I just launch the player and that's it.
You can!
If you put near or under preview button a text box or other selection box where we can select or write seeking position in seconds (I think are seconds), in such a form that it appends at your temp.conf:

seek (int) val [(int) type=1]
(Seek to some place in the movie. Type 0 is a relative seek of +/- val seconds. Type 1 seek to val % in the movie.)

and follwing that, "pause" command.

The initial preview window will go to the seek position and pauses.
Now you can open another mencodeme instance (with others filters) and do the same.
Now you can compare both results.
-------------------------------------------------------------------------
mplayer accepts followings keyboard shorcuts (only most usefull mentioned)
Quote:
p or Space Bar: Pause/Continue.
q or ESC: Stop and Exit.
f: Toggle fullscreen/Windowed.
Righ Arrow/Left Arrow: 10 sec forward/backward.
UP Arrow/Down Arrow: 1 min forward/backward.
Scroll Up/Scroll Down: 10 min forward/backward.
  #274  
04-25-2004, 05:26 PM
Zyphon Zyphon is offline
Free Member
 
Join Date: Oct 2003
Location: London, England (UK)
Posts: 1,035
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
What's new in 0.22:
-=-=-=-=-=-=-=-=
- preview filters/crop options/resize using MPlayer throught a nice preview button
- Crop added. Now overscan is possible.
- Deinterlace via KernelDeint added
- Clear Log button
- MPEG1 crashing should be solved.
- command-line is saved as "encode.bat"
@vmesquita

Forgive this newb question but in the new 0.22 update log above where it says Deinterlace via KernalDeint. Does this mean MencoderME can now work with PAL Interlaced sources or is that still out of the question at this time
__________________
Regards.

Michael.
  #275  
04-25-2004, 08:50 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
@Prodater64
Thanks, looks like there's a way to implement then.I'll look into it.

@Zyphon
Yes you can input interlaced PAL/NTSC. And kerneldeint is a really great deinterlacer, the best I've ever seem,
  #276  
04-26-2004, 03:50 AM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
@Prodater64
Thanks, looks like there's a way to implement then.I'll look into it.
Also for previewing purposes (and only for that), maybe you could set preview button to append at temp.conf the command:

-aspect 4:3
  #277  
04-26-2004, 04:20 AM
incredible incredible is offline
Free Member
 
Join Date: May 2003
Location: Germany
Posts: 3,189
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to incredible
This Weekend I got still several issues when generating mencoder generated m2vs as DVDs using DVDlabPro latest beta.
Still "gop out of memory" issues and some bad errors which arent named by DVDlabs message window!

So I took my streams and did the whole authoring way using my old friend "MeastroDVD" using Multiple Audiochannels and so on Everythig works fine! No errors where dvdlab i.e. was pissed of.

And I thought the m2v got a bug! Investing many hours to inspect them --- btw the old final release of DVDlab also got those issues.

so lets stick on DVDauthor or MaestroDVD

@ VMesquita

Yep I wanted to give you some DVD sample Templates, they will come to you. I found out that the newest release did let me reach approx. 2500kbit instead of 2000kbit. - but that could be also that the several tested sources let there be a better quantisation?!
As suggested some pots above a change from lmin=1 to lmin=0.3 (or 0.1) gave me more possibility to get to higher HQ DVD avg bitrates.
  #278  
04-26-2004, 05:59 AM
Zyphon Zyphon is offline
Free Member
 
Join Date: Oct 2003
Location: London, England (UK)
Posts: 1,035
Thanks: 0
Thanked 0 Times in 0 Posts
@vmesquita

Yipee! thanks for the info vmesquita I can finally use my Interlaced DVD sources in this nice little GUI, im glad that kerneldeint can deal with my sources.

Thank you for all your hard work in making this tool and helping newbs like me to be able to use Mencoder.

Keep up the good work my friend.
__________________
Regards.

Michael.
  #279  
04-26-2004, 06:51 AM
fozzieb fozzieb is offline
Free Member
 
Join Date: Sep 2002
Location: Scotland
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to fozzieb
@vmesquita

Great release mate, the way things are going there will soon be a drink waiting for you in every major city in the world
  #280  
04-26-2004, 08:29 AM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
and in "smallvilles" too!
Closed Thread




Similar Threads
Thread Thread Starter Forum Replies Last Post
Avisynth: A newbie needs help with script eqlb02 Avisynth Scripting 6 01-29-2004 11:39 AM
Please help a newbie with not the right tool Rambytes Avisynth Scripting 4 08-02-2003 05:12 PM
Newbie! Was heisst AR und CQ? Repsac Video Konvertierung und Encodieren (Deutsch) 11 07-13-2003 06:57 AM
Newbie ptite kestion???? Evile-Death Conversion et d'Encodage de Vidéo (Français) 1 06-12-2003 01:07 AM
KVCD: What?...no newbie section? EightBall Off-topic Lounge 3 04-26-2002 03:02 PM

Thread Tools



 
All times are GMT -5. The time now is 12:29 AM  —  vBulletin © Jelsoft Enterprises Ltd