Quantcast Que Filtros AVIshynht 2.5 Usar para Esta Captura? - digitalFAQ.com Forums [Archives]
  #1  
05-17-2004, 12:10 PM
generador generador is offline
Free Member
 
Join Date: Jul 2003
Location: Euskadi
Posts: 449
Thanks: 0
Thanked 0 Times in 0 Posts
Hola!!

Resulta que me he dado cuanta que Mencode no trabaja con avishynt 2.08 asi que como no encuntro la .dll para poder trabajar en 2.5 con filtros 2.08 , me gustaria que me aconsejarais, es sobre la imagen que posteo, es una captura de tv y la señal de este canal no es muy buena, me gustaria saber que filtros version 2.5 usar para adecentarlo lo maximo posible.



a ver que se le puede hacer
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
05-17-2004, 12:26 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Hola generador,

Mira aqui: http://www.mplayerhq.hu/DOCS/man/es/manpage.html#OPCIONES%20DE%20CODIFICACI%D3N%20GENE RALES%20(SOLAMENTE%20MENCODER)

Y baja por ahi, hasta que llegues a la seccion de filtros (denoise3d)

-kwag
Reply With Quote
  #3  
05-17-2004, 01:10 PM
generador generador is offline
Free Member
 
Join Date: Jul 2003
Location: Euskadi
Posts: 449
Thanks: 0
Thanked 0 Times in 0 Posts
Hola Kwag.

Ya lo he leido y releido, per no se como aplicar los filtros
Code:
denoise3d[=luma:chroma:time]
He probado a editar en la carpeta donde tengo mencode los note pad, pero nada, laverdad que no se como aplicarlos....podeis ayudarme??
Reply With Quote
  #4  
05-17-2004, 01:17 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Hola generador,

Si usas MencodeME, notaras que el programa crea un archivo "temp.conf" y un "encode.bat", una vez le das a que empiece a codificar. Asi que simplemente, arrancas a codificar, y le das a "STOP", para que aborte el proceso.

Entonces editalos con "Notepad", y ahi puedes cambiar los parametros de los filtros. Una vez haces los cambios, simplemente corre el encode.bat"

-kwag
Reply With Quote
  #5  
05-17-2004, 01:38 PM
generador generador is offline
Free Member
 
Join Date: Jul 2003
Location: Euskadi
Posts: 449
Thanks: 0
Thanked 0 Times in 0 Posts
Que mala suerte tengo....

Resulta que hago lo que me indicas
Code:
of=rawvideo=1
ovc=lavc=1
nosound=1
sws=2
lavcopts=vcodec=mpeg2video:vrc_eq=tex:vmax_b_frames=2:vrc_maxrate=2500:aspect=1.3333:keyint=24:vrc_buf_size=917:preme=2:precmp=2:vstrict=-1:autoaspect=1:scplx_mask=0.3:vqblur=0:mbqmin=1:vqmin=1:mbqmin=1:lmin=1:intra_matrix=8,9,12,22,26,27,29,34,9,10,14,26,27,29,34,37,12,14,18,27,29,34,37,38,22,26,27,31,36,37,38,40,26,27,29,36,39,38,40,48,27,29,34,37,38,40,48,58,29,34,37,38,40,48,58,69,34,37,38,40,48,58,69,79:inter_matrix=16,18,20,22,24,26,28,30,18,20,22,24,26,28,30,32,20,22,24,26,28,30,32,34,22,24,26,30,32,32,34,36,24,26,28,32,34,34,36,38,26,28,30,32,34,36,38,40,28,30,32,34,36,38,42,42,30,32,34,36,38,40,42,44
denoise3d[=luma:chroma:time]
ofps=25
Lo guardo, ejecuto el encode.bat, se abre una ventana de comandos, y se cierra sola, y hay no pasa nada, despues le doy a convertir al mencodeME pero no utiliza ese filtro.

Este filtro lo tengo que descargar de algún sitio....no se como hacer que esto funcione......
Reply With Quote
  #6  
05-17-2004, 01:45 PM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Mira denoise3d[=luma:chroma:time]
Estas poniendo la linea tal y como esta en el manual
Tienes que ponerle valores a luma, chroma y a time
Code:
Este filtro intenta reducir el ruido de la imagen produciendo imágenes suavizadas y haciendo que las imágenes quietas sean realmente quietas (Esto de- bería mejorar la compresibilidad). Puede tener de 0 a 3 parámetros. Si omite un parámetros, se usará un valor razonable.
	luma
	dureza de la luminancia espacial (por de- fecto = 4)
	chroma
	dureza de crominancia espacial (por defecto = 3)
	time
	dureza temporal (por defecto = 6)
O sea, por ejemplo: denoise=4:5:6

-kwag
Reply With Quote
  #7  
05-17-2004, 01:52 PM
generador generador is offline
Free Member
 
Join Date: Jul 2003
Location: Euskadi
Posts: 449
Thanks: 0
Thanked 0 Times in 0 Posts
Gracias por tu paciencia.

Pero creo que tengo un problema con el Mplayer,
por que despues de hacer lo que me indicas,
ejecuto el Encode.bat y se cierra la ventana
cuando busca codecs de mplyer, eso meparece
entender, ademas fijandome en el Log del MEncodeME veo esto:

Code:
Source Width:352 Source Height:576 Aspect:1.000000

Mencoder.exe -include temp.conf -lavcopts vbitrate=1200:vpass=1 "I:\solovideo\FASLASOAVIS\pruebass.avi" -o "I:\solovideo\FASLASOAVIS\pruebass.mpv" MEncoder dev-CVS-040506-06:00-3.3.1 (C) 2000-2004 MPlayer Team
 
 CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1646 MHz (Family: 6, Stepping: 2)
 Detected cache-line size is 64 bytes
 CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
 Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
 
 Reading //.mplayer/codecs.conf: Reading mplayer//codecs.conf: Using built-in default codecs.conf.
Can't open '//.mplayer/codecs.conf': No such host or network path
Can't open 'mplayer//codecs.conf': No such file or directory
 Reading config file //.mplayer/mencoderReading config file temp.conf
File not found: 'frameno.avi'
 font: can't open file: //.mplayer/font/font.desc
Failed to open frameno.avi
 font: can't open file: /usr/local/share/mplayer/font/font.desc
: No such host or network path
 success: format: 0  data: 0x0 - 0x7800
 AVI file format detected.
 AVI_NI: No audio stream found -> no sound.
 VIDEO:  [AVIS]  352x576  16bpp  25.000 fps    0.8 kbps ( 0.1 kbyte/s)
 [V] filefmt:3  fourcc:0x53495641  size:352x576  fps:25.00  ftime:=0.0400
 Opening video filter: [expand osd=1]
 Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
 ==========================================================================
 Opening video decoder: [vfw] Win32/VfW video codecs
 Loaded DLL driver ffvfw
 VDec: vo config request - 352 x 576 (preferred csp: Packed YUY2)
 [PP] Using codec's postprocessing, max q = 9.
 VDec: using Planar YV12 as output csp (no 0)
 Movie-Aspect is undefined - no prescaling applied.
 videocodec: libavcodec (352x576 fourcc=3267706d [mpg2])
ICDecompressBegin failed: Error -100
 Selected video codec: [makeavis] vfm:vfw (FFvfw makeavis)
[mpeg2video @ 0x802070]rc buffer underflow
 ==========================================================================
 Writing AVI header...
 Pos:  15.8s    396f (39%) 151fps Trem:   0min   0mb  A-V:0.000 [87:0]
Ose aque mi gran problema igual esta hay,
por mas que releo el manual de Prodater no
veo que haya que bajar ningun codec extra
para el Mplayer.

Lo dicho, gracias por tu paciencia

EDITADO: He puesto el log completo, pero no se, el MencodeME me funciona bien, el problema esta cuando hago doble click sobre el encode.bat, que se esfuma la ventana de comandos y no puedo hacer nada, antes de esfumarse pone esto:


[/code]
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtros para Avisynth SonGil Conversão e Codificação de Vídeo (Português) 1 06-15-2004 07:29 AM
VMESQUITA/ D.I.K.O > ESTA NA HORA DE USAR !! MR.Maker Conversão e Codificação de Vídeo (Português) 8 05-17-2004 09:14 PM
Drivers para Captura de Video para NVIDIA GeForce 5600FX 128 FBC Conversão e Codificação de Vídeo (Português) 3 02-29-2004 03:19 AM
Ajuda para filtrar esta captura de VHS Soulman Conversão e Codificação de Vídeo (Português) 1 12-23-2003 03:37 PM
Vmesquita - está é para você ... grc Conversão e Codificação de Vídeo (Português) 3 08-11-2003 12:10 PM

Thread Tools



 
All times are GMT -5. The time now is 09:43 PM  —  vBulletin © Jelsoft Enterprises Ltd