Quantcast Problème de Son - digitalFAQ.com Forums [Archives]
  #1  
07-13-2004, 01:45 PM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Je n'arrive pas a trouver de solution a mon problème de décalage sur mon lecteur de salon, qui soit dit en passant, lit très bien le KVCD ...
Voici le problème ....
Je suis parti d'une source AVI en 25fps que je dois convertir en 23.976fps (Québec oblige)
Avec VirtualDub, j'ai converti le framerate vidéo (25 à 23.976), puis sauvegardé le son PCM uncompressed ...
J'ai essayé deux méthodes pour convertir le son ...
1) avec Besweet et le preset 25 to 23.976
2) avec Cool Edit
Les deux ont donnés de bons résultats, après vérification de la longueur des fichiers audio et vidéo, les temps sont identiques, et pas de décalage sur l'ordi ..
J'encode en MPEG avec Tsunami (avec le template KVCD), multiplexe a la sortie, j'écoute le vidéo sur l'ordi, pas de probèmes, pas de décalage ..
Quand je le fais jouer sur mon lecteur de salon, le décalage se fait progressivement, plus le film avance, plus le décalage est prononcé...
là j'appuie sur STOP et sur PLAY, le film recommence et le son est revenu a sa place et puis le décalage recommence progressivement..
J'ai sorti le vidéo du CD, démuxer pour vérifier les longueurs a/v les temps sont égaux, et sur l'ordi pas de décalage ...
Encore une fois mon lecteur salon lit très bien le KVCD ...
J'espère trouver une solution a mon problème ...
Si quelqu'un peut m'aider .. merci d'avance .......................
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
07-13-2004, 02:54 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Papi
Avec VirtualDub, j'ai converti le framerate vidéo (25 à 23.976)
Oulah ! Peux tu detaille rplus cette manip :
- tu t'es mis en "direct stream copy", change le framerate et tu as sauve l'avi

ou

- tu as REENCODE l'avi ?

Juste pour savoir, parce que si tu as reencode, tu as une perte effroyable de qualité.

Quote:
J'espère trouver une solution a mon problème ...
Si quelqu'un peut m'aider .. merci d'avance .......................
Le son est-il en 44.1Khz ou en 48Khz ?
Reply With Quote
  #3  
07-14-2004, 12:03 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
oups ... oui en Direct Stream Copy, je ne réencode pas le vidéo ..
Reply With Quote
  #4  
07-14-2004, 12:17 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Et le son est en 44.1 Khz
Reply With Quote
  #5  
07-14-2004, 07:59 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Etrange car d'ordinaire c'est le 48KHZ qui pose probleme.
Et tu as multiplexe avec quoi ? Qu'est ce qui change par rapport a tes autres KVCD ?
Reply With Quote
  #6  
07-14-2004, 09:40 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Je multiplexe toujours avec Tmpgenc ...
La majorité de mes sources vidéos sont déjà en 23.976fps... ou 29.97fps
J'ai quelque fois du 25fps, normalement je n'ai pas de problème pour la conversion...
J'ai déjà fais l'expérience avec le son en 48KHZ c'est pas trop jolie à la TV ...
Petite anecdote.....Ca m'est revenu ce matin ...
Dans mes premiers balbutiements pour la création de VCD, j'avais créé un VCD tout a fait standard, mais en PAL 25fps, d'une source video AVI PAL 25fps, le son et l'image étais excellent sur ma Télé, mais j'avais ce même problème de décalage ... peut-être que ce petit fait pourra aider a voir clair ou au contraire n'a rien n'a voir ...
Merci de ton intérêt ...
Reply With Quote
  #7  
07-14-2004, 10:32 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
A la limite que tu ais le pb en restant en PAL, ca me semble comprehensible : les systemes vendus en europe sont tous PAL/NTSC alors que chez vous on ne trouve quasi aucun lecteur supportant le PAL.

Mais justement, es tu sur de ta manip. Je veux dire es tu certain que l'encodage s'est bien fait a 23.976 ?
Tu devrais verifier avec avicodec par exemple, ou en jouant le peg avec zoomplayer et en demandant les infos sur la video en cours de lecture.
Reply With Quote
  #8  
07-14-2004, 01:44 PM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
oui, tout a été fait dans les règles de l'art ...
Le framerate est bien de 23.976 ..
Si le framerate n'aurait pas été converti et que le son passe de 25fps a 23.976, je crois que les dommages aurait été plus important, tu ne pense pas....
les infos du MPEG me donne aussi les bons résultats ..
Viedeo:
VBV Buffer size = 40 Kbytes
Video Bitrate = 12793 kBytes/s
704 * 480 23,98

Audio:
128 Kbit/s
44,1 KHZ Stereo
MAIS, en .crivant ceci, une lumière viens de s'allumer ...
l'audio original est MONO ...

Serait-ce la clé du problème ................
Reply With Quote
  #9  
07-14-2004, 05:32 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Papi
Audio:
128 Kbit/s
44,1 KHZ Stereo
MAIS, en .crivant ceci, une lumière viens de s'allumer ...
l'audio original est MONO ...

Serait-ce la clé du problème ................
Vu que je ne vois pas du tout ce qui peut clocher... on va dire "pourquoi pas" ?
Reply With Quote
  #10  
07-15-2004, 07:21 AM
Suzanne Suzanne is offline
Free Member
 
Join Date: Dec 2003
Location: Canada
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Salut je répond juste pour dire que moi je me soucie guère du fait que ce soit du pal ou du ntsc lors de l'encodage. Je ne change rien à mes réglages par défaut de tmpgenc sauf le template qui sont soit du ntsc (352*240) ou pal (352*28 et la cq. Dans mon script d'avisynth si c'est du pal je mets toujours dans Grip grop 352*288 et si c'est du ntsc c'est toujours 352*240. Je ne me soucie pas des bandes noires à la fin de l'encodage. Parfois le résultat final me donne du 16:9 parfois c'est du 4:3. Moi ça me dérange pas. Donc au résultat final c'est soit un pal ou un ntsc ça dépend. C'est lors du gravage avec nero qui fait la différence je crois. Comme je grave en ntsc j'imagine que tout doit se faire là.

À la fin tout passe nickel sur mon dvd et même plusieurs dvd( J'ai eu 3 dvd différents et ils passaient nickel). Donc si tu es comme moi tu ne devrait pas avoir a convertir tout en 23.97fps ou le 29, moi je n'y prête pas attention sauf pour le grip grop et le template de tmpgenc.

Pour ce qui est du mono j'ai fait un kvcd en pal mono cette semaine et aucun décalage.

J'espère t'avoir un peu aidé.
Reply With Quote
  #11  
07-15-2004, 10:10 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Moi, j'ai toujours gravé avec VCDEasy, c'est soit du Pal ou du NTSC, il ne converti pas ...
Il faudra que je fasse l'essai avec Nero...
Si ca fpnctionne pour toi, p'têt bien que pour moi aussi ..
Merci ...
Mais j'aimerais avoir l'avis d'un expert ..............
Reply With Quote
  #12  
07-15-2004, 10:16 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Papi
Moi, j'ai toujours gravé avec VCDEasy, c'est soit du Pal ou du NTSC, il ne converti pas ...
Je te rassure Nero ne converti pas non plus et je l'avais deja signale a Suzanne il me semble : ce choix sous nero n'a aucune incidence sur quoi que ce soit, sauf lorsque tu demande a Nero de reencoder ta video (ce que bien sur il ne faut pas faire)

Quote:
Mais j'aimerais avoir l'avis d'un expert ..............
Ah ca non, c'est une methode de travail qui m'horripile : demander un avis avant de faire un test soi meme. Ca prends 5 minutes de faire ce test, et plus a "l'expert" de repondre a ton message. Alors soit sympa avec "l'expert" et pose une question quand tu as tout teste et que rien n'a fonctionne.

Merci pour lui
Reply With Quote
  #13  
07-16-2004, 12:52 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
I'm sorry ....
C'est vrai que j'ai choisi le chemin le plus facile ...
C'est pas dans mes habitudes ...
Il va retenir la leçon ...

J'ai continué mes investigations, car vois-tu je veux comprendre le pourquoi de cette situation ...
J'ai sorti le son de mon fichier MPEG ... et là je ne comprends pas ce qui suit ....
Vidéo M1V = 1:56:39
Audio MP2 = 1:56:39
Je converti le MP2 en WAV (une simple conversion, même spec)
Audio WAV = 1:53:56 ?

Pourquoi cet écart de temps pour une simple conversion?

Là je converti mon WAV (NTSC) en PAL = 1:49:16 (Besweet)
et change le framerate du vidéo 23.976fps à 25fps = 1:49:16 (VirtualDub)

Donc, si les temps a/v sont égaux en PAL, c'est qu'il y aurait peut-être eu une erreur lors de l'encodage audio (WAV en MP2) avec Tmpgenc ..
J'ai gardé le son en stéréo ...

Question?
Est-ce que le temps audio a préséance sur le temps vidéo, si les temps ne sont pas égaux...?
Reply With Quote
  #14  
07-16-2004, 03:37 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Papi
Vidéo M1V = 1:56:39
Audio MP2 = 1:56:39
Je converti le MP2 en WAV (une simple conversion, même spec)
Audio WAV = 1:53:56 ?
Hum hum... quel outil as tu utilise ?

Quote:
Pourquoi cet écart de temps pour une simple conversion?
Parce qu'il y a un bug Je te rassure, ce n'est pas normal

Quote:
Là je converti mon WAV (NTSC) en PAL = 1:49:16 (Besweet)
et change le framerate du vidéo 23.976fps à 25fps = 1:49:16 (VirtualDub)
Je comprends pas la : tu as reencode toute la video an avi, c'est ca ?

Quote:
Donc, si les temps a/v sont égaux en PAL, c'est qu'il y aurait peut-être eu une erreur lors de l'encodage audio (WAV en MP2) avec Tmpgenc ..
Ne cherches plus, tu reponds toi meme a ta propre question.

Quote:
Question?
Est-ce que le temps audio a préséance sur le temps vidéo, si les temps ne sont pas égaux...?
La video a preseance mais tout sera decalle bien evidement.
Reply With Quote
  #15  
07-16-2004, 10:07 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Tmpgenc pour démultiplexer ...
Besweet pour le MP2 en WAV ...

Oui, j'ai réencodé la vidéo en AVI avec VirtualDub ..
J'ai pensé quand faisant le chemin inverse je trouverais d'ou vient l'erreur ...
Donc, je suis revenu au point de départ .. mais l'idéal serait que je puisse écouter la vidéo originale, histoire de voir si tout est OK ...

En tout cas, je vais recommencer les opérations de transformation, on verra bien ..

Merci Phil pour tes conseils ...

Je réencode tout ça et redonne des nouvelles........................................
Reply With Quote
  #16  
07-19-2004, 09:35 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Petit rappel:
AVI Source : Video = 1:53:56
Audio = 1:53:56

J'ai réencodé mon AVI
MP2 = 1:53:56
M1V = 1:53:50

Multîplexer avec Tmpgenc
Résultat = MPEG de 1:53:56

Donc, encore 6 secondes de décalage ....

J'utilise TMPGenc 2.511.51.160

J'avais déjà remarqué des différences après encodage sur d'autres vidéos, entre l'audio et la vidéo, mais rien qui porte a conséquence ....

Ma version de TMPGenc ...?
Reply With Quote
  #17  
07-19-2004, 09:51 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Non. Ta source.
Il m'arrive parfois une diff de taille d'une ou 2 sec entre piste audio et video mais sans consequence (audible ?) sur le multiplexage. Ta source a un probleme et tu ne pourras rien y faire.

Idee: encode video ET audio en meme temps avec tmpgenc. Le resultat sera probablement synchrone.
Reply With Quote
  #18  
07-19-2004, 10:51 AM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Lorsque que je l'ai encoder la première fois, c'est ce que j'avais fais et il y avait une différence de presque 3 minutes ...

Probablement a cause de la conversion du framerate ...

Depuis un certain temps, j'encodais et l'audio et la vidéo en même temps avec TMPGenc (pas besoin de multilexer a la fin, se fait tout seul) mais, en parcourant le forum, j'ai cru comprendre que le son était meilleur si pas encoder avec TMPGenc .... Besweet par exemple ...

Je viens de faire un bout d'essai sur ma télé, la première fois au bout de 20 min le son était totalement décalé, mais là c'est très acceptable ... sais pas ce que ca va donner aprés 1h30 ...

Et le temps final s'accorde plus avec l'audio que la vidéo ....
Reply With Quote
  #19  
07-19-2004, 11:35 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Papi
Et le temps final s'accorde plus avec l'audio que la vidéo ....
C'est drole mais lorsqu'on parle de decallage, on a le reflexe de penser que c'est l'audio qui est fautif. Ca peut tres bien etre la video qui te pose probleme justement ! Donc tous tes efforts au nivau de la piste audio restent vains.
Reply With Quote
  #20  
07-19-2004, 10:20 PM
Papi Papi is offline
Free Member
 
Join Date: Dec 2003
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Salut ..
Ca devrait être ma dernière intervention sur ce posting ...
Étant donné que j'aime aller au fond des choses, j'ai décidé de refaire un encode de mon video en laissant TMPGenc encodé le son en même temps comme tu venais de me suggérer ...

Je m'attendais a quelque chose de semblable à l'encodage que je venais de faire (même vidéo) seulement la vidéo, ensuite multiplexer avec le MP2 ... Et non .. gros décalage ... démultiplexe ...
video M1V = 1:53:50
audio MP2 = 1:53:56
même chose que l'encodage précédent ...
Je converti mon MP2 en WAV ... pour en avoir le coeur net ...
Et OH .. Surprise ... le son fait 1:18:15 ???????????????????????????

Et bien, maintenant pour les PAL to NTSC, je ne laisserai plus TMPGenc encoder le son ...
Ou bien, j'essaierai la voie que Suzanne a suggéré, laissé 25fps et encoder avec Nero NTSC .......................

Merci pour tout .... J'ai appris beaucoup de cette petite aventure ..
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Probleme de son tyff Conversion et d'Encodage de Vidéo (Français) 1 09-01-2004 11:35 AM
Probleme de fps tamahome Conversion et d'Encodage de Vidéo (Français) 3 05-10-2004 11:48 AM
Ton probleme gassi Video Konvertierung und Encodieren (Deutsch) 5 03-07-2004 12:13 AM
Problème de son big Conversion et d'Encodage de Vidéo (Français) 4 12-01-2003 06:52 PM
Probleme baloo30ales Conversion et d'Encodage de Vidéo (Français) 2 05-18-2003 02:25 PM

Thread Tools



 
All times are GMT -5. The time now is 07:03 AM  —  vBulletin © Jelsoft Enterprises Ltd