Quantcast Probleme Vobsub - digitalFAQ.com Forums [Archives]
  #1  
08-11-2004, 07:10 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
bonjour a tous

Je viens de recuperer un xvid avec sous titre incruster (le plugin vobsub se met en marche quand je visionne la video)
Mais j'ai un probleme quand je veu le mettre en kvcd sa m'encode bien la video mais les soustitre n'apparaisse plus :/ d'habitude j'encode avec soustitre a coter avec la commande textsub mais la c deja incruster dans la video

Comment faire pour qu'il reste visible pendant l'encodage?
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
08-11-2004, 07:22 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Tu melange un peu tout la :

- soit les ss-titres sont incrustes dans la video, par dessus l'image donc, et il n'y a pas de module vobsub necessaire a leur lecture.

- soit vobsub est bien utilise et alors les ss-titres ne sont pas incrustes. Si tu n'as pas de fichier de sous titres externe, alors tu n'as pas a faire a un Xvid mais a un OGM.

Il faudrait savoir quelle est ta situation reele.

PS et pour devancer une future question, les ss-titres sont dans les bandes noires ou sur l'image ?
Reply With Quote
  #3  
08-11-2004, 07:31 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
alors la video est en xvid et le son en ac3

les soustitre sont caller pile entre la bande noir et la video (en plein ecran)

gspot me donne c info en video 4cc=03tx/xvid Name=xvid

en audio :: bitrate 448 kb/s (5ch) cbr fs: 48000 hz

sinon c un icone appeler direct vobsub qui s'affiche quand je lis cette video
Reply With Quote
  #4  
08-11-2004, 07:37 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
parce que tu as laisse le reglage par defaut sur "load always" au lieu de "only if nedeed" je suppose.

Le format XVID ne supporte pas les sous-titres "embeded" (je trouve plus le mot en francais), donc aucun risque que ca en soit.

Tu encodes en utilisant un script incluant Gripcrop ?
Reply With Quote
  #5  
08-11-2004, 08:02 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
alors j'ai bien le reglage load when needed

Sinon por les test je ne met aucun filtre je charge la video direct dans tmpgenc , mais je remarque que j'ai le meme probleme si je veux par exemple reencoder la video en divx via virtualdub les soustitre ne s'affiche pas en encodant
Reply With Quote
  #6  
08-11-2004, 08:16 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
il faudrait que j'ai un ogm sous la main pour voir si Gspot indique "ogm" ou "xvid" (un ogm n'etant qu'un container qui englobe une video souvant xvid -, une piste audio - souvant ogg mais pkoi pas ac3 - , et d'autres choses qui peuvent etre par exemple des ss-titres !)

Mais bon, facile a verifier : ouvres le xvid dans virtualdubMOD et va dans le menu "stream" puis "stream lists". Dans la fenetre qui s'ouvre tu dois avoir ton stream audio ac3. Si tu as autre chose en plus, il y a fort a parier que ce sont tes ss titres ! Il ne te restera plus qu'a les demultiplexer et a les encoder comme tu as toujours fait.
Reply With Quote
  #7  
08-11-2004, 08:53 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
erf il s'agit bien d'un ac3 en stream list j'ai la bande ac3 :/

rien trouver comme soustitre erf apprement il faux que direct vobsub soit activer pour qu'il s'affiche mais comment le faire activer pour encodage :/
Reply With Quote
  #8  
08-11-2004, 09:03 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Mais attends, c'est une histoire de fou ton truc. Tu as necessairement un fichier avec les ss-titres dedans sur ton disque, y'a pas d'autres moyen

Un Xvid ne peut pas contenir de sous-titres !
Reply With Quote
  #9  
08-11-2004, 09:17 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
mais moi non plus j'y capte rien

bon alors nouveauté j'ai utiliser codecView dans le doute des donné de gspot et il me met : unknown fourcc Xvid et la Gspot me met xvid met codecs non disponible (pourtant j'arrive bien a la lire sous windows o_0)
Reply With Quote
  #10  
08-11-2004, 09:38 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Qu'utilises tu dans le script avisynth ? Directshowsource ou Avisource ?

GSpot te donne aussi la liste des fiultres utilises pour le rendering (partie en bas de l'ecran). Peux tu me dire ce qui est utilise pour lire la video ?
Reply With Quote
  #11  
08-11-2004, 09:43 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
je met avisource

gspot me dit
(S) --> AVI Splitter --> XviD MPEG-4 Video Decoder --> DirectVobSub (auto-loading version) --> (R)
Reply With Quote
  #12  
08-11-2004, 09:46 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Ecoute je ne peux rien pour toi. Vas sur le site Xvid.org, tapes "subtitle" comme pattern de recherche et tu verras qu'il ne te sort AUCUN resultat !

Le Xvid ne supporte PAS les sous titres

Renomme ton ficheir en "toto.ogm" et repasses le par gspot puis par un media player. Dit moi ce qu'il se passe.
Reply With Quote
  #13  
08-11-2004, 09:51 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
alors quand je met en .ogm gspot me sort pareil que c xvid :/

j'ai le 1er xvid soustitree alors
Reply With Quote
  #14  
08-11-2004, 09:54 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by tamahome
alors quand je met en .ogm gspot me sort pareil que c xvid :/

j'ai le 1er xvid soustitree alors
En fait c'etait un essai a la con parce que gspot ne se base pas (et heureusement) sur le nom du fichier

Mais tu as bien mis "toto.ogm" ? Pas 'le titre d'origine'.ogm.
Reply With Quote
  #15  
08-11-2004, 09:57 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
oui j'ai bien fais comme dit toto.ogm
Reply With Quote
  #16  
08-11-2004, 10:01 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
et peux tu essayer d'utiliser directshowsource au lieu d'avisource juste pour voir ?
Reply With Quote
  #17  
08-11-2004, 10:06 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
alors g test sa me met message invalid arguments to function "directshowsource"

j'ai bien mit directshowsource("c:\film", false)
Reply With Quote
  #18  
08-11-2004, 10:21 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
oui, le ",false" est a enlever ou s'i ca crie toujours a remplacer par "fps=25" (ou 23.976 si c'est un ntsc).
Reply With Quote
  #19  
08-11-2004, 10:30 AM
tamahome tamahome is offline
Free Member
 
Join Date: Oct 2003
Posts: 184
Thanks: 0
Thanked 0 Times in 0 Posts
la ca me met "un objet ou un nom n'as pas etais trouver "
Reply With Quote
  #20  
08-11-2004, 10:40 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
???
Tu me la refais avec le vrai texte ? (qui doit etre en anglais je pense, non ?)
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Ffdshow + Vobsub = X_X raptor2000 Convertir y Codificar Video (Español) 0 04-05-2004 12:01 AM
Subtitles: New VobSub Filter and new VobSub ripper rds_correia Subtitles 0 12-13-2003 02:37 PM
Problemas com o vobsub mcmagoobr Conversão e Codificação de Vídeo (Português) 0 09-09-2003 10:53 PM
Ayuda con vobsub XBart Convertir y Codificar Video (Español) 3 08-29-2003 06:09 PM
Avisynth: VobSub with avs 2.52 boeddha Avisynth Scripting 16 06-05-2003 12:24 PM

Thread Tools



 
All times are GMT -5. The time now is 04:55 PM  —  vBulletin © Jelsoft Enterprises Ltd