Quantcast Sous-Titres À Problèmes - digitalFAQ.com Forums [Archives]
  #1  
10-24-2003, 04:36 PM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
salut à tous, salut dialhot,
voilà mon problème. j'ai réalisé un script avec avisynth, script que voici :

AviSource("C:\MonFilm\shining.avi")
ConverttoYV12()
FluxSmooth()
TemporalCleaner()
Undot()
DCTfilter(1,1,1,1,1,1,0.5,0)
TextSub("C:\Mes documents\shining\shining.srt")

or, je n'arrive pas à ouvrir le sous-titre ! j'ai pourtant bien coché "texsub for virtualdub and avisynth" en installant vobsub" et le chemin du fichier est correct...
d'autre part, lorsque j'ouvre le script avec zoom player (après avoir effacé du script ce qui concerne le sous-titre), l'image est très plus pixélisée et il y a un décalage son/image. c'est normal ? c'est parceque c'est pas encore encodé ? ou il faut rectifier ça ?
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-24-2003, 04:57 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Vobsub est livre avec des dll valables pour avisynth 2.0x. Si tu as avs2.5x c'est vsfilter.dll qu'il te faut utiliser et tu le trouveras la :

http://prdownloads.sourceforge.net/g...9.zip?download

Pour le decallage son, c normal; la pixelisation, tu es sur de savoir ce que c'est une pixelisation ? Parce que si c'est vraiment ca, ce n'est pas normal du tout.

PS: on n'encode pas son et video en meme temps, tu le sais ?
Reply With Quote
  #3  
10-24-2003, 05:38 PM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Dialhot
la pixelisation, tu es sur de savoir ce que c'est une pixelisation ?
ben, pour moi des pixels, c'est les carrés qui composent l'image, alors quand je dis que c'est pixelisé, ça signifie qu'au lieu d'avoir une image nette et propre, on distingue quelques carrés . dans ce cas ci, les contour des visages sont pleins de carrés, bon j'ai vu pire mais c'est quand même plus mauvais que sur la video originale.
Quote:
PS: on n'encode pas son et video en meme temps, tu le sais ?
ouais, ouais je sais. j'ai déjà utilisé tmpgenc.
bon, je vais essayer ton filter car oui, j'ai bien avisynth 2.5
Reply With Quote
  #4  
10-24-2003, 06:01 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Ce n'est absolument pas normal que tu ais de la pixelisation sur une preview de ton script avs. Tu dois avoir un codec bizarre d'installe.

Il est tres difficile de te dire si ca restera sur l'encodage final car je ne sais pas exactement a quel niveau est introduit la pixelisation dans ton cas.
Reply With Quote
  #5  
10-24-2003, 07:22 PM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
en fait, j'avais déjà un des VSFILTER.dll (car il y en a deux dans le zip que tu m'as conseillé) . j'ai quand même fait l'échange, pour voir : toujours le même message "can't open textsub"
j'ai essayé le deuxième (celui qui est dans le dossier release unicode) est là c'est un message de windows qui s'affiche ("runtime error").
bizarre, bizarre...peut-être que mon système n'est pas assez puissant.
impossible de mettre les deux en même temps, sauf si j'en renomme un, est-ce que je dois le faire ?
sinon, comme codecs video, j'ai le codec divx5.1 et le sld codec pack.
Reply With Quote
  #6  
10-25-2003, 05:35 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Attends, quel est le texte EXACT (et complet) du message d'erreur que tu as stp ?

(c'est bien la version qui est dans Release qu'il faut prendre, pas la unicode)
Reply With Quote
  #7  
10-25-2003, 09:40 AM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Dialhot
Attends, quel est le texte EXACT (et complet) du message d'erreur que tu as stp ?
c'est ça:
TextSub: Can't open"C:\Mes Documents\shining\shining.srt"
(C:\MESDOCS 1\MARCHE.AVS.line7)

"MARCHE" est le nom de mon script. je l'ai appelé ainsi en espèrant que ça le fasse marcher...
Reply With Quote
  #8  
10-26-2003, 10:32 AM
serrabastien serrabastien is offline
Free Member
 
Join Date: Sep 2002
Location: France, Lille
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Essaie de mettre ton .srt ailleurs que dans "Mes documents", on ne sait jamais... Genre C:\machin.srt

'Z
Reply With Quote
  #9  
10-26-2003, 10:43 AM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
c'est bon, ça marche. merci.
Reply With Quote
  #10  
10-26-2003, 11:53 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Je te signale a tous hazard que si tu avais mis le srt dan s"Mes documents", ce n'est pas "C:\Mes Documents" le chemin mais "C:\Document and settings\tonnom\Mes documents" le vrai chemin.

Merci windows XP.
Reply With Quote
  #11  
10-26-2003, 02:50 PM
jason jason is offline
Free Member
 
Join Date: Oct 2003
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Dialhot
Je te signale a tous hazard que si tu avais mis le srt dan s"Mes documents", ce n'est pas "C:\Mes Documents" le chemin mais "C:\Document and settings\tonnom\Mes documents" le vrai chemin.

Merci windows XP.
c'est Windows 98, que j'ai. le chemin "documents and settings", ne marche pas dessus ("error de code 3")
bon, je vais faire l'encodage et demain, je verrai si ça a marché.
merci pour votre aide.
merci aussi à edny, s'il lit ce message.
Reply With Quote
  #12  
10-26-2003, 04:45 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
De toutes manieres les ss-titres devraient tjs etre dans le meme repertoire que la video. Ca evite bien des problemes.
Reply With Quote
  #13  
10-27-2003, 04:57 AM
serrabastien serrabastien is offline
Free Member
 
Join Date: Sep 2002
Location: France, Lille
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Et je dirais même plus, pour la 3 milliardième fois : Ne mettez pas vos fichier sources dans des répertoires à rallonge avec des espaces !

Cela vous évitera bien des soucis, il y a déjà bien à faire comme ça.

'Z
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Pb de sous titre Buzz-l-eclair Conversion et d'Encodage de Vidéo (Français) 1 03-14-2004 10:50 AM
Sous titres forcés DaleCoop Conversion et d'Encodage de Vidéo (Français) 7 03-09-2004 11:04 AM
Sous titres occasionnels ! ! ! elise Conversion et d'Encodage de Vidéo (Français) 1 12-23-2003 04:17 AM
Je gagne 100 Mo sous Néro Man_In_The_Moon Conversion et d'Encodage de Vidéo (Français) 10 12-04-2003 04:52 AM
Sous titre forcés CATENA JP Conversion et d'Encodage de Vidéo (Français) 0 07-09-2003 02:01 AM

Thread Tools



 
All times are GMT -5. The time now is 11:26 AM  —  vBulletin © Jelsoft Enterprises Ltd