Quantcast Rajouter la Bande Sonore? - digitalFAQ.com Forums [Archives]
  #1  
11-05-2003, 12:54 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Bonjour tout le monde.

Voila, j'ai encodé ma vidéo, mais a la fin, je n'ai eu que le fichier au format .m1v, donc j'ai la video, mais sans le son...

Comment est-ce que je peut rajouter la bande son(que j'ai extraite du fichier avi, puis converti au format mp2)(et regler les décalages s'il yen a) a mon fichier .m1v pour en faire un fichier .mpg sans réencoder le fichier???parce que sa me ferai bien chier de repasser 3 heures a reconvertir ma vidéo...

Merci d'avance.bye
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
11-05-2003, 02:28 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by N8mAare
Voila, j'ai encodé ma vidéo, mais a la fin, je n'ai eu que le fichier au format .m1v, donc j'ai la video, mais sans le son...
Oui, jusque la tout est normal, je te rassure

Quote:
Comment est-ce que je peut rajouter la bande son(que j'ai extraite du fichier avi, puis converti au format mp2)
Et bien tu as deja fait la plus grosse partie alors.

Quote:
(et regler les décalages s'il yen a) a mon fichier .m1v pour en faire un fichier .mpg sans réencoder le fichier???parce que sa me ferai bien chier de repasser 3 heures a reconvertir ma vidéo...
Mais non. Ton operation de "melanger le son a la video" ca s'apelle le multiplexing, et c'est une etape independante de l'encodage.

Tu ouvres TMPGENG, dans le menu "File" tu as "MPEG Tools" et la un onglet "simple multiplex". Tu indiques ton chemin poru el m1v, pour la video, tu regles le mode de multiplexage sur VCD(non standard) APRES avoir charge les 2 sources, tu indiques le nom du mpeg final et c'est parti.
Reply With Quote
  #3  
11-05-2003, 04:30 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Waouu, merci beaucoup..Mais moi les onglets, c'est "Outils mpeg" et "Multiplexage simple" lol

merci encore, bye
Reply With Quote
  #4  
11-06-2003, 02:40 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Merci bien, mais maintenant que j'ai le son, j'ai un fichier qui fait 844 Mo, alors que j'avais demandé de le faire pour un cd de 80 min(700 Mo)... d'ou viens le problème, et comment puis-je résoudre...

Quand il me lance Tmpgenc, il doit calculer la CQ pour que le film tienne sur le CD tout pile, mais ne doit prendre en compte que la vidéo...comment puis-je résoudre cela???

merci.
bye
Reply With Quote
  #5  
11-07-2003, 04:36 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by N8mAare
Merci bien, mais maintenant que j'ai le son, j'ai un fichier qui fait 844 Mo, alors que j'avais demandé de le faire pour un cd de 80 min(700 Mo)...
Tu as demande... a qui ? (enfin, a quoi)

Quote:
Quand il me lance Tmpgenc, il doit calculer la CQ pour que le film tienne sur le CD tout pile, mais ne doit prendre en compte que la vidéo...
Non, on tient tjs compte du son. D'ailleur le "a qui" precedent tu dois avoir une case pour indiquer la taille du son, d'une maniere directe ou indirecte.

Reste a voir qui est ce "a qui".
Reply With Quote
  #6  
11-07-2003, 02:17 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Ben j'ai demandé a tok, com indiqué dans le tuto...

Dans l'onglet "prediction & spacing", j'ai indiqué le nombre de CD(1 seul), et la durée du cd, 80min(700Mo)...

Dans "Audio and more", j'ai bien sélectioné "External Audio", puis j'ai indiqué le chemin pour accéder a mon fichier extrait avec virtualdub, puis encodé en mp2 avec Headac3he....

Comment remédier???
Reply With Quote
  #7  
11-07-2003, 04:07 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by N8mAare
Ben j'ai demandé a tok, com indiqué dans le tuto...
Tu viens donc de comprendre pkoi je repette svt que Tok est a la masse cote prediction de taille et conseille plutot d'utiliser CQMAtic qui est moins souvent pris en defaut.

Quote:
Dans "Audio and more", j'ai bien sélectioné "External Audio", puis j'ai indiqué le chemin pour accéder a mon fichier extrait avec virtualdub, puis encodé en mp2 avec Headac3he....
Et ce faisant, tu as donc bien indique a Tok la taille de ton fichier son. Comme je te le disais, on indique tjs la taille d'une maniere ou d'une autre. D'ailleur tu ne pourrais pas lancer le travail de Tok sans lui avoir precise ce point.

Quote:
Comment remédier???
Se mettre a CQMatic ou pour cette video en particulier, baisser le coeff de Tok a moins que 1.00.
Reply With Quote
  #8  
11-08-2003, 08:34 AM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Ok ok, j'ai téléchargé CQmatic, mais comment l'utiliser???

Avec CalculMatic, je trouve que mon film fai 116 min et 28 secondes, dans CQmatic, je met 116 min ou 117???

Dans Calcul matic, "Average bitrate", il m'affiche 809.8, dans CQ matiq, j met 809, ou 810???Doi-je cocher "Override Default CQ"???Dois-je me mettre sur "Full Encode", ou bien "Prediction Only"???

Merci d'avance.bye
Reply With Quote
  #9  
11-08-2003, 09:10 AM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Bon alor, dans CQ matic j'ai fai un essai avec temps=117min, average bitrate=809 'ce qu'il ma calculé avec CalculMatic), et j'ai coche Override default CQ, et Full encode

le pbm, c'est que la, il est en train de m'encoder la video avec ue CQ de 89.69, alors que quand j'utilisais tok, il m'encodait la meme video avec une CQ de 82 et quelqe, donc la vidéo finale va encore etre plus volumineu que avec tok non???

ps, jcompren rien a CQmatic
Reply With Quote
  #10  
11-08-2003, 10:18 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Non tu as tout compris a CQMatic (mettre les valeurs supperieures ou inferieures n'a que peu d'influence sur le resultat final, donc tu mets la valeur la plus proche).

Par contre, tu devrais jeter un coup d'oeil du cote des logs : tu verras que toutes les tailles de fichier vues pas CQMatic lors du calcul de la CQ sont negatives : ca indique qu'il y a un probleme.

Le probleme je vais te le dire : UTILISES DES NOMS DE FICHIERS ET DE REPERTOIRE COURTS.

L'ideal c'et de tout mettre dans un repertoire "C:\kvcd".
Reply With Quote
  #11  
11-08-2003, 01:07 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
ok ok merci bcp, j'essaye sa tout de suite

J'avai remarqué les tailles de fichier negatives dans le log, mais je me suis dis que c'était normal....

A tien, sayé, les tailles sont positives....

merci encore.
Reply With Quote
  #12  
11-08-2003, 03:24 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
re

Bon mon pc a planté, donc je recommence, mais il me semble k'il y a un problème...

Lorsque je calcule l'average bitrate avec CalculMatic, j'indique ma source, le nombre de disque, la taille,(je met CD 80 min) et lorsqu'il calcule, il m'inidique "Video size = 700624" et "Audio size = 118576"

Lorsqu'il parle de video size, il parle de la video seulemen(sans le son), ou bien de la video finale(avec le son)

Packe si dans la taille des CD j'indique Custom, puis 700MB(=cd 80 min), il m'indique "video size = 598224"....

Dois-je rester sur CD 80 min, ou bien sur Custom 700MB????

merci d'avance.
Reply With Quote
  #13  
11-09-2003, 11:00 AM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
personne ne sait???

Bon j'ai fait un essai en mettant "Custom, 700 Mo", et il m'a sorti un fichiers de 615Mo...c'est normal ou bien j'aurai du mettre "CD 80 min"???

Autre problème, a la sortie de l'encodage(avec CQmatic, puis Tmpgenc), il m'a sorti un fichier .mpg de 600 Mo, mais pas de son a la lecture, et quand je veu rajouter ma bande sonore avec "Mpg tools"(bande sonore de 111Mo), il me sort un autre fichier .mpg qui fait 615 Mo... et a la lecture, le son est vraimen pourri, plein de coupure, et un sacré decallage...


resultat, 3h d'encodage(et de mon tps) de perdu...

Comment faire???? Me serai-je gouré dans l'utilisation de CQ matic???ou bien de Tmpgenc, acant de sauvegarder le projet...???

merci d'avance...
Reply With Quote
  #14  
11-09-2003, 11:39 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Euh... On ne t'a jamais dit qu'un CD de 80 minutes en mode video c'est 800 MO ?

Et bien tu viens de le decrouvrir alors

80min = 700 Mo data (CDROM) = 800 Mo video (VCD/SVCD...)

Il n'y avait aucun probleme donc.

Quand a tes problemes de lecture et de son, tu lis avec quoi ?
Reply With Quote
  #15  
11-09-2003, 12:21 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
ah ben non, je ne savai pas...merci (encore) de me l'avoir dis

Ben j'ai essayé de le lire avec real on player, et winamp 3, pas moyen qu'il y ait un son corect...

Bon je réessaye tout sa...
Reply With Quote
  #16  
11-09-2003, 12:34 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Utilise un vrai lecteur de video. Zoomplayer par exemple.

Mais ca peut aussi venir des codecs sur ton disc. Utilises GSPOT pour determienr quels codecs sont employes et dit moi ca.
Reply With Quote
  #17  
11-09-2003, 12:58 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
Mais je pense que je me trompe aussi, c'est quand il faut faire la sauvegarde du projet sous TMPGenc...

Dans source video, je met ma source,
dans source audio, je met la source audio, au format mp2
et fichier en sortie, je met le nom, au format jpg...

Ensuite, dans "Options", je règle:
Type de flux : Mpeg 1 video
Dimension : 352 * 240
Ratio d'aspect : 1:1(VGA)
Frequence dimage(23.976)
Mode de controle du débit : Qualité Constante(CQ)
Recherche de mouvement : standard

dans "Expert", je cocehe " reduction de l'effet fantome"

DAns "Audio"
type de flux : Mpeg1 audio couche II
Frequence d'echatillionage : 44100
Mode de canalo : stereo

Puis dans "systeme", type de flux : Mpeg1 Video CD

C'est bon tout sa, ou j'ai fait des conneries???

sinon jsuis en train de telecharger Gspot
Reply With Quote
  #18  
11-09-2003, 01:21 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
1/ Tu n'as pas a mettre la source audio ! TMPGEnc doit etre utilise par CQMatic uniquement pour la video. Tu joindras les 2 (video + audio) ensuite (tu pourras utiliser la fonction de multiplexage de tmpgenc, ce n'est pas un soucis).
La maniere dont tu travailles fait que tmpgenc REENCODES le son !

2/ recherche doit etre sur "Motion estimate search(fast)" et non pas sur normal. C'est plus rapide et donne de meilleurs resultats.

3/ Pkoi tu coches "reduction de l'effet fantome" ? N'utilise jamais aucun filtre de tmpgenc ! Si tu as un problemes de fantome a corriger, avisynth est la pour ca.

Note: et ce n'est pas "mpeg1 VCD" mais "MPEG1 vcd NON STANDARD".

Note2: tu as charge un template KVCD dans ton TMPGENC ? Parce que vu que tu as "standard" en methode de recherche je commence a avoir des doutes serieux sur le reste des parametres (GOP - matrice...).
Reply With Quote
  #19  
11-09-2003, 01:33 PM
N8mAare N8mAare is offline
Free Member
 
Join Date: Oct 2003
Location: Cambrai
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to N8mAare Send a message via MSN to N8mAare
ah ok donc mes conneries viennent de la...

Quote:
Note2: tu as charge un template KVCD dans ton TMPGENC ? Parce que vu que tu as "standard" en methode de recherche je commence a avoir des doutes serieux sur le reste des parametres (GOP - matrice...).
euh j'ai 4 templates kvcd :
-KVCD-CQ-352x240-(NTSCFilm).mcf
-KVCD-CQ-352x240-(NTSCFilm)-PLUS.mcf
-KVCD-CQ-352x240-_NTSCFilm_-PLUS.mcf
-KVCD-CQ-352x288-_PAL_-PLUS.mcf

y faut kje choisisse lequel???

sinon j'ai essayé avec les paramètres que tu vien de me donne, je lance CQmatic, et il m'affiche TMPGenc apeine une seconde, kitte le programme,puis recommence, et il fait 8 fois, et a la fin, une "message box" s'ouvre et m'affiche "Fromat de flux invalide"...

je compren plu rien...
Reply With Quote
  #20  
11-09-2003, 01:53 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Settings -> Expert -> source range (double click)

Si tu as une fenetre d'erreur, tu confimes que tu veux continuer. La tu cliques sur "default" puis sur "cut editing" et "reset editing" s'il n'est pas en gris ('si c'est en gris, tu peux passer a la suite).

Tu ressort par Ok. Tu sauves le project en temps que TEXTE.

Et la ca doit marcher. Tout ca c'est indique dans les instructions de CQMATIC et il eut ete bon de les lire au moins une fois.

Quand au template, peu importe celui que tu charges. Mettons "KVCD-CQ-352x240-(NTSCFilm)-PLUS.mcf" poru etre tranquille.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Ajouter bande noire sans crop l'image tamahome Conversion et d'Encodage de Vidéo (Français) 1 02-14-2005 02:38 PM
Petit probleme de bande sur tv plat tamahome Conversion et d'Encodage de Vidéo (Français) 2 12-05-2004 03:26 PM

Thread Tools



 
All times are GMT -5. The time now is 09:41 PM  —  vBulletin © Jelsoft Enterprises Ltd