Quantcast Erreur Du Script Danstok - digitalFAQ.com Forums [Archives]
  #1  
01-01-2004, 02:05 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Voilà mon script (V4)

AviSource("C:\****.avi",false)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(576, 304, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()

je reçois le message d'erreur suivant :
BlindPP:Work in YV12 Colorspace
(C:\***.avs, line 2)

si quelqu'un peut m'éclairer, ca vient de quoi, que dois-je modifier ?
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
01-01-2004, 02:24 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Tu dois mettre a jour tes codecs Xvid et Divx et les configurer pour qu'ils sortent du YV12 et non pas du YUY2.

Plus rapide (mais a deconseiller tres fortement), juste pour eviter de t'entendre me dire que je parle chinois : ajoute "ConvertToYV12()" apres la ligne "avisource".

Note: j'ai ete gentil et me suis contente de retirer le titre du film de ton post. Mais j'aurais du clore le sujet normalement. Attention donc.
Reply With Quote
  #3  
01-01-2004, 02:38 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
merci beaucoup g rectifié

mais je recois un nouveaux message d'erreur :
GripCrop:Unrecognized destination frame size
je comprends pas pourtant c bien les bons chiffres : largeur 576 et hauteur 304

pour le nom du film 1000 excuses j'avais oublié de le masquer désolée.
Reply With Quote
  #4  
01-01-2004, 04:24 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by laure
je comprends pas pourtant c bien les bons chiffres : largeur 576 et hauteur 304
En parlant de "bonnes valeurs" tu dois te referer a celles de ta source. Hors ce sont les dimensions de la destination qu'on te demande ici.
Les seules valeurs possibles je les rappelle ici :

http://www.kvcd.net/forum/viewtopic.php?t=8294
Reply With Quote
  #5  
01-01-2004, 04:39 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
ah ok bon alors j'ai choisi 480*480 c'est ce qui se rapproche le plus de la résolution d'origine.

maintenant encore un autre message d'erreur :
"there is no function named Undot" ligne 8
j'imagine qu'il faut compléter quelque chose mais quoi ? dans la ligne 12 aussi je suppose (GripBorders)

j'espère que je ne t'embete pas trop avec mes questions !
Reply With Quote
  #6  
01-01-2004, 05:20 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by laure
ah ok bon alors j'ai choisi 480*480 c'est ce qui se rapproche le plus de la résolution d'origine.
Encore une quebecoise ? Et bien

Quote:
maintenant encore un autre message d'erreur :
"there is no function named Undot" ligne 8
j'imagine qu'il faut compléter quelque chose mais quoi ? dans la ligne 12 aussi je suppose (GripBorders)
Non il n'y a rien a changer nulle part dans le script. L'erreur que tu as veux dire que tu n'as pas le plugin undot.dll.

Tu dois telecharger tous les plugins necessaires au script comme indique en debut de message ou je donne ces scripts.

Va voir ici : http://www.avisynth.org/warpenterprises/
Reply With Quote
  #7  
01-01-2004, 05:28 PM
Man_In_The_Moon Man_In_The_Moon is offline
Free Member
 
Join Date: Sep 2003
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Man_In_The_Moon
pour palier aux erreurs de script que j'ai rencontrées, j'ai installé SwiftAVS qui est un soft générant des script AVS, une fois ce soft installé, j'ai mis à jour ma version d'avisynth en 2.52 (bien vérifier la version du fichier 'avisynth.dll'). Ensuite j'ai copié les filtres pour avisynth 2.52 nécessaire à mon script dans le dossier plugins de SwiftAVS ; à savoir :
BlockBuster_YV12.dll , Convolution3D_YV12.dll, Cnr2_YV12.dll, MPEG2Dec3.dll, GripFit_YV12.dll, grip.dll, UnDot.dll et DctFilter.dll.
Puis j'ai éditer mon script afin de fournir les bons chemins d'accès des filtres du dossier plugins de Swift AVS : ça donne ceci
-----------------
#Script Generated by SwiftAVS.

#PLUGINS:
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\BlockBuster_YV12.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\Convolution3D_YV12.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\Cnr2_YV12.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\MPEG2Dec3.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\MPEGDecoder_Nic_YV12.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\GripFit_YV12.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\grip.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\UnDot.dll")
LoadPlugin("D:\LOGICIELS\XVID_VIDEO\Swift_AVS\Plug ins\DctFilter.dll")

#SOURCE:
AviSource("D:\FTP_PERSO\DL_Emule\Nomdudivx.avi", false)
ConvertToYV12()
BlindPP(cpu=4)



#BLOCKBUSTER:
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)

#CONVOLUTION 3D:
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)

#BANDE-NOIRES:
GripCrop(480, 576, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")

#UNDOT:
Undot()

#TEMPORAL SOFTEN:
TemporalSoften(2,7,7,3,2)

#DCT FILTER:
DCTFilter(1,1,1,1,1,1,0.5,0)

#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()
--------------------------
une fois ces points vérifiés, tu ne devrais plus rencontrer de problèmes... enfin chez ouam ça fonctionne

SwiftAVS >> http://www.swiftavs.net/
Avisynth 2.52 >> http://www.avisynth.org
filtres avisynth 2.52 >> http://www.avisynth.org/warpenterprises/

voilà en espérant que ça aide
Reply With Quote
  #8  
01-01-2004, 05:39 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Man_In_The_Moon
pour palier aux erreurs de script que j'ai rencontrées, j'ai installé SwiftAVS
En fait je ne comprends pas bien pkoi les "debutants" que vous etees (sans aucune mechante arriere pensee en disant ca) cherchent a fire des scripts.
Vous maitrisez deja tres mal les concepts de base alors pkoi vouloir faire des scripts alors qu'il suffit de prendre ceux deja donnes, de changer DEUX lignes (avisource et gripcrop) avec notepad et tout baigne ?

Uen fois que tous les tenants et les aboutissants du KVCD sont maitrises, alors on peut se mettre a faire des scripts repondant plus a ses besoins.

Quote:
qui est un soft générant des script AVS, une fois ce soft installé, j'ai mis à jour ma version d'avisynth en 2.52
Mais ou allez vous tous chercher votre avisynth ? Depuis 1 mois la version officielle est la 2.5.3 !

Quote:
(bien vérifier la version du fichier 'avisynth.dll'). Ensuite j'ai copié les filtres pour avisynth 2.52 nécessaire à mon script dans le dossier plugins de SwiftAVS
Ca ne sert a rien ! Il faut les mettre dans le repertorie plugin de avisynth et ainsi tu n'as PLUS BESOIN de lignes loadplugin ! Et donc pas besoin d'editer ton script "pour mettre a jour les chemins".

Quote:
Convolution3D_YV12.dll
Attention, tu as la mauvaise version de convolution3D. Il ne faut pas prendre la "_YV12" mais la C3D totu court _pour avs2.5x_. Ce n'est pas la meme chose.

Quote:
AviSource("D:\FTP_PERSO\DL_Emule\Nomdudivx.avi", false)
Quitte a editer ton post pkoi ne pas retire "DL-Emule" ?

Quote:
ConvertToYV12()
BEEEEP ! Cette ligne ne devrait JAMAIS etre utilisee ! Si on en a besoin c'est qu'on a un probleme de Codec. Et il vaut LARGEMENT mieux soigner un probleme a sa source que traiter les symptomes.

Au final je ne vois pas l'interet de swiftAVS puisque tu as genere EXACTEMENT le script V4. Que defatigue alors que notepad te suffisait. Non ?

Quote:
Avisynth 2.52 >> http://www.avisynth.org
Verification faite, le 2.5.3 est sortie il y a DEUX mois, et non pas un !

Quote:
voilà en espérant que ça aide
Pour sure ca aide, mais quelle complication aussi
Reply With Quote
  #9  
01-01-2004, 05:47 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
j'ai télécharger les derniers plugins sur le site que tu m'a indiqué.
maintenant je reçois un autre message dans une fenêtre quand je sélectionne mon .avs : "invalid floating point operation"
qu'est-ce que c'est encore que ça ?

sinon, g pas bien compris pour la québéquoise
et 450*450 c'est pas bien comme résolution ?
Reply With Quote
  #10  
01-01-2004, 05:54 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by laure
maintenant je reçois un autre message dans une fenêtre quand je sélectionne mon .avs : "invalid floating point operation"
qu'est-ce que c'est encore que ça ?
Que tu n'as pas de chance ! Ce genre d'erreurs est tres aleatoire et surtout tres rare ! Peut tu esssayer une autre source, juste poru voir si c'est du a _ce_ film ou si ca te le fait tout le temps ?

Quote:
inon, g pas bien compris pour la québéquoise
480*480 est une resolution NTSC. J'en ais deduit que tu etais de l'autre cote de l'Atlantique. TOn film est PAL ou NTSC ?

Quote:
et 450*450 c'est pas bien comme résolution ?
Euh... j'ai indique toutes les reso possible dans un autre thread et je t'ai mis le lien plus haut. Il faudrait penser a lire les reponses
Reply With Quote
  #11  
01-01-2004, 05:54 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
heu pour la résolution c'est 480*480 me suis trompé

j'arrive toujours pas a voir mon film dans ToK

merci pour tes conseils man in the moon mais je crois que pour ce quiest du script c'est bon enfin j'espère
Reply With Quote
  #12  
01-01-2004, 05:58 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by laure
j'arrive toujours pas a voir mon film dans ToK
Rien ne sers d'ouvrir le script dans tok tant qu'il ne s'ouvre pas d'abord dans windows media player (ou un autre player pour les avi que tu utilises).

Tok rajoute des problemes supplementaires et il est bon de progresser etape par etape.
Reply With Quote
  #13  
01-01-2004, 05:59 PM
Man_In_The_Moon Man_In_The_Moon is offline
Free Member
 
Join Date: Sep 2003
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Man_In_The_Moon
rahhhh t'es un dieu Dialhot mais vachement pointilleux sûr ta religion

bon je vais tâcher de m'expliquer :
1/ d'abord je sais qu'avisynth 2.53 est sortie malheureusement le lien permettant de le télécharger m'a toujours fourni la vs2.52
2/ j'ai rencontré des problèmes de chargement des filtres pour avisynth donc j'ai chercher à me dépatouiller par moi même et comme j'avais swiftAVS installé depuis bien longtemps sur mon PC j'en ai profité et ai copier les filtres dans son dossier afin que celui-ci me génère le chemin adéquat. Ensuite j'ai ajouté les éléménts de ton script.
3/ D'ailleurs il me semblais que ConverttoYV12 était dans ton script ... m'enfin je crois ... Aïe Aïe ... nan m'tapes pas
4/J'édite mes scripts avec notepad maintenant que les chemins d'accès sont Ok, je change juste le nom du film (pétêtre que cé pour ça que jé oublié de *** le dossier contentieux )
4/ en quoi la version de C3D est différente de convolution3D_YV12 ?? cela se fait rélemment sentir sur le résultat de l'image ?
5/ t'as pas un lien ok pour la version 2.53 de avisynth au passage

et pour finir, dilettante et fier de l'être
Reply With Quote
  #14  
01-01-2004, 06:04 PM
Man_In_The_Moon Man_In_The_Moon is offline
Free Member
 
Join Date: Sep 2003
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Man_In_The_Moon
pour répondre à ta question de l'autre post pour le machin truc chouette .. cé sans les bandes et je me fout de l'avoir au mois d'aout ou maintenant
Reply With Quote
  #15  
01-01-2004, 06:04 PM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
pour le message d'erreur donc g essayé pur un autre film, ça me le fait aussi

sinon je c pas comment voir si c PAL ou NTSC je c pas ou je faut regarder pour ca ?
Reply With Quote
  #16  
01-01-2004, 06:12 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Man_In_The_Moon
1/ d'abord je sais qu'avisynth 2.53 est sortie malheureusement le lien permettant de le télécharger m'a toujours fourni la vs2.52
Tu es tombe sur un miroir mal mis a jour car je viens de tester et c'est bien la 2.5.3 qui se charge. De toutes manieres personellement j'en suis a la 2.5.4 (non officielle encore).

Quote:
2/ j'ai rencontré des problèmes de chargement des filtres pour avisynth donc j'ai chercher à me dépatouiller par moi même et comme j'avais swiftAVS installé depuis bien longtemps sur mon PC j'en ai profité et ai copier les filtres dans son dossier afin que celui-ci me génère le chemin adéquat. Ensuite j'ai ajouté les éléménts de ton script.
Ok, va pour l'explication. Il est tjs louable de se debrouiller seul. Maintenant ce que je disais a propos des debutants et de faire ses scritps reste valable et il ce que je disais avait pour but de veiller a eviter d'embrouiller les choses en balancant l'utilisation d'un nouveau soft pas vraiment utile (et en anglais. )

Quote:
3/ D'ailleurs il me semblais que ConverttoYV12 était dans ton script ... m'enfin je crois ... Aïe Aïe ... nan m'tapes pas
Ah non, ca ne risque pas (qu'il y soit et que je te frappe)

Quote:
4/J'édite mes scripts avec notepad maintenant que les chemins d'accès sont Ok
Ce que je ne comprends pas c'est en quoit SwifAVS a corrige ton probleme ? Ton script est a la ligne pres (si tu enleves le convert et les commentaires) mon script V4.

Quote:
4/ en quoi la version de C3D est différente de convolution3D_YV12 ?? cela se fait rélemment sentir sur le résultat de l'image ?
Vas sur le site tu verras qu'elles ont qques jours d'ecart. Celle que je te dis de prendre etant la plus recente.
Sinon je ne sais quelles difference il y a si ce n'est qu'un joru on s'est pris la tete avec qq'un qui avait un pb avant de comprendre qu'il n'avait pas la bonne version de C3D.

Quote:
5/ t'as pas un lien ok pour la version 2.53 de avisynth au passage
Comme dit plus haut, j'ai telecharge a l'instant et c'etait bien la 2.5.3 qui s'est chargee. Le miroir etant choisi au hazard, tu as du tomber sur un mauvais.
Reply With Quote
  #17  
01-02-2004, 04:22 AM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
et pour mon probleme alors je fais quoi ??
Reply With Quote
  #18  
01-02-2004, 04:27 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Tu laisses tomber Tok.

(vu que tu ne m'as pas dis si ton script s'ouvre dans wmp ou non, je decide que c'est oui, et que donc c'est Tok ton probleme. Si j'ai faux, corrige moi).

Quand a savoir si ta video est Pal ou NTSC, c'est la frequence d'image qui te dit ca. PAL c'est 25 im/s, tout le reste c'est NTSC.
Reply With Quote
  #19  
01-02-2004, 04:44 AM
laure laure is offline
Free Member
 
Join Date: Jan 2004
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
je n'ai effectivement pas pu ouvrir le film ni avec wmp ni avec bsplayer.
c'est un Pal.

bon ben tant pis, je vais essayer sans ToK mais la qualité finale du mpeg sera moins bonne j'imagine.

merci Phil de m'avoir consacrer de ton temps et à bientôt
Reply With Quote
  #20  
01-02-2004, 04:51 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by laure
je n'ai effectivement pas pu ouvrir le film ni avec wmp ni avec bsplayer.
Donc le pb ne vient pas de Tok ! Ca tombe sous le sens non ?

Quote:
c'est un Pal.
Alors tu ne peux utiliser 480*480 qui est une reso NTSC. Utilises 480*576.

Quote:
bon ben tant pis, je vais essayer sans ToK mais la qualité finale du mpeg sera moins bonne j'imagine.
D'une part ton pb ne vient pas de Tok, d'autre part Tok (et je le repettes souvent) est TOTALEMENT a la masse pour la prediction de tailel de fichier et 60% du temps tu va devoir t'y reprendre a plusieurs fois avant d'obtenir un resultat aussi bon que ce que que tu aurais obtenu en une seule fois avec CQMatic.

Bon, pour ton probleme, tu dois avoir une mauvaise version de plugin dans le repertoire des plugin.
Commence deja par virer tout ce qui n'est pas des fichiers dll. Ensuite reprends ton script et commente toutes les lignes (en mettant un "#" en debut de ligne) sauf la premiere (chargement de la source). Ouvres l'avs dans wmp. Marche-t-il ?

Si oui, tu decommentes la seconde ligne et tu retestes... et ainsi de suite jusqu'a tomber sur la ligne qui te cree l'erreur.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Erreur TMPGEnc neptune Conversion et d'Encodage de Vidéo (Français) 2 10-20-2004 01:30 AM
Pb erreur script CATENA JP Conversion et d'Encodage de Vidéo (Français) 1 08-16-2004 02:57 AM
Message d'erreur greg Conversion et d'Encodage de Vidéo (Français) 10 05-26-2004 06:39 AM
Erreur avs greg Conversion et d'Encodage de Vidéo (Français) 2 03-24-2004 04:10 AM
Petit probleme erreur script wolfen142000 Conversion et d'Encodage de Vidéo (Français) 5 02-08-2004 12:59 PM

Thread Tools



 
All times are GMT -5. The time now is 03:38 PM  —  vBulletin © Jelsoft Enterprises Ltd