Quantcast De l'Aide sur TOK pour un Débutant.... - digitalFAQ.com Forums [Archives]
  #1  
01-10-2004, 09:27 AM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Pour un nouveau sur le forum.
J'ai beaucoup lu sur le sujet et j'ai pu avancer tant bien que mal et je pense que je ne suis pas loin d'un résultat. Voici le message d'erreur que j'obtient dans une "vidéo Test.m1v" faite par TMPGenc lorsque je lance TOK:
:d\Tok-extras\Sampler\Sampler.dll is not an A
(c:\Mon-kvcd\Mon-film\video.avs, line 13)

Et voici la ligne 13 de vidéo.avs :
LoadPlugin("C:\Mon_kvcd\ToK_EXTRAS\Sampler\Sampler .dll")
J'utilse un sript optimiser du forum que voici:
AviSource("C:\Mon_kvcd\Mon_Film\mon-film.AVI",false)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(480,576, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()

Un petit coup de pousse pourrait peut être m'aider à finir enfin mon kvcd. J'ai déjà fait dee essais avec d'autres méthode de kvcd mais le résultat est plus que mitigé. C'est tout juste exploitable...mais j'ai fais mes essais sur des CD réincriptibles...
Je suis un "bleu" dans l'encodage et je ne demande qu'a apprendre.
Merci par avance....
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
01-10-2004, 01:12 PM
Buzz-l-eclair Buzz-l-eclair is offline
Free Member
 
Join Date: Jan 2004
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
est ce que tu a telecharger les plugin que tu a mis ds ton script ?
tu peux telecharger la plupart sur cette page :
http://www.avisynth.org/warpenterprises/

a bientot
Reply With Quote
  #3  
01-10-2004, 01:33 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
J'ai fais des téléchargements au fur et mesure des messages d'erreurs que je recevais...mais sur celui-ci je ne vois lequel pourrait me manquer. Voicila liste des plugins présents dans avysinth sur ma machine:
==> ac3source.dll
==> avsmon25a.dll
==> blockbuster-2.5.dll
==> convolution3DYV12.dll
==> DctFilter.dll
==> GripFit_YV12.dll
==> MPEG2Dec3.dll
==> UnDot.dll
Si il me manque quelque chose en fonction du script que j'utilise je n'arrive pas à trouver. Et si au contraire il y a quelque de trop dite le moi...car là je cherche et je n'arrive plus à avancer...@+
Reply With Quote
  #4  
01-10-2004, 08:05 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Tu dois faire pointer Tok vers la version 2.5 de sampler.dll (appelee "sampler-25.dll"). Ca se regle dans les settings de Tok.
Reply With Quote
  #5  
01-11-2004, 07:51 AM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Après avoir envoyé mon appel à l’aide je me suis souvenu avoir lu que l’on pouvait tester le fichier « vidéo.avs » dans le lecteur multimédia et là j’ai vu qu’il manquait la « sampler2,5.dll ». Je l’ai alors télécharger mais je n’ai eu le réflexe de la validé dans Tok. Merci beaucoup car tout est rentré dans l'ordre. J'ai pu obtenir mes premières images avec cette méthode qui est largement supérieur à celle que j'ai déjà testé. Le seul inconvénient c'est la durée d'encodage...TMPGEnc m'avait afficher une durée de 9h30 pour un film de 1h45mn...j'ai trouvé cela trop long. Y a t il un moyen de réduire cela ? Cela ne viendrait-il pas de la résolution choisie dans le script? Faut-il aussi configurer TMPGEnc pour un bon fonctionnement ? Car à part la configuration de Tok je n'ai rien fait dans TMPGEnc. J’espère que je ne pose pas de questions mais le sujet me passionne tellement que je ne peux me retenir. Encore merci par avance pour ces éclaircissements.
Reply With Quote
  #6  
01-11-2004, 08:50 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Il est evident que la resolution influe sur le temps d'encodage. Mais chercher a reduire celiu-ci est une mauvaise voie : il est tres simple de diminuer par 2 le temps d'encodage mais... tu diminueras par 20 la qualite de ce que tu vas obtenir.

Alors... toujours volontaire ?
Reply With Quote
  #7  
01-11-2004, 01:39 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mr. Dialhot,
Non si le rapport est celui-ci, si déjà je fais quelque chose j'aime que le résultat soit à la hauteur de la piene que je me donne. Mais tout autre chose, lors de premier encodage j'ai arrêter lorsque j'avais 10mn de video que je pouvais visualiser. J'ai gravé sur cd-rw cette petite que j'ai pu lire sans aucun problème sur mon lecteur DVD mais par contre sur celui d'un copain rien à faire....pourtant il a les mêmes caractéristiques que le mien...y a t il une explication? @+
Reply With Quote
  #8  
01-11-2004, 03:58 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Oui : le KVCD est une modification du standard (VCD ou SVCD, selon le mode que tu utilises) et un lecteur affichant dans ses caracteristiques "supporte les VCD (ou les SVCD)" ne veut pas dire qu'il supporte qque chose qui sorte du standard en question.

Voila pkoi il faut tjs tester son lecteur avant de debuter. Note que le lecteur en question peut lire un autre type de KVCD (exemple : tu as teste en SVCD mais en VCD ca aurait pu marcher).
Reply With Quote
  #9  
01-12-2004, 10:44 AM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Finalement pour l'autre lecteur c'est le Cd-Rw qui était un peu abîmé et la platine en question est peut être plus sensible que la mienne. Perso j'ai un lecteur pioneer et l'autre une sous "marque" de je ne sais quoi...
Voilà j’ai finalement fini mon premier encodage par la méthode Tok, la qualité est très bonne. Image, son rien à redire…mais j’ai 2 petites bandes noir en haut et en bas de l’écran et parfois en fonction de la scène (C’est un spectacle d’un humoriste) le personnage a la tête couper…ce n’est pas trop gênant mais si il y a un moyen de corrigé cela je suis preneur. C’est dans le script qu’il faut agir, mais je sais vraiment quoi modifier bien qu’il n’u a que 6 lignes de codes…je viens de lancer un encodage par la méthode CQmatic et cela semble bien se dérouler…En fonction du résultat je verrais quelle méthode adopter définitivement et alors essayer de bien en saisir toutes les ficelles.
Reply With Quote
  #10  
01-12-2004, 10:58 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by maomar
C’est dans le script qu’il faut agir, mais je sais vraiment quoi modifier bien qu’il n’u a que 6 lignes de codes…
S'il y a une petite bande norie en haut et en bas tout le long c'est que ta source n'etait pas dans un format facilement redimensionable en 480*576. Gripcrop prefere dans ce cas ajouter une bande noire que couper de l'image.

Par contre le coup de la tete coupee, ca devait etre comme ca au depart. Ou alors tu as mal regle tmpgenc mais ca c'est impossible puisque tu passes par tok, qui regle tout comme il faut.
Reply With Quote
  #11  
01-13-2004, 11:49 AM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Finalement j’ai visualisé toute la vidéo et c’est plus qu’honorable. Mais où je perds mon latin que sur la base du script utiliser précédemment avec le quel j’ai encodé, plus rien ne veut fonctionner. Lorsque dans Tok, onglet « Main » le script est pointé (je donne le nom de la vidéo que je veux encoder) il me crée un autre script qu’il nomme video.avs, et c’est dans ce fichier, où la base du script de départ est reprise mais beaucoup de ligne de codes sont rajouter et les messages d’erreur viennent de là:
“SelectRangeEvery ((round (framecount/interval)), nFrames)”.
Ceci est-il normal?
J’avais tenté quelque chose avec Cqmatic mais après 3h d’encodage mon nouveau fichier était plus gros (960Mo) qu’original et il restait encore1h30 d’encodage…mais je laisse ça de côté pour plus tard. D’abord essayé de maîtrisé une méthode. Mais toi, Dialhot, laquelle tu conseilles pour un débutant ?
Mais quand même cette question : dans le petit tuto où tu explique comment utiliser Cqmatic en ligne 3 tu dis : tu mets en source l’avs, j’ai beau chercher dans TMPGenc je ne trouve pas l’endroit où le pointé. S’agit-il du script « .avs » ? Je crois que j’exagère avec mes questions et je m’en excuse, merci.
Reply With Quote
  #12  
01-13-2004, 12:04 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by maomar
il me crée un autre script qu’il nomme video.avs, et c’est dans ce fichier, où la base du script de départ est reprise mais beaucoup de ligne de codes sont rajouter et les messages d’erreur viennent de là:
“SelectRangeEvery ((round (framecount/interval)), nFrames)”.
Ceci est-il normal?
Oui c'est normal. Ca sert a faire la pahse de prediction de taille (pour calculer la CQ).

Quelle version d'avisynth as tu ? Et quel est le contenu du script video.avs ? Car je sais d'ou vient ton erreur mais je n'ai pas envie de detailler tous les cas de figure alros je prefere savoir lequel correspond a ton cas.

Quote:
J’avais tenté quelque chose avec Cqmatic mais après 3h d’encodage mon nouveau fichier était plus gros (960Mo) qu’original et il restait encore1h30 d’encodage…
Parce que tu n'as pas fait tout ce qu'il est demande de faire, que CQMAtic plante et que je mets ma main a couper que la CQ calculee etait de 89.77. Non ?

Quote:
Mais toi, Dialhot, laquelle tu conseilles pour un débutant ?
Surtout pas Tok !
CQMatic me semble ma bonne solution avec une premiere periode qui est de faireun KVCD sans se preoccuper de determiner la bonne CQ. Utiliser une CQ de 70 et vogue la galere. La taille du fichier ne sera jamais bonne (parfois trop grosse, parfois trop petite), mais pendant ce temps on apprends les techniques de base. Apres ca, rajouter la "surcouche" CQMAtic c'est l'enfance de l'art !

Quote:
j’ai beau chercher dans TMPGenc je ne trouve pas l’endroit où le pointé. S’agit-il du script « .avs » ?
Yes
Et tu le mets en tant que source video. Si tmpgenc te le refuse il peut y avoir plusieurs causes, la premiere etant que tu n'as pas installe le plugin Readavs.dll qui est necessaire a Tmpgenc pour... lires les scripts avs (les avs, en abregge )
Reply With Quote
  #13  
01-13-2004, 12:25 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
J'ai le version 2.5 d'avisynth.
Pour le Cq la valeur que tu annonce (89,77) ça colle.
Je vais installé Readavs.dll car je sais que je ne l'ai pas fait du fait que Tok ne la demandepas...@+
Reply With Quote
  #14  
01-14-2004, 12:13 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
je me permet de revenir avant d'avoir eu une réponse. Voilà après un succès avec Tok je ne suis plus arrivé a faire quoi que se soit...alors je me suis tourné vers Cqmatic et là il me semble plus facile...mais lors du calcul du Cq j'obtient des valeurs très basse comme 52,02 ou 54,8 ...et comme j'ai pu lire à queque part, toi Dialhot tu n'encode pas en dessous de 60. D'où cela peut venir pour obtenir des valeurs aussi faibles. J'ai aussi vu ces valeurs de résolutions données par toi et j'essai de les appliqué dans le script "V4" du site, à savoir :
=> 1h30 544*576
=> 1h45 480*576
=> 2h00 352*576
=> 2h30 252*288
Merci pour ta patience. @+
Reply With Quote
  #15  
01-14-2004, 12:22 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Note que toutes ces valeurs ne sont applicables que pour des films en cinemascope (avec bandes noires) et pas en plein ecran.

Qu'essayes tu d'encoder ? Quel bitrate audio utilises tu (moi j'utilises 128 en gal, parfois 112) ? Et surtout, utilises tu le script V4 ou non ?
Reply With Quote
  #16  
01-14-2004, 12:48 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Par exemple le fameux documentaire sur "les oiseaux qui changent de région" et là Cqmatic m'a proposé un Cq de 52,02. Mon bitrate audio est de 128. Oui j'utilise le script V4 du forum mais peut-être pas comme il faut. Je fais un copier coller du dernier:

AviSource("C:\Mon_kvcd\Mon_Film\Mon-documentaire.avi",false)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(544, 576, overscan=2, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
#Blockbuster(method="noise",detail_min=1,detail_ma x=10,variance=0.3,seed=5623)
GripBorders()

Fit moi ce ne cloche pas...merci
Reply With Quote
  #17  
01-14-2004, 01:36 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Je ne connais pas la duree de ton documentaire mais je suis pres a parier par contre qu'il est en plein ecran, non ? Donc rien d'etonnant.

Avec une source plein ecran, il te faudra plutot utiliser la reso 352*576 si tu veux t'en sortir. Mais dans un premier temps, essayes 480*576 avec un bitrate audio de 112 au lieu de 128.
Reply With Quote
  #18  
01-14-2004, 05:23 PM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Non mon documentaire n'est pas en plein écran. Du moins quand je le lis dans WMP ou Bsplayer c'est du 16/9eme.
Il dure 1h34mn24s, selon Calcumatic, le bitrate audio est à 128.
C'est avec une résolution supérieure (544 * 576) à celle que tu me proposes (480*576) que Cqmatic m'a fait la proposition d'un Cq à 52,02. Je vais tester cela et je donnerais les résultats.
Mais à partir des éléments fournis par Calcumatic est-il possible de se dire je vais prendre telle résolution plutôt qu'une autre ? L'expérience je pense comme dans toute activité...@+
Reply With Quote
  #19  
01-14-2004, 05:38 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
L'experience n'est pas tout car la situation varie d'un film a l'autre. Par contre, tes yeux, eux ne changent pas .
Lorsque CQMatic a fini de travailler, il reste le resultat de son dernier test sur le disque dur. Il porte l'extension .sample.

Lis ce fichier dans wmp, et tu verras la qualite que tu obtiendras en encodant avec la valeur trouvee par CQMatic. Vois si elle te convient ou non ( a mon avis non).

Mais il est extremement etonnant d'obtenir une si faible CQ. Quel min bitrate mets tu en video ?

Peux tu me donner la resolution de la video de depart stp ?

PS: ne jamais faire confiance a wmp pour les problemes d'aspect ratio. Bsplayer est plus convaincant.

PS2: ce n'est pas calcumatic qui te dit que le bitrate audio estr a 128, c'est toi qui lui dit que tu veux un bitrate a 128 ! Ce parametre est modifiable a ta guise.
Reply With Quote
  #20  
01-15-2004, 05:24 AM
maomar maomar is offline
Free Member
 
Join Date: Jan 2004
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
J'ai vu ce fichier (.sample) et je l'ai visualisé. La qualité sur le moniteur n'est pas mal, alors j'ai laisser aller le processus j'usqu'au bout et j'ai obtenu un fichier qui fait "833Mo". J'ai même pousser plus loin, je l'ai gravé avec Néro (en surcapacité, il me manque un bout du générique de fin...) sur un Cd-Rw et le résultat à la lecture sur la platine (pioneer DV-444) est juste acceptable.
Voici les caractéristiques de départ du documentaire (selon BSplayer):
=> 715 400Ko
=> 640*368
=> 24,999 fps (???)
Si avec tout cela tu peux me guider pour vers bon résultat je suis preneur et surtout je pense que pour mes prochaines vidéos je verrais mieux le chemin à suivre. Merci.
PS: Pour le bitrate j'ai bien compris qu'il est possible de le réduire dans calcumatic.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Débutant.... neptune Conversion et d'Encodage de Vidéo (Français) 1 09-17-2004 03:32 AM
Besoin d'aide pour faire un KDVD bigfif Conversion et d'Encodage de Vidéo (Français) 4 09-07-2004 07:56 AM
Besoin d'aide laure Conversion et d'Encodage de Vidéo (Français) 15 07-15-2004 10:06 AM
Questions d'un débutant. Djam Conversion et d'Encodage de Vidéo (Français) 37 02-16-2004 01:43 PM
Premières questions d'un débutant.. valdef Conversion et d'Encodage de Vidéo (Français) 4 11-24-2003 02:18 AM

Thread Tools



 
All times are GMT -5. The time now is 06:49 AM  —  vBulletin © Jelsoft Enterprises Ltd