Quantcast Alguns Problemas ao Fazer KDVD No DIKO - Help-Me Please - digitalFAQ.com Forums [Archives]
  #1  
07-07-2004, 08:52 AM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Oi pessoal, comprei um grav. de DVD e estou tentando fazer meu 1º KDVD
Estou tentando montar um KDVD com 14 videos em divx (em média 20 min. cada) que têm resoluções variadas, mas procurei selecionar apenas os Frame rates q o Diko free suporta. 13 vid. estão em 29.970 e apenas um em 23.976.
Pois bem, vou destacar os prob. que tive durante todo o processo:
1º - Nos parametros tive que mudar o encoder audio para Softencode, pois o besweet estava gerando arquivo com 0kb.
2º Feito isso, deixei rolar todo o processo (iniciou as 14:43) e voltei no dia seguinte (~8:00) pensando q já ia estar concluído, mas para o meu azar, o CCE travou em uma das prediçoes do vídeo 9 . Fechei o CCE e ele passou para a próxima predição normalmente e ele continuou todo o processo .
3º No processo de áudio, em 4 videos o softencode travou, não sendo possível continuar o processo para estes (ainda bem q nessa hora eu estava na frente do PC , foi só fechar o erro e o DIKO passou para o seguinte) . Depois ao analisar o log verifiquei q o áudio destes filmes estavam em 22khz.

Ao terminar fui testar os videos gerados em mpg e os mesmos estavam apresentando falta de sincronia com o audio
Como não tinha apagado os mpvs e os ac3 gerados, importei-os para o DVD-LAB e notei que o tempo de duração entre o áudio e o vídeo não batiam em nenhum filme, dando diferença de ~ 2 seg. entre eles.

Concluíndo:
Vou refazer todos os áudios manualmente através do VDub e gerar MP2 através do HeadAC3. Será q vai dar certo?

Uma curiosidade: estive vendo os avs que o diko gerou, e ele colocou
AssumeFPS(29.97) em todos eles. Porque? Este recurso não é apenas para vídeos que tem frame rates diferentes? Será que é este o motivo da falta de sincronia?
PS: Desculpem o texto longo , mas só assim o Vmesquita poderá aprimorar, com os nossos erros, este excelente programa que ele criou.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
07-07-2004, 09:02 AM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RAvengar-wolfenstein
Pois bem, vou destacar os prob. que tive durante todo o processo:
1º - Nos parametros tive que mudar o encoder audio para Softencode, pois o besweet estava gerando arquivo com 0kb.
2º Feito isso, deixei rolar todo o processo (iniciou as 14:43) e voltei no dia seguinte (~8:00) pensando q já ia estar concluído, mas para o meu azar, o CCE travou em uma das prediçoes do vídeo 9 . Fechei o CCE e ele passou para a próxima predição normalmente e ele continuou todo o processo .
Verifique se o seu ECLCCE é a ultima versão. (1.81)
Quote:
3º No processo de áudio, em 4 videos o softencode travou, não sendo possível continuar o processo para estes (ainda bem q nessa hora eu estava na frente do PC , foi só fechar o erro e o DIKO passou para o seguinte) . Depois ao analisar o log verifiquei q o áudio destes filmes estavam em 22khz.
É, essa frequencia da problema com o BeSweet... Está na lista de coisas pra fazer um "work-around"
Quote:
Ao terminar fui testar os videos gerados em mpg e os mesmos estavam apresentando falta de sincronia com o audio
Estranho... Será que não haviam frames corrompidos? vc checou os videos com DivFix?
Quote:
Como não tinha apagado os mpvs e os ac3 gerados, importei-os para o DVD-LAB e notei que o tempo de duração entre o áudio e o vídeo não batiam em nenhum filme, dando diferença de ~ 2 seg. entre eles.
Isso tb é muito estranho.
Quote:
Vou refazer todos os áudios manualmente através do VDub e gerar MP2 através do HeadAC3. Será q vai dar certo?
Só Deus sabe. Mas manualmente vc terá mais controle sobre o processo e poderá descobrir onde está o problema.
Quote:
Uma curiosidade: estive vendo os avs que o diko gerou, e ele colocou
AssumeFPS(29.97) em todos eles. Porque? Este recurso não é apenas para vídeos que tem frame rates diferentes? Será que é este o motivo da falta de sincronia?
O AssumeFPS é sempre colocado. Mas não deveria causar problemas, afinal assumir o mesmo FPS que já é do vídeo não muda nada (em teoria). Vc pode tentar remover a linha e abrir o avs no VD pra ver se muda o tamanho do filme em segundos.
Quote:
PS: Desculpem o texto longo , mas só assim o Vmesquita poderá aprimorar, com os nossos erros, este excelente programa que ele criou.
Exatamente! Se todos reportarem os problemas com detalhes e exatidão, posso melhorar e consertar bugs!
Reply With Quote
  #3  
07-07-2004, 12:07 PM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
Verifique se o seu ECLCCE é a ultima versão. (1.81)
Sim, é a v. 1.81

Quote:
Estranho... Será que não haviam frames corrompidos? vc checou os videos com DivFix?
Não tinha checado, mas acabei de checar e não tem problemas.

Quote:
Uma curiosidade: estive vendo os avs que o diko gerou, e ele colocou
AssumeFPS(29.97) em todos eles. Porque? Este recurso não é apenas para vídeos que tem frame rates diferentes? Será que é este o motivo da falta de sincronia?
Quote:
Originally Posted by vmesquita
O AssumeFPS é sempre colocado. Mas não deveria causar problemas, afinal assumir o mesmo FPS que já é do vídeo não muda nada (em teoria). Vc pode tentar remover a linha e abrir o avs no VD pra ver se muda o tamanho do filme em segundos.
Abri no vdub, o original e o avs estão com o mesmo tempo.
O curioso é que depois de compressados, todos os vídeos estão com, extamente, 2 seg a menos!! os áudios estão no tempo certo!

Eu to querendo fazer um teste com apenas um video e tirar o "assume fps" do script, mas como fazer no CCE com a mesma predição que foi feita antes no diko com os 14 juntos? pelo log ele mostra a predição final que o diko encontrou pra cada video?

Valeu Vmesquita!!
Reply With Quote
  #4  
07-07-2004, 12:24 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
O QFactor é calculado para todos os vídeos em conjunto. Isso permite que todos os vídeos tenham a mesma qualidade, independente do bitrate necessário para cada um.
Tive uma idéia: abra os filmes originais e o MPV gerado no VirtualDubMod e verifique se o número de frames está igual.
Reply With Quote
  #5  
07-07-2004, 01:12 PM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
O QFactor é calculado para todos os vídeos em conjunto. Isso permite que todos os vídeos tenham a mesma qualidade, independente do bitrate necessário para cada um.
Tive uma idéia: abra os filmes originais e o MPV gerado no VirtualDubMod e verifique se o número de frames está igual.
Desculpe a ignorância , mas qual a diferença entre qfator e bitrate?
Neste KDVDs eu tenho videos com boa qualidade e outros com qualidade bem inferior (divx de 25 min em 130 MB).
Quando fazia KVCD no Tmpgenc eu aumentava o Qfator (não mexia no bitrate) dos videos ruins pra não perder mais qualidade ainda na recompressão.
Pelo que eu entendi o Diko não identifica isso e coloca um padrão pra todos, de forma que eles caibam em 1 DVD?

Eu nem sabia q existia esse VirtualdubMod!!
Baixei agora, instalei, abri o video .mpv , mas ao ir em file information o programa fecha!!
Mas, como falei, eu coloquei no DVD-lab os mpvs com os respectivos audios, ao invés de colocar os mpgs e todos os mpvs são 2 seg menores em relação ao original.
Reply With Quote
  #6  
07-07-2004, 03:35 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RAvengar-wolfenstein
Desculpe a ignorância , mas qual a diferença entre qfator e bitrate?
QFactor é tipo um fator de qualidade, que no CCE varia de 1 (melhor) a infinito (pior) Só que para um dado fator de qualidade, o bitrate necessário não é o mesmo, por que cada conteúdo comprime de uma forma. Pegando exemplos extremos, uma tela preta comprime muito melhor que uma explosão, portanto para a mesma qualidade de compressão da tela preta será necessário muito mais bitrate no caso da explosão.
Bitrate é simplesmente o numero de bits por segundo.
Quote:
Neste KDVDs eu tenho videos com boa qualidade e outros com qualidade bem inferior (divx de 25 min em 130 MB).
Argh!
Quote:
Quando fazia KVCD no Tmpgenc eu aumentava o Qfator (não mexia no bitrate) dos videos ruins pra não perder mais qualidade ainda na recompressão.
Bom, aí é diferente. O que vc fazia era diminuir a deterioração causada pela compressão usando um fator de qualidade melhor. Mas em tese, se vc usasse o mesmo fator para todos os filmes eles ficariam com a mesma qualidade, só que os que já estavam ruins iriam ficar pior ainda e nos "bons" a piora seria menor e tolerável.
Quote:
Pelo que eu entendi o Diko não identifica isso e coloca um padrão pra todos, de forma que eles caibam em 1 DVD?
A forma mais eficiente é usar o mesmo QFactor para todos, supondo que a qualidade da fonte seja mais ou menos a mesma. Mas não tem como um programa avaliar se a qualidade da fonte é ruim ou boa, pq isso é uma medida subjetiva, que só um "humano" pode dizer. Para um programa, as informações necessárias para representar aquele vídeo estão ali e ele não tem como comparar com outra coisa pra dizer se já está ruim ou não.
Quote:
Eu nem sabia q existia esse VirtualdubMod!!
Baixei agora, instalei, abri o video .mpv , mas ao ir em file information o programa fecha!!
é verdade, ele não mostra as propriedades para MPEG2, eu esqueci... Mas tem outro programa que mostra, não lembro qual é agora...
Quote:
Mas, como falei, eu coloquei no DVD-lab os mpvs com os respectivos audios, ao invés de colocar os mpgs e todos os mpvs são 2 seg menores em relação ao original.
Vc já tentou tocar os MPG pra ver se estão normais? De repente o DVD-Lab ta informando errado?
Reply With Quote
  #7  
07-07-2004, 03:53 PM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Eu to gravando em dvd-ram (ainda não comprei um DVDR-W ) pra ver como ficou. Vou asssitir no Pc e depois t conto se deu certo! vamos torcer!!

Vmesquita, não tem muito a ver com KDVD, mas se vc puder me ajudar eu agradeço! é que eu tenho um filme em 4 CDs em SVCD e to querendo colocar tudo em um DVD, então acho que não compensa fazer KDVD.
Só que ao tentar importar o arquivo MPG-2 no DVD-LAB ele recusa alegando incompatibilidade. tenho que multiplexar?
Reply With Quote
  #8  
07-07-2004, 04:09 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RAvengar-wolfenstein
Eu to gravando em dvd-ram (ainda não comprei um DVDR-W ) pra ver como ficou. Vou asssitir no Pc e depois t conto se deu certo! vamos torcer!!
Bom, vc não precisava gravar: O windvd e o powerdvd tem uma função reproduzir DVD da pasta.

Quote:
Vmesquita, não tem muito a ver com KDVD, mas se vc puder me ajudar eu agradeço! é que eu tenho um filme em 4 CDs em SVCD e to querendo colocar tudo em um DVD, então acho que não compensa fazer KDVD.
Só que ao tentar importar o arquivo MPG-2 no DVD-LAB ele recusa alegando incompatibilidade. tenho que multiplexar?
Use o programa SVCD2DVDMPG, que irá desmultiplexar (separar audio e video) e colocar o audio em 48 khz. A resolução, claro será não padrão pra DVD (480X480) mas geralmente funciona.
Reply With Quote
  #9  
07-07-2004, 04:52 PM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
Bom, vc não precisava gravar: O windvd e o powerdvd tem uma função reproduzir DVD da pasta.
é q eu to sem espaço na HD!!



Quote:
Use o programa SVCD2DVDMPG, que irá desmultiplexar (separar audio e video) e colocar o audio em 48 khz. A resolução, claro será não padrão pra DVD (480X480) mas geralmente funciona.
Nossa Cara!!!! VALEU MESMO!!!

Em Breve vou depositar os R$40,00 na sua conta!!
Não é promessa de político não tá?
VC merece muito mais do que isso, não só pelo DIKO mas também pela disposição e paciência em compartilhar seu conhecimento com todos aqui do fórum!

NÃO DESANIME E CONTINUE ASSIM!!
[]'s
Rogério
Reply With Quote
  #10  
07-07-2004, 05:51 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Obrigado pelos elogios, Rogério, é sempre um prazer ajudar.
Reply With Quote
  #11  
07-08-2004, 07:46 AM
RAvengar RAvengar is offline
Free Member
 
Join Date: May 2004
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Vmesquita,
compilei os videos no DVD-lab e todos eles ficaram em tamanho miniatura, ocupando 1/4 da tela, mesmo colocando em tela cheia!

Pelo DIKO eu fiz KDVD em 352X240, usei esta resolução pq são episódios capturados da TV e a resolução não estava lá essas coisas.
Importei pro DVD-lab e FUI em "project properties", "project size" e coloquei 352X240 SIF.
Será que foi esse o problema?
As outras opções são:
720X480 full d1,
704X480 broadcast d1,
352x480 half d1
480x480 non standart
544x480 non standart

E agora? Qual q eu uso??
Reply With Quote
  #12  
07-08-2004, 07:50 AM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Bom, pode ser problema no player de DVD que vc usou... Tente fazer de novo mudando o projeto para 720X480 full d1, acho que o DVD-Lab recomenda deixar nessa resolução mesmo quando os videos estão em outra resolução. Mesmo assim acho que no DVD-Player deve funcionar.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Erro no Diko 0.74 ao tentar fazer KDVD martigo Conversão e Codificação de Vídeo (Português) 2 08-21-2004 04:26 PM
Problemas ao fazer KDVD de um DVD de SHOW (entrelaçado) RAvengar Conversão e Codificação de Vídeo (Português) 1 07-16-2004 05:50 PM
Alguns probleminhas com o Diko andre1211 Conversão e Codificação de Vídeo (Português) 1 07-09-2004 01:17 PM
DIKO Alguns d2v estão travando o CCE el34 Conversão e Codificação de Vídeo (Português) 18 07-01-2004 07:07 PM
Alguns problemas e duvidas Fabaum Conversão e Codificação de Vídeo (Português) 1 04-12-2004 06:09 PM

Thread Tools



 
All times are GMT -5. The time now is 05:48 PM  —  vBulletin © Jelsoft Enterprises Ltd