digitalFAQ.com Forums [Archives]

digitalFAQ.com Forums [Archives] (http://www.digitalfaq.com/archives/)
-   Conversão e Codificação de Vídeo (Português) (http://www.digitalfaq.com/archives/portugues/)
-   -   Filme tá achatando !!! (http://www.digitalfaq.com/archives/portugues/11391-filme-ta-achatando.html)

SurfBoy 08-08-2004 03:12 PM

Filme tá achatando !!!
 
Eae !!! Pô galera me ajudem ae !!!
Fiz um SKVCD seguindo o tutorial do Vmesquista pelo CCE, e o filme tá achatando, estou usando o script do tutorial na resolução 528x480, o que eu posso fazer para que o filme não achate ?

Valeu mesmo galera!!!

[]'s

zakimart 08-09-2004 08:48 AM

Re: Filme tá achatando !!!
 
Quote:

Originally Posted by SurfBoy
Eae !!! Pô galera me ajudem ae !!!
Fiz um SKVCD seguindo o tutorial do Vmesquista pelo CCE, e o filme tá achatando, estou usando o script do tutorial na resolução 528x480, o que eu posso fazer para que o filme não achate ?

Oi SurfBoy!
Mande detalhes da sua fonte, principalmente se é 16:9 ou 4:3.
E mande tb seu script.
Abraço

SurfBoy 08-09-2004 12:09 PM

Eae zakimart !!!

Bem a resolução original é:
560x416
4:3

Meu script é:

Code:

AVISource("Caminho\Filme",false)

#Post-Process
ConvertToYUY2()
#addborders(0,8,0,0)
Blockbuster(method="noise",detail_min=1,detail_max=8,variance=0.3,seed=5823)
ATC(1,2,4,0.5,false)
TemporalSoften(2,7,7,3,2)
Blockbuster(method="noise",detail_min=1,detail_max=10,variance=0.5,seed=5823)

#Resize, overscan and borders
#TextSub("Caminho\LegendanoFilme")
GripCrop(480, 480, overscan=2,source_anamorphic=false,dest_anamorphic=false)
GripSize(resizer="LanczosResize")
GripBorders()

#Subtitles #
############
TextSub("Caminho\Legenda")
#Sampler(100,length=15)

Obs: Já testei em outros overscan e ocorreu o mesmo problema.

Desde já agradeço muitissimo a sua ajuda !!!

[ ] ' s

zakimart 08-09-2004 12:46 PM

Oi SurfBoy!
Quote:

Obs: Já testei em outros overscan e ocorreu o mesmo problema.
Overscan está relacionado a bordas laterais.
Ao meu ver seu script está correto.
Provavelmente vc errou nas configurações do TMPGEnc.
Verifique as configurações e faça um teste.
Abraço

SurfBoy 08-09-2004 01:41 PM

Ola zakimart, mais uma vez te agradeço pela ajuda.

É que estou fazendo pelo CCE !
Já testei em todos os aspects ratios existentes nele, e acontece a mesma coisa. E não é só com este filme, é com qualquer um mesmo que eu encodo... hehehe... estou ficando louco com isso já! hehehe! :wink:

[ ]'s

FlavioMetal 08-09-2004 01:58 PM

Tente mudar o "source_anamorphic" (ou o dest_anamorphic, não me lembro agora) do script para "true" e vj no que dá! Testa aí e poste!

SurfBoy 08-09-2004 04:08 PM

Pô valeu pela ajuda.
Mais não iria adiantar eu colocar source_anamorphic true, já que o filme está em 4:3 Full Screen, e dest serviria apenas para o deixa-lo fullscreen e ele já é em fs, então infelizmente não resolve o problema!!!

Valeu mesmo a ajuda!!!

[ ]'s

BJ 08-09-2004 04:32 PM

Quote:

Originally Posted by SurfBoy
Pô valeu pela ajuda.
Mais não iria adiantar eu colocar source_anamorphic true, já que o filme está em 4:3 Full Screen, e dest serviria apenas para o deixa-lo fullscreen e ele já é em fs, então infelizmente não resolve o problema!!!

Valeu mesmo a ajuda!!!

[ ]'s

Resolverá sim.
Code:

GripCrop(480, 480, overscan=2,source_anamorphic=false,dest_anamorphic=true)
Pelo fato de ser FS vc deve mudar o destino para true.

Outro detalhe, seu vídeo será encodado a 480x480 e não 528x480 como havia dito.

Abraços!

vmesquita 08-09-2004 05:21 PM

@BJ
Mudando o dest_anamorphic para true vc está indicando que quer produzir um video anamorfico, que não é o caso aqui. :wink:

@SurfBoy
Em todo caso, como o vídeo é 4:3, pode fazer isto para foçar o redimensionamento:

Code:

AVISource("Caminho\Filme",false)

#Post-Process
ConvertToYUY2()
#addborders(0,8,0,0)
Blockbuster(method="noise",detail_min=1,detail_max=8,variance=0.3,seed=5823)
ATC(1,2,4,0.5,false)
TemporalSoften(2,7,7,3,2)
Blockbuster(method="noise",detail_min=1,detail_max=10,variance=0.5,seed=5823)

#Resize, overscan and borders
#TextSub("Caminho\LegendanoFilme")
LanczosResize(480,480)
letterbox(16,16,16,16)

#Subtitles #
############
TextSub("Caminho\Legenda")
#Sampler(100,length=15)


BJ 08-09-2004 07:43 PM

Quote:

Originally Posted by vmesquita
@BJ
Mudando o dest_anamorphic para true vc está indicando que quer produzir um video anamorfico, que não é o caso aqui. :wink:

@SurfBoy
Em todo caso, como o vídeo é 4:3, pode fazer isto para foçar o redimensionamento:

Code:

AVISource("Caminho\Filme",false)

#Post-Process
ConvertToYUY2()
#addborders(0,8,0,0)
Blockbuster(method="noise",detail_min=1,detail_max=8,variance=0.3,seed=5823)
ATC(1,2,4,0.5,false)
TemporalSoften(2,7,7,3,2)
Blockbuster(method="noise",detail_min=1,detail_max=10,variance=0.5,seed=5823)

#Resize, overscan and borders
#TextSub("Caminho\LegendanoFilme")
LanczosResize(480,480)
letterbox(16,16,16,16)

#Subtitles #
############
TextSub("Caminho\Legenda")
#Sampler(100,length=15)


O filme está em FS!
Colocando TRUE ele manterá o FS. Já fiz isso várias vezes com fontes FS. Quando deixava false ou ele achatava ou dava erro no avysinth.

@vmesquita
Dá uma olhada aih no seu PVT :wink: !

Grande abraço!

FlavioMetal 08-09-2004 07:58 PM

Pois é! Comigo funfou também! Uma vez peguei um filme q estava achatado, aí mudei esses parâmetros e ele deu uma "esticada" na imagem!

Bem, de qualquer forma, vc tentou fazer isto só pra testar?

SurfBoy 08-09-2004 08:44 PM

Poxa, valeu messsssmo galera a ajuda!!! Esse forum é 10 !!! :)
Vou testar tudo como você me recomendaram e irei postar o resultado !!!

Obrigado a todos, zakimart, flavio metal, bj e vmesquita !!! :wink:

zakimart 08-10-2004 09:30 AM

Hi
 
Oi Pessoal!
Só para não fazer confusão, widescreen e widescreen anamorfico são tamanhos diferentes.
Quando se coloca dest_anamorphic=true em um filme wide, ele estica um pouco sim, por que anamorfico a tela é maior.
O ideal é fazer o resize no movie stacker para redimensionar corretamente.
Senão as vezes as pessoas ficam um pouco esticadas.
Fazendo como o VMesquita falou (LanczosResize(480,480) ), força o filme ficar em 4:3.
Abraços


All times are GMT -5. The time now is 06:54 PM  —  vBulletin © Jelsoft Enterprises Ltd

Site design, images and content © 2002-2022 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2022 Jelsoft Enterprises Ltd.