Quantcast Captura Compactando Aos Trancos - digitalFAQ.com Forums [Archives]
  #1  
12-04-2004, 01:09 PM
Exodus Exodus is offline
Free Member
 
Join Date: Jun 2004
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Exodus
Olá a todos !

Tenho a seguinte configuração: Windows XP SP2, Atlhon XP 2.6+, 768Ram, GForce FX5600 ViVo, 2 HDs 120GB (micro da assinatura). Nesta configuração estou com a seguinte situação: estou usando uma filmadora Sony Digital8 Modelo DCR-TRV330 NTSC para gravar alguns trabalhos que estamos efetuando na empresa, nisto fiz a filmagem e estou querendo capturar no meu micro, já convertendo em um formato compactado (Divx, Xvid, WMV, Mpeg2, qualquer um).

O problema é que, ao usar o VCR Virtual ou Virtual Dub Mod para capturar, se eu usar compactação no Vídeo já na captura, o video fica simplesmente aos trancos, de uma forma lastimável ! No caso do audio este esta ficando perfeito, mesmo usando a bagaceira do VIA AC'97 on-board, compactando direto em MP3 (não estou discutindo neste caso a qualidade sonora, afinal é uma apresentação no telão, sem necessidade de um som impecável)

Agora se eu capturo em AVI nativo (UYVY) ele o faz perfeitamente, mas haja espaço em disco para isso ! O problema é que tem um amigo que o faz em uma ATI Radeon em formato MPEG2 naturalmente, só que ele captura desenhos direto de sua TV a Cabo, mas até ai não faz diferença a fonte, certo ? Afinal eu estou usando entrada S-Video e ele também !

Alguém poderia me dar uma força nisto ? Aconselhar algum formato bacana de compactação, algum outro programa mais *compatível* com minha GForce FX5600, ou algo assim ?

Do modo que esta aceito qualquer coisa, até uma oração já vai estar ajudando !


Abraços !
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
12-04-2004, 03:07 PM
FoXMuLD3R FoXMuLD3R is offline
Free Member
 
Join Date: May 2003
Location: Brasil/SP/SãoPaulo/PL
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to FoXMuLD3R Send a message via Yahoo to FoXMuLD3R
Quote:
Originally Posted by Exodus
Olá a todos !

Tenho a seguinte configuração: Windows XP SP2, Atlhon XP 2.6+, 768Ram, GForce FX5600 ViVo, 2 HDs 120GB (micro da assinatura). Nesta configuração estou com a seguinte situação: estou usando uma filmadora Sony Digital8 Modelo DCR-TRV330 NTSC para gravar alguns trabalhos que estamos efetuando na empresa, nisto fiz a filmagem e estou querendo capturar no meu micro, já convertendo em um formato compactado (Divx, Xvid, WMV, Mpeg2, qualquer um).

O problema é que, ao usar o VCR Virtual ou Virtual Dub Mod para capturar, se eu usar compactação no Vídeo já na captura, o video fica simplesmente aos trancos, de uma forma lastimável ! No caso do audio este esta ficando perfeito, mesmo usando a bagaceira do VIA AC'97 on-board, compactando direto em MP3 (não estou discutindo neste caso a qualidade sonora, afinal é uma apresentação no telão, sem necessidade de um som impecável)

Agora se eu capturo em AVI nativo (UYVY) ele o faz perfeitamente, mas haja espaço em disco para isso ! O problema é que tem um amigo que o faz em uma ATI Radeon em formato MPEG2 naturalmente, só que ele captura desenhos direto de sua TV a Cabo, mas até ai não faz diferença a fonte, certo ? Afinal eu estou usando entrada S-Video e ele também !

Alguém poderia me dar uma força nisto ? Aconselhar algum formato bacana de compactação, algum outro programa mais *compatível* com minha GForce FX5600, ou algo assim ?

Do modo que esta aceito qualquer coisa, até uma oração já vai estar ajudando !

Abraços !
Vc esta tendo "DropFrames" durante a captura!? capturar comprimindo direto pra um codec pesado, como DivX e qualquer MPEG4 sempre da perda de frames, como se o processador nao conseguisse converter em tempo real toda informação e ainda "jogar nas mãos" do HD gravar em disco!

Muitos programas executados no sysTray?
evite ter executado programas durante captura... e evite ter icones em execução no systray!
__________________
FoXMuLD3R
Reply With Quote
  #3  
12-05-2004, 09:30 AM
Exodus Exodus is offline
Free Member
 
Join Date: Jun 2004
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Exodus
Olá Fox !

Não sei o que houve, eu havia respondido ontem e não apareceu postado

Mas blz, vamos lá: eu já verifiquei a parte de processamento/memória disponível no sistema, e não deve ser isto. Tenho +/- 95% de processamento livre e 560MB Ram livres, no sistema (em execução) tenho apenas Netlimiter, AV NOD 32 e o aplicativo de atualização do No-Ip,mais nada.

Usando o codec MS Windows Media Video 9 o processamento fica mesmo no talo, mas usando o Xvid ou Divx 4 o proessamento nao ultrapassa os 70%, claro que mesmo assim não executo nada durante a captura. No Virtual VCR ou no Virtual Dub Mod o processo em si parece tranquilo, até fiz testes com apenas 1 min de video capturado, mas continua aos trancos. Já setei a captura em NTSC (mesmo padrão da filmadora) em 23.976FPS, usei tanto o Video Componente quanto o S-Video, já atualizei os drivers WDM da nVidia, ja fiz varredura com AV em todo sistema (só por desencargo consciencia) mas neda, não consegui ver nada de errado.

É algo na captura mesmo, só não sei o que estou fazendo de errado... para não dizer que não achei nada estranho eu não estou conseguindo capturar direto em MPEG2, o sistema não me habilita este formato, mas não estou muito interessado nele.

Bom, é isso, se alguém tiver mais alguma dica agradeço. Valeu !


[ ]'s
Reply With Quote
  #4  
12-05-2004, 12:12 PM
Cyberlab Cyberlab is offline
Free Member
 
Join Date: Jul 2004
Location: Joinville/SC/Brasil
Posts: 177
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Cyberlab
Faço capturas com o micro da assinatura que é pior que o seu sem nenhum problema em Divx. Mas capturo em Divx apenas quando o video de destino for em Divx. Se for fazer Mpeg 1 ou 2 capturo com o Huffyuv ou Picvideo. Detalhe importante é que uso os codecs alternativos WMD e o programa iuVCR para gravação.

Eu nunca faço as minhas capturas abaixo de 29,970 não importando se o sistema de cor é NTSC ou PAL. Quanto à resolução, utilize NTSC (???x480) pois o standard por aqui é o "M".
__________________
MSI KT880, Sempron2400, R9200SE, DVDRW 4160B, 1024DDR400, PlayTVPro bt878a, Intel R537, DLink500G, Maxtor40e80Gb
Reply With Quote
  #5  
12-05-2004, 02:48 PM
jeo jeo is offline
Invalid Email / Banned / Spammer
 
Join Date: Nov 2002
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Cyberlab
Quanto à resolução, utilize NTSC (???x480) pois o standard por aqui é o "M".
grande comentário Cyberlab!
Reply With Quote
  #6  
12-06-2004, 04:13 PM
FoXMuLD3R FoXMuLD3R is offline
Free Member
 
Join Date: May 2003
Location: Brasil/SP/SãoPaulo/PL
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to FoXMuLD3R Send a message via Yahoo to FoXMuLD3R
Quote:
Originally Posted by Exodus
... É algo na captura mesmo, só não sei o que estou fazendo de errado... para não dizer que não achei nada estranho eu não estou conseguindo capturar direto em MPEG2, o sistema não me habilita este formato, mas não estou muito interessado nele...
Fala Exodus,

Então, eu acredito que vc nao consiga capturar em MPEG2 no VirtualDub ou VirtualVCR, justamente por que eles sao aplicativos OpenSource, ou seja Free, e até onde eu sei MPEG2 é um codec "proprietário; pago.... logo só um softwares de captura pagos devem oferecer esse recurso para capturar em MPEG2.

Uma ferramenta que ando usando muito para capturar em MPEG2 na faixa dos 5Mbits VBR, anda sendo o MainConcept MPEG Encoder, na internet vc encontra ele para achar, Trial ou "apapagaiado" (Termo By: Jorel)

Todos os testes que fiz com MPEG4 nunca foram com sucessos, tb nao posso fazer muito teste em cima de HD's IDE comuns, tenho conciência de que isso é um fator altamente limitador em taxas de I/O.

Ainda mais quando se usa algo que digere a capacidade de armazenamento de seu HD como; AVI "cru" ou DV ou Huffyuv!

deve haver alguma manha em capturar em MPEG4, mais o principal para mim sempre foi capturar em MPEG2 em taxas de 6~ Mbits aprox. pq quase todo material que captura vai para DVD, rarissimamente vai um VCD e etc... mesmo assim exportar pelo premiere via Adobe Media Encoder para VCD é tranquilo depois, isso me da poucos "dropframes" e ocupa pouco espaço no HD, o unica coisa é que no timeLine do premiere sou obrigado a Re-Renderizar para que ele (o premiere) consiga interpretar os "Key" do MPEG2.

Mais o MPEG4 que vc esta capturando, esta tendo "DropFrame" ou é outra parada?
__________________
FoXMuLD3R
Reply With Quote
  #7  
12-06-2004, 04:18 PM
FoXMuLD3R FoXMuLD3R is offline
Free Member
 
Join Date: May 2003
Location: Brasil/SP/SãoPaulo/PL
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to FoXMuLD3R Send a message via Yahoo to FoXMuLD3R
Quote:
Originally Posted by Cyberlab
...Eu nunca faço as minhas capturas abaixo de 29,970 não importando se o sistema de cor é NTSC ou PAL. Quanto à resolução, utilize NTSC (???x480) pois o standard por aqui é o "M"...
Opa Cyberlab,

Estou ainda tentando entender esta sua frase...
O que exatamente define um video como PAL - > 25fps c/ 576 linhas?
O que exatamente define um video como NTSC? -> 29,970 c/ 480 linhas?

PAL = a padrão europeu correto!?
e PAL-M? PAL-N e etc da onde vem todas estas macabras variações!

Ando tendo muito problema de padrão PAL-M, possivelmente tenha que investir numa "amazing" transcoder, pois muito materia chega as vezes em minhas mãos em PAL-M e quase sempre me f*d*!

EDITADO pelos Mods: Fox, no Brasil talvez essa palavra não tenha muita importancia, mas eu garanto q em Portugal fica feio.


!?!?!??!!?!
__________________
FoXMuLD3R
Reply With Quote
  #8  
12-06-2004, 09:55 PM
Cyberlab Cyberlab is offline
Free Member
 
Join Date: Jul 2004
Location: Joinville/SC/Brasil
Posts: 177
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Cyberlab
PAL, NTSC e SECAM são sistemas de cores.

M, G, N, etc... são os padrões (standard). No Brasil temos o sistema de cores PAL combinado com o padrão M. Nos Estados Unidos o sistema de cor é NTSC e o padrão é também M. Por este motivo há compatibilidade entre estes dois e não com o sistema europeu onde o fps pode ser de 50.
__________________
MSI KT880, Sempron2400, R9200SE, DVDRW 4160B, 1024DDR400, PlayTVPro bt878a, Intel R537, DLink500G, Maxtor40e80Gb
Reply With Quote
  #9  
12-07-2004, 06:54 AM
rds_correia rds_correia is offline
Free Member
 
Join Date: Apr 2003
Location: Chinese Democracy starts now!
Posts: 2,563
Thanks: 1
Thanked 0 Times in 0 Posts
Excelente comentário Cyber
__________________
Rui
Reply With Quote
  #10  
12-09-2004, 07:58 PM
Exodus Exodus is offline
Free Member
 
Join Date: Jun 2004
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Exodus
Olá a todos !

Antes de mais nada gostaria muito de agradecer todos os posts, pois se não resolvi o problema ainda pelo estou consegundo obter cada vez mais informações úteis. O ruim é que ainda persiste a dificuldade e acho isso o cumulo do absurdo visto a configuração do micro, afinal capturar o vídeo compactando o mesmo não deveria ser impecílio no micro da assinatura e não deve-se a padrões, não pode ser, então só sobra problema no programa de captura e eu já testei 3: Virtual Dub Mod, iuVCR e o Virtual VCR e todos dão na mesma. Codec poderia ser também mas eu já testei com Divx 4/5, Xvid e MS WMV 9. WDM da nVidia eu já estou com a última versão e também nada, sendo que a entrada, tanto RCA qto. S-Video funcionam perfeitamente.

Ó vida, ó azar..... ;/

Alguém aqui no Fórum usa alguma nVidia ViVo e poderia me da uma força ? Aceito qualquer oferta de ajuda ae galeraaaaaa !!!!

Abraços a todos e valeu mesmo !
Reply With Quote
  #11  
12-09-2004, 10:28 PM
Cyberlab Cyberlab is offline
Free Member
 
Join Date: Jul 2004
Location: Joinville/SC/Brasil
Posts: 177
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Cyberlab
O que você exatamente quer dizer com trancos. Significa que passa normal, dá uma pausa e continua e dá uma pausa? Ou quer dizer que o video é mostrado como se estivesse a 10 ou 15 fps ou câmera lenta?

Outra coisa que pode estar acontecento é que o seu HD esteja muito fragmentado e o arquivo tende a ficar "aos pedaços" pelo HD.
__________________
MSI KT880, Sempron2400, R9200SE, DVDRW 4160B, 1024DDR400, PlayTVPro bt878a, Intel R537, DLink500G, Maxtor40e80Gb
Reply With Quote
  #12  
12-10-2004, 10:30 PM
Exodus Exodus is offline
Free Member
 
Join Date: Jun 2004
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Exodus
@Cyberlab

Vou tentar ser o mais detalhista possível, quem dabe não ajuda vcs a me ajudarem ! Bom, quando capturo do AVI sem nenhum tipo de compactação, ao termino de uma captura, quer seja de 30 segs. ou de 10 mins. o filme roda normal, dai posso usar o Virtual Dub e compacta-lo em Divx, MS WMV9, etc., normalmente e assistir com excelente qualidade. O problema ocorre quando eu tento capturar JÁ compactando o arquivo no momento da captura, ou sejá: vou lá no Virtual VCR, marco opção de compactar vídeo e escolho qualquer codec que sejá, o vídeo é capturado aparentimente sem erros, mas ao rodar este em qualquer player este fica mais do que quadro-a-quadro, parece até que só movimento um único quandro a cada 3 segs. +/-, é bizarro Parece até que ele esta engasgando, travando, aos trancos e barrancos para passar o vídeo, como se muitos frames estivessem sendo perdidos. É o melhor modo que consigo descrever o problema.

A dificuldade em diagnosticar o caso é que já vi de tudo: codecs, programas de captura, drivers de captura, virus no sistema, espaço em disco, etc. A minha vontade de capturar já compactando é para não usar um espaço gigantesco (apesar de ter 240GB de HD eu tenho muito, mas muito anime gravado nos HDs, ai já viu), fora que depois é um saco ter de deixar o vídeo sendo compactado, o bom mesmo seria já pegar o danadinho e ir compactando, não é mesmo ?

Já o som este consigo já compactar na hora da captura e vai tranquilamente, até mesmo porque entendo eu que som é mais "leve" para o sistema tratar, e olha que ja testei capturar sem áudio para ver se não era esse o problema, e não resolveu. Sei lá, pela configuração do micro não achei que haveria tantos problemas em já capturar o video usando compactação, mas enfim, fica a sua dica para testar, então vou gravar alguns animes em DVD (tava sem mídia), dai vou apagar os arquivos, dar uma desfragmentada e testo a captura, mas eu acho estranho de ser isso pois se fosse o AVI puro deveria, em tese, apresentar este problema se fosse fragmentação no HD, fora que ele fica GIGANTE se não compactar, chega na casa de varios gigas de HD para poucos minutos de video capturado ;P


Mesmo assim valeu pela atenção, abraços !
Reply With Quote
  #13  
12-13-2004, 08:36 AM
FoXMuLD3R FoXMuLD3R is offline
Free Member
 
Join Date: May 2003
Location: Brasil/SP/SãoPaulo/PL
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to FoXMuLD3R Send a message via Yahoo to FoXMuLD3R
Quote:
Originally Posted by Exodus
...Vou tentar ser o mais detalhista possível, quem dabe não ajuda vcs a me ajudarem ! Bom, quando capturo do AVI sem nenhum tipo de compactação, ao termino de uma captura, quer seja de 30 segs. ou de 10 mins. o filme roda normal, dai posso usar o Virtual Dub e compacta-lo em Divx, MS WMV9, etc., normalmente e assistir com excelente qualidade. O problema ocorre quando eu tento capturar JÁ compactando o arquivo no momento da captura, ou sejá: vou lá no Virtual VCR, marco opção de compactar vídeo e escolho qualquer codec que sejá, o vídeo é capturado aparentimente sem erros, mas ao rodar este em qualquer player este fica mais do que quadro-a-quadro, parece até que só movimento um único quandro a cada 3 segs. +/-, é bizarro Parece até que ele esta engasgando, travando, aos trancos e barrancos para passar o vídeo, como se muitos frames estivessem sendo perdidos. É o melhor modo que consigo descrever o problema...
Isto esta parecendo DropFrame...
se vc pegar este arquivo compactado (por exemplo: MPEG2 á 4Mbits ou DivX) e tentar rodar em outro micro tb ocorre o mesmo, pois codec quando da pepino no micro é doloroso arrumar... quase impossivel, mais não impossivel!
__________________
FoXMuLD3R
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Captura Homer_s Conversão e Codificação de Vídeo (Português) 5 12-07-2004 02:53 PM
Trancos -Problemas no Pulldown? gilco Conversão e Codificação de Vídeo (Português) 5 10-23-2004 11:16 AM
Trancos apos terminar um KDVD!!! - RESOLVIDO Borjao Conversão e Codificação de Vídeo (Português) 40 09-06-2004 03:39 PM
Fps na captura de vhs wcellabr Conversão e Codificação de Vídeo (Português) 8 07-27-2004 07:35 PM
Problemas na Captura.. corsineto Conversão e Codificação de Vídeo (Português) 7 06-05-2004 06:18 AM

Thread Tools



 
All times are GMT -5. The time now is 01:33 AM  —  vBulletin © Jelsoft Enterprises Ltd