Quantcast Runtime Error! - digitalFAQ.com Forums [Archives]
  #1  
01-12-2004, 11:55 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Estava seguindo o manual do vmesquita para kvcd e quando fui carregar o script avs no tmpgenc recebi a seguinte mensagem de erro:

Microsoft visual c++ runtime library
Runtime error
This application has requested the runtime to terminate it in na unusual way
Acontece o mesmo no virtualdub!

O que será isso?

Beijos
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
01-13-2004, 06:54 AM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Bom dia Fabiana!
Essa mensagem de erro é um saquinho...
Posso estar errado, mas acho que é devido aos plugins do avisynth.
Em qual pasta vc juntou os plugins?
Tente colocar os plugins em outra pasta e não esqueça de mudar o endereço dos mesmos no script.
Depois, post o resultado para nós, por favor.
Abraço
Reply With Quote
  #3  
01-13-2004, 08:05 AM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Olá zakimart!
Olha, eu coloquei os plugins na seguinte pasta:

C:\Arquivos de programas\AviSynth 2.5\plugins

Como assim colocar os plugins em outra pasta? Essa não é a pasta adequada para os mesmos?

Mais uma perguntinha: para que serve o plugin VSFilter.dll ?
É que quando eu deletei esse arquivo o erro de runtime sumiu e deu lugar à seguinte mensagem:

VirtualDub error
Avisynth open failure
BlindPP: Work in YV12 colorspace
(c:\Programas\kvcd\divx.avs, line 3

Ah, o meu script é o seguinte:

AviSource("C:\Filmes\Movie.avi",false)
#addborders(0,8,0,0)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
GripCrop(528, 480, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()
TextSub("e:\legenda.smi")
ConvertToYUY2()
#Sampler(length=24)


Obrigada pela ajuda zakimart!

Beijos
Reply With Quote
  #4  
01-13-2004, 08:11 AM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Oi Fabiana!
Quote:
Como assim colocar os plugins em outra pasta? Essa não é a pasta adequada para os mesmos?
É que já me deu esse erro e quando mudei os plugins da pasta do avisynth, o erro sumiu.
Os meus plugins eu coloco na pasta plugins do movie stacker.
Quote:
Mais uma perguntinha: para que serve o plugin VSFilter.dll ?
É o plugin das legendas.
Quote:
É que quando eu deletei esse arquivo o erro de runtime sumiu e deu lugar à seguinte mensagem:

VirtualDub error
Avisynth open failure
BlindPP: Work in YV12 colorspace
(c:\Programas\kvcd\divx.avs, line 3
Deixe o VSFilter.dll na pasta release dentro da pasta de plugins do avisynth.
Vamos ver se some esse erro.
Tente colocar a linha ConvertToYUY2() depois do AVI Source.
Parece-me tb, que vc deve atualizar seus codecs Divx e Xvid.
Reply With Quote
  #5  
01-13-2004, 10:50 AM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Oi de novo zakimart! Muito obrigada pela ajuda!

Olha fiz o que vc me indicou, inseri a linha ConvertToYUY2() depois de AVI Source, coloquei o VSFilter.dll na pasta Release dentro da pasta Plugins e não apareceu mais o erro de runtime mas aquele "Avisynth open failure - BlindPP: Work in YV12 colorspace" ainda continua! O que eu faço?
Já estou até pensando em desistir desses scripts do avisynth!

Meu script ficou assim:

AviSource("C:\Filmes\Movie.avi",false)
ConvertToYUY2()
#addborders(0,8,0,0)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
GripCrop(528, 480, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()
TextSub("e:\legenda.smi")
#Sampler(length=24)


Beijo!
Reply With Quote
  #6  
01-13-2004, 10:55 AM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Oi Fabiana!
Puxa que pena, ainda continua o erro?
Xiiiii marquinhos...
Vc atualizou seu divx?
Seria bom...
Tente isso tb.
Vamos ver se o VMesquita te ajuda tb.
Quote:
Já estou até pensando em desistir desses scripts do avisynth!
Mas já?
Hehehe...
Olha Fabiana, demora um pouco mesmo até vc conseguir seu KVCD.
Todos demoraram para conseguir.
Não desista, vale a pena ter paciência.
Outros problemas irão aparecer, mas vc tira de letra.
Atualize seu divx e vamos ver no que dá.
Abraço
Reply With Quote
  #7  
01-13-2004, 11:31 AM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
O vídeo que estou querendo encodar está em Xvid com som AC3 e instalei os codecs semana passada (baixei o Xvid do superdownloads.com.br)!

Eu sei que é preciso ter paciência mas nos tutoriais parecia tudo tão fácil e agora isso?!

Obrigada por tudo!

Beijo
Reply With Quote
  #8  
01-13-2004, 11:36 AM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Oi Fabiana!
Dá uma olhada nesse post:
http://www.kvcd.net/forum/viewtopic.php?t=8451
Abraço
Reply With Quote
  #9  
01-13-2004, 12:30 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Dei uma mexida no Enviromental setting do Tmpgenc de acordo com o post e reinstalei o codec Xvid... e continua tudo na mesma!

Oh my God!


Beijo!
Reply With Quote
  #10  
01-13-2004, 12:38 PM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Ohhhhhhhhh noooooo...
Xiiii Marquinhos...
E agora?
Hehehehe...
Vou procurar
1 minuto
Reply With Quote
  #11  
01-13-2004, 12:47 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Alterei o script colocando # na frente de BlindPP(cpu=4) e achei um novo erro:

Avisynth open failure
Evaluate: Unrecognized exception!
(c:\Programas\kvcd\divx.avs, line 7)

O script ficou assim:

AviSource("C:\Filmes\Movie.avi",false)
ConvertToYUY2()
#addborders(0,8,0,0)
#BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
GripCrop(528, 480, overscan=1, source_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()
TextSub("e:\legenda.smi")
#Sampler(length=24)

Seguindo o padrão do erro anterior, parece que dessa vez o problema está na linha "GripCrop(528, 480, overscan=1, source_anamorphic=false)"

Será que não é a falta de algum plugin? Qual é o plugin que trabalha com essa linha e com a linha BlindPP(cpu=4) ?

Beijo
Reply With Quote
  #12  
01-13-2004, 12:50 PM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Quando vc coloca # na frente da linha do script, vc desativa a leitura do mesmo.
Não é falta de plugin não.
Vamos achar o problema.
Vc tem o Divx na máquina tb?
Abraço
Reply With Quote
  #13  
01-13-2004, 12:58 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Eu já sabia disso, zakimart!
Eu desabilitei a linha BlindPP e ele pulou para o erro seguinte!
Tenho todos os codecs conhecidos tanto os de aúdio quanto os de vídeo!

Beijo
Reply With Quote
  #14  
01-13-2004, 01:50 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Só para teste desabilitei quase todas as funções problemáticas do script e o virtualdub carregou o mesmo!

O script ficou assim:

AviSource("C:\Filmes\Movie.avi",false)
ConvertToYUY2()
#addborders(0,8,0,0)
#BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
ATC(2,3,5,0.5,false)
#GripCrop(528, 480, overscan=1, source_anamorphic=false)
#GripSize(resizer="LanczosResize")
#Undot()
#TemporalSoften(2,7,7,3,2)
#DCTFilter(1,1,1,1,1,1,0.5,0)
#GripBorders()
#TextSub("e:\legenda.smi")
#Sampler(length=24)

Claro que não desabilitei todos de uma vez só, fiz um por vez e ocorreram os seguintes erros:

Script error: Invalid arguments to function GripSize (linha
UnDot: Only SSEMMX CPU`s currently supported (linha 9)
There´s no function named DCTFilter (linha 11)
Script error: Invalid arguments to function GripBorders (linha 12)


Aparentemente o único que passou foi o Blockbuster!

Beijo
Reply With Quote
  #15  
01-13-2004, 01:52 PM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Acho que vc não pode desabilitar a linha blind.
Infelizmente não sei o que poderia ser.
Ve se tem o plugin GripFit_yv12.dll na máquina.
Espere que alguém vem te auxiliar.
Sinto muito ...
Abraço
Reply With Quote
  #16  
01-13-2004, 02:27 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Tenho esse plugin instalado sim!

Acho que sairia mais em conta codificar o avi direto no tmpgenc do que usar o script do jeito que eu deixei ele!
Foi uma atitude desesperada!

Obrigada por ter me ajudado a tarde toda zakimart!

Beijo!
Reply With Quote
  #17  
01-13-2004, 02:49 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
É realmente necessário usar o avisynth, plugins e scripts para encodar um filme? A diferença é assim tão visível?
Terei algum ganho na velocidade do encode?

Estou precisando de incentivos!

Beijo!
Reply With Quote
  #18  
01-13-2004, 03:24 PM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Oiiii...
Quote:
É realmente necessário usar o avisynth, plugins e scripts para encodar um filme? A diferença é assim tão visível?
A diferença é bem visível... bem mesmo.
Os plugins servem para dar uma melhor qualidade para o seu vídeo.
É... vc vai ver quando conseguir.
Faça KVCDs de VOBs que vc vai ficar doidinha.
Eu não faço AVIs.
Fiz um uma vez que me deixou
Hehe...
Faz assim, desinstala tudo e instala de novo.
Volta para o começo, com calma.
Abraço
Reply With Quote
  #19  
01-13-2004, 05:57 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mas a qualidade do divx ou xvid original é mantida ou há uma perda significativa da mesma quando encodado para kvcd??

Tudo bem, vou tentar tudo de novo!

Você disse que coloca os plugins na pasta do moviestacker, é indicado usar esse programa?

Você poderia enviar os plugins que vc usa para o meu e-mail?
fabianapazneves@terra.com.br

Muito obrigada por tudo!

Beijo
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
TMPGEnc: changes the runtime of movie novagte Video Encoding and Conversion 1 02-21-2005 09:31 AM
Runtime Error que aparece no Diko 0.74 iachel Conversão e Codificação de Vídeo (Português) 6 08-20-2004 09:36 AM
DVD Lab Runtime error! Program compile.aux khusru Authoring VCD, DVD, Blu-ray 6 03-26-2004 04:23 AM
Kvcd Scripts and Runtime? kev23m Video Encoding and Conversion 21 03-04-2004 06:24 PM
Vsfilter giving me a runtime error? totonho03 Avisynth Scripting 9 08-04-2003 04:00 PM

Thread Tools



 
All times are GMT -5. The time now is 05:13 AM  —  vBulletin © Jelsoft Enterprises Ltd