digitalFAQ.com Forum

digitalFAQ.com Forum (http://www.digitalfaq.com/forum/)
-   Video Hardware Repair (http://www.digitalfaq.com/forum/vcr-repair/)
-   -   Leitch DPS-475 fail "no loadable firmware found" (http://www.digitalfaq.com/forum/vcr-repair/8074-leitch-dps-475-a.html)

JohnGalt48 06-23-2017 09:02 AM

Leitch DPS-475 fail "no loadable firmware found"
 
I have purchased several DPS-475 TBC/frame syncs from eBay and have great luck with them. One of them, which has been working fine until recently, now lights up all the LEDs on the panel and displays "no loadable firmware found" on the display.
I have never tried any sort of network connections with these units, as I haven't needed to. Any thoughts of what I need to do to try and and fix this problem? Could I somehow connect to this thing and copy firmware from another one of my units? If so, how would I do that?
Thanks for any leads on this....

NJRoadfan 06-23-2017 10:45 AM

The procedure to update the firmware requires connecting the unit to a computer via the RS-232/422 port. From there you are supposed to use the Leitch uploader software. Looks like another forum user located that: http://www.digitalfaq.com/forum/vcr-...eitch-tbc.html

Finding the DPS-475 firmware is another story. Leitch was bought out by Harris, who doesn't have any links or support information for these units. They used to be on their FTP site, which wasn't archived: http://lsv.uky.edu/scripts/wa.exe?A2...F=&S=&P=177289

JohnGalt48 06-23-2017 11:58 AM

I did run across that uploaded software in my search, but it seems like the device needed to at least boot up to access the network settings to get to it from a computer. Should I connect it to my network anyway and see what happens?

NJRoadfan 06-23-2017 02:13 PM

The Ethernet port is not used at all for loading firmware and is likely unusable right now anyway. The manual states its for remote control of the device.

JohnGalt48 06-23-2017 02:49 PM

That's what I was thinking as well. How is firmware loaded and...how did it get "un" loaded, I wonder?
It worked great for months until last week.


All times are GMT -5. The time now is 09:17 PM

Site design, images and content © 2002-2022 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2022 Jelsoft Enterprises Ltd.