digitalFAQ.com Forum

digitalFAQ.com Forum (http://www.digitalfaq.com/forum/)
-   Capture, Record, Transfer (http://www.digitalfaq.com/forum/video-capture/)
-   -   Various ATI MMC registry hacks (http://www.digitalfaq.com/forum/video-capture/164-ati-mmc-registry.html)

admin 02-15-2005 09:23 AM

from
http://www.videohelp.com/forum/viewtopic.php?t=213534

Quote:

SCHEDULED recording problem, ONE TOUCH rec preset problem and RECORDINC PRESETS problems with MMC 8.9 & AIW 9000 PRO (the settings are not saved into the registry correctly).

__________________________________________

DESCRIPTION of my HW/SW and BACKGROUND


I have an Connect 3D All In Wonder 9000 PRO (Powered by ATI) and my OS is XP with SP-1, additional SW includes WME 9 and DirectX 9.0b with TV-tuner hotfix (before installing the fix I lost the TV-tuner completely after installing DirextX 9). The hotfix took care of the TV tuner problem.

Recently I upgraded from MMC 7.6 to MMC 8.6 and further to MMC 8.9 and also installed the new XP drivers and Catalyst 4.2.

Now to the problems; after this my scheduled VCR recordings choose the wrong input, when choosing the composite input as the source I get timed recordings from TV tuner instead, always from the tuner channel 8. Also the one touch recording naming and duration is messed up, sometimes I get the capture name from the scheduled VCR recording settings and most annoying, the one touch recording stops at the time the last executed capture was stopped!

I upgraded to MMC 8.9 but the same problems are still there. With MMC 7.6 these issues worked just fine.

I did the un-installation completely; the instructions I followed are later in this message. They didn't help, anyway. But I found some answers and workarounds if they would help somebody with the same problems, and what I heard, many people are experiencing the same ones.

__________________________________________________ _______

1. DETAILED DESCRIPTION AND MANUAL SOLUTION TO THE SCHELUDED REC WRONG INPUT PROBLEM

Scheduled VCR recordings choose the wrong input, when choosing the composite input
as the source I get timed recordings from TV tuner instead (always from the tuner channel 8
The problem occurs only when changing or modifying a scheduled event or creating a new one.

Manual Solution:
The only solution I found is to put the settings as they should be in MMC and then close the MMC.
Then directly go the registry under:
[HKEY_USERS\S-1-5-21-220523388-1979792683-682003330-1003\Software\ATI Technologies\MultiMedia\Features\Schedule\0\Captur e]

and see that there is the following entry under each scheduled event "Channel"=dword:00000000 , which stands for composite input. Otherwise the channel number in question, if the capture is intended from a specific TV tuner channel.

EXTRACT the whole scheduled branch from there to a reg. entry (shortcut to desktop) and run it if the settings are again messed up.

__________________________________________________ _______

2. DETAILED DESCRIPTION AND MANUAL SOLUTION OF ONE TOUCH REC SETTINGS PROBLEM

One touch recording naming and duration is messed up, sometimes I get the capture name from the scheduled VCR recording settings
and most annoying, the one touch recording stops at the time the last executed capture was stopped! MMC will write the presets over by its own will.


Manual Solution:
The solution I found is to put the settings ok (one touch rec duration here to 3 hours and name "One Touch Rec") and close the MMC.
Then directly go the registry under:

[HKEY_USERS\S-1-5-21-220523388-1979792683-682003330-1003\Software\ATI Technologies\MultiMedia\Features\TV\Video Capture\Custom Data]
"Maximum Capture Days"=dword:0000001f
"Customized Capture Duration Seconds"=dword:00004650
"Minimum Capture Duration Minutes"=dword:00000005
"Custom"="OneTouchRec"

[HKEY_USERS\S-1-5-21-220523388-1979792683-682003330-1003\Software\ATI Technologies\MultiMedia\Features\TV\Video Capture\Custom Data\Pattern Data]
"Custom"="OneTouchRec"

EXTRACT the above branch to a reg. entry (shortcut to desktop) and run it EVERY TIME AFTER something has been recorded.


__________________________________________________ _______

3. DETAILED DESCRIPTION AND MANUAL SOLUTION OF RECORDING PRESETS PROBLEMS

The MMC doesn't remember the recording preset settings; the four defaults are set.
This doesn't happen if I just close the MMC 8.9 and start it again. The problem occurs on REBOOT.

Manual Solution:
The solution I found is to put the settings as you wish and close the MMC. Then directly go the registry under:
[HKEY_USERS\S-1-5-21-220523388-1979792683-682003330-1003\Software\ATI Technologies\MultiMedia\Features\TV\Video Capture]
and EXTRACT the whole branch to a reg.entry (schortcut to desktop) and run it EVERY TIME AFTER REBOOT BEFORE STARTING MMC.


__________________________________________________ _______

4. "atidvcr.dll" RELATED DE-INTERLACENG PROBLEM WITH DVD RESOLUTION when upgrding to MMC 8.6 to MMC 8.9

Not related to the above, With MMC 8.9 came also another "atidvcr.dll" related issue, when capturing using the DVD resolution and checking in the modified settings the De-interlaced to remove the "combing effect", I still do get blurry double details in fast moving scenes. Not that combing effect but the obviously de-interlacing is not done properly. With MMC 8.6 this setting gave me perfect results. I manually replaced the MMC8.9 atidvcr.dll file with one from MMC 8.6 and the problem was gone, though I lost the new MPEG-4 presets as well. Not good.


__________________________________________________ _______

APPENDIX: COMPLETE UNINSTALL INSTRUCTIONS I TRIED BEFORE ALL THIS. They didn't help, anyway.

Uninstalled all ATI software, cleaned the registry for all ATI references, deleted everything in Windows, system 32, temp and installation directories according to the instructions for a complete uninstall further below.
Then installed in following order:

1. tv-capture-wdm-6-14-10-6227.exe
2. Windows XP Display Driver version 6.14.10.6422
(wxp-w2k-7-981-040127m-013420c.exe) (02-11-2004)
3. control-panel-7-981-040127m-013420c.exe
4. mmc-8-1-0-0-dao-mdac.exe
5. mmc-8-9-0-0.exe
6. remote-wonder-2-2-0-1-english.exe

...but still the same problem!! Scheduled recordings from composite start capturing from TV tuner!!! Frustrating!!


Here are the instructions I followed..

__________________________________________

Uninstall

Remove all ATI drivers and programs that are listed in add/remove programs. Do not restart. Do not save any custom settings if asked whether you would like to do so. Double click on My comp. on your desk top. ..double click on the C drive.. double click on program files.. Delete the ati multimedia folder(if present)..DO NOT REBOOT.

Please go to: C:\windows(or winnt)\Temp and empty the contents of the temp folder ( C: may be replaced by whatever letter represents the local drive); C:\program files\common files rename the install shield if it is listed, to OLDINSTALL SHIELD. ( C: may be replaced by whatever letter represents the local drive)


Registry edit

Go to : Start..Run...Type regedit.. Click OK .. Click on Registry on the menu bar..Export ALL of the registry to the desktop. Click on the plus sign beside Hkey local machine...click on the + sign beside software...delete the ATI folders.

Click on the + sign beside hkey current user....click on the + sign beside software...delete any ati folders..
Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion \Uninstall remove all ati keys
Also under the install key, highlight all folders, if any reference to ati is made in the right window then delete this folder also.
- Exit the registry
- Reboot to safe mode
- During reboot, hit F8 or hold down CTRL to bring up the MS Start Up Menu.
- Select safe mode.
- Set Performance slider to full
- Go to advance display properties click on trouble shoot.. set the slider to full
- Open the Control Panel and double-click on System. Click on hardware
- Then select the Device Manager Button and click on the plus + sign next to Display adapters.
- Remove ALL VIDEO CARDS LISTED UNDER THE DISPLAY ADAPTER HEADING.
- Remove all Monitors as well.( if present)
- Also click on the + sign beside Sound Video and Games and remove everything that says ati.
- Do a search for ati*.* in C:\winnt\system32 ..remove all ati files found.
- Do a search for ati*.* in C:\winnt\system ..remove all ati files found.
- Reboot to Normal Mode. Windows will detect new hardware , let it install its drivers...reboot ...


Install the new display driver(s) and software : Use the ati installation CD

OR

If you are using the downloaded ATI driver(s) and software, then please use the following order of install as a guide in the process of reinstalling them



Order of install:

Please install the capture drivers first (only needed for All In Wonder and cards with VIVO), restart.
then install the catalyst driver, restart
install the control panel, restart
install DAO/MDAC, restart
install the dvd player, restart
install the multimedia centre, restart
install the remote control software (if needed)




All times are GMT -5. The time now is 08:07 AM

Site design, images and content © 2002-2021 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2021 Jelsoft Enterprises Ltd.