digitalFAQ.com Forum

digitalFAQ.com Forum (http://www.digitalfaq.com/forum/)
-   Video Hardware Repair (http://www.digitalfaq.com/forum/vcr-repair/)
-   -   Panasonic S-VHS VCR Service Manuals (PDF) [DOWNLOADS] (http://www.digitalfaq.com/forum/vcr-repair/3672-panasonic-vhs-vcr.html)

kpmedia 11-21-2011 05:38 AM

Panasonic S-VHS VCR Service Manuals (PDF) [DOWNLOADS]
 
4 Attachment(s)
For repairing Panasonic professional S-VHS VCRs...

Edit -- Admin Note: You must be logged in to download files. If you're not already a member, then register now as a Free Member.
Or better yet, upgrade to a Premium Member status to support the community and get access to exclusive emails, newsletters and site content.

berkfaq 12-07-2011 10:41 PM

KPMedia,
Thanks. Hopefully the info in the service manuals will help in restoring the operation of my AG-1980, since it just loads and then ejects any tape I insert.

wdwms 03-30-2012 03:08 PM

Mine 1980 is doing the same.. any luck fixing it?

lordsmurf 03-30-2012 09:51 PM

Sometimes having a repair manual still is not enough information to fix a VCR. You'll likely need parts and some experience with repair. The service manuals may only help you in finding out what's wrong -- not in fixing the problem. In fact, sometimes a DIY job will just risk breaking the unit even more, as VCR internals can be quite delicate, brittle or flimsy!

Where are you located? If in the USA, then considered sending it to a reliable repair shop. All of our equipment is serviced by Jots Electronics in the Dallas, Texas metro. I'd say the average total cost (repair, cleaning, shipping) of the AG-1980P units is about $300. But these are pro decks, and very much worth it. If this is equipment used for a business, just invest in the pro repair work.

wdwms 03-30-2012 09:59 PM

Worked on vcrs as a kid growing up. Took this one apart and checked out everything. Really aligned and adjusted a few things and tried different positions of the mode switch. Oddly it wasn't aligned correctly but the correct position didn't solve the problem.
I put the unit into service mode. No error codes. Restarted machine and Viola. All was well. Go figure!

lordsmurf 03-30-2012 10:04 PM

Quote:

Originally Posted by wdwms (Post 20109)
I put the unit into service mode. No error codes. Restarted machine and Viola. All was well. Go figure!

How funny! Maybe it just wanted some attention? :P

wdwms 03-31-2012 08:33 AM

Quote:

Originally Posted by lordsmurf (Post 20111)
How funny! Maybe it just wanted some attention? :P

Lol.. maybe! i went through all the service modes spending some extra time with 7. Making the tape go in and out.. maybe it just cleared something out..


All times are GMT -5. The time now is 11:34 PM

Site design, images and content © 2002-2021 The Digital FAQ, www.digitalFAQ.com
Forum Software by vBulletin · Copyright © 2021 Jelsoft Enterprises Ltd.