Quantcast Avisynth: Script Playback in Media Plyer Motion Jerky or Smooth? - digitalFAQ.com Forums [Archives]
  #1  
03-26-2004, 05:50 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
when playing back a avisynth script in media player is the motion supposed to be jerky or smooth?

iv noticed that on some of the xvids iv done the playback of the script in media player on some occasions it has been smooth and on others quite jerky
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
03-26-2004, 05:55 AM
incredible incredible is offline
Free Member
 
Join Date: May 2003
Location: Germany
Posts: 3,189
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to incredible
Quote:
when playing back a avisynth script in media player is the motion supposed to be jerky or smooth?


The playback in avisynth depends primary on your included processing routines/filters and therefore your CPU power.

So u are talking about script preview playback and NOT ready encoded mediafile (mpeg) playback ???
Reply With Quote
  #3  
03-26-2004, 06:05 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
yeh script preview playback, when i just double click the script. some movies the motio has been smooth other not?

the script is the optimal one from the xvid conversion page,
Reply With Quote
  #4  
03-26-2004, 06:15 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
i asked because some times my output video the motion has not been smooth. even when iv kept the standard the same (ntsc23.9 to ntsc 23.9).
i burned the file to dvd and played back on my computer but couldnt really notice it but when played on my tv i could see it was jerky on moving scenes

i know its only a small thing but its noticeable and is well annoying, any ideas what the problem may be incredible?
my source is good, very high quality xvid
Reply With Quote
  #5  
03-26-2004, 07:04 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Do you expect that the filters in the script are immediate ?
The encoding time won't be in hours if that was so fast.

In other word : YES, the playing is jerky.
Reply With Quote
  #6  
03-27-2004, 08:14 AM
Paulus Paulus is offline
Free Member
 
Join Date: Jun 2003
Location: Ottersum, The Netherlands
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same problem on some Xvid - MPEG transcodes ....."jerkyness" .

But when I play the .avs file in BSplayer it plays smoothly (with subs / textsub)..........

???
Reply With Quote
  #7  
03-27-2004, 08:54 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Paulus
But when I play the .avs file in BSplayer it plays smoothly (with subs / textsub)..........
If your script does nothign or your PC is extremly fast that's also normal.

Is is SO difficult to understand that filters are mathematical operations that needs CPU time to be processed ?

Note: even smooth, look at the rendered framerate. Chances are great that this is not 25 fps.
Reply With Quote
  #8  
03-27-2004, 01:55 PM
Paulus Paulus is offline
Free Member
 
Join Date: Jun 2003
Location: Ottersum, The Netherlands
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
My CPU is an Athlon XP 2400 with 512 Mb RAM. Reasonably fast but not "extreme".

Of course I understand that we are talking about mathematical operations.......Just that I read in this thread that it's so normal for an .avs script to play back jerky in a media player.....

Quote:
Note: even smooth, look at the rendered framerate. Chances are great that this is not 25 fps.
Don't know exactly what you mean but, in my case, it's a 25fps.
Reply With Quote
  #9  
03-27-2004, 03:02 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
I really don't know what is your script but if you can play it at 25 fps (which resolution ?) your PC is definitely fast
Reply With Quote
  #10  
03-30-2004, 12:50 PM
Paulus Paulus is offline
Free Member
 
Join Date: Jun 2003
Location: Ottersum, The Netherlands
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
....I played another .avs file directly in BSplayer at full screen (23.976fps 480x480) and it plays smooth .


(Playing it in Zoomplayer shows a split screen with green colored distorted image by the way..... ).

How to get Zoomplayer play the .avs properly ?

LoadPlugin("C:\PROGRA~1\DVD2SVCD\AVISYN~1.5PL\Mpeg 2dec\MPEG2D~1.DLL")
AVISource("D:\Everwood\EVERWO~4.AVI",False)
ConvertToYUY2()
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
GripCrop(480, 480+0+0, overscan=1, source_anamorphic=false, dest_anamorphic=false)
GripSize(resizer="LanczosResize")
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
GripBorders()
function ConvertToYUY2(clip c){ return isYV12(c) ? c : convertToYV12 (c) }
Reply With Quote
  #11  
03-30-2004, 01:14 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Your problem with zooplayer is probably due to a directshow filter taht is used. Probably ffdshow.
I have this sometimes and I rid of that by not allowing ffdshow to output in YUY2.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
KVCD video has Jerky motion? kev23m Video Encoding and Conversion 3 05-06-2004 02:07 PM
KVCD: Jerky Motion and AssumeFPS() ? Jellygoose Avisynth Scripting 4 06-27-2003 02:02 AM
Jerky VCD Playback? miksmith Players, DVRs, Media Centers 24 02-03-2003 01:45 PM
KVCD: Non-smooth playback of scrolling movies? wouter Video Encoding and Conversion 2 01-26-2003 12:34 PM
KVCD: motion in the video is not smooth? mgaitonde Video Encoding and Conversion 10 06-06-2002 09:56 AM

Thread Tools



 
All times are GMT -5. The time now is 04:21 PM  —  vBulletin Jelsoft Enterprises Ltd