Quantcast Problemas con Audio Desfasado en KVCD - digitalFAQ.com Forums [Archives]
  #1  
05-17-2005, 09:58 AM
Hellfire Hellfire is offline
Free Member
 
Join Date: Apr 2005
Location: Argentina
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Tengo un problema con un archivo de audio extraido de un .avi. En el .avi funciona perfecto en cuanto a su sincronismo. Pero luego de extraer el audio (que originalmente es un archivo .mp3), convertirlo en un archivo .mp2 y vuelto a multiplexar con TMPEnc (video mpeg-1 y audio mpeg-2) me queda desplazado el audio del video.

Como puedo hacer para volver a sincronizarlo? Ya intenté con el VirtualDubMod y no logro hacerlo. alguien podria sugerirme algun otro SW que me permita agregar retardos en el archivo de audio para poder sincronizarlo con el video?

Muchas gracias.

Saludos.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
05-17-2005, 10:18 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
¿Que utilizadas para convertir de mp3 a mp2? Puedes generalmente introducir un delay en el momento de la conversión (positivo o negativo).

Sino utilizadas bbmpeg para multiplexar.
Reply With Quote
  #3  
05-17-2005, 10:48 AM
Hellfire Hellfire is offline
Free Member
 
Join Date: Apr 2005
Location: Argentina
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Para pasar de mp3 a mp2 utilizo HeadAC3he v0.24-a10.

En realidad lo que probé es introducir los retrasos (interleave) dentro del VirtualDubMod y luego convertir con el HeadAC3he. Pero me parece que al convertir el archivo se pierden los retrasos introducidos.

Tambien probé hacerlo directamente desde el HeadAC3he en la opcion que dice "Delay: .... ms" y tampoco consigo los retardos que necesito.

Voy a intentar con el bbmpeg para ver si es que consigo los resultados que necesito.

Nunca lo utilicé, pero lo voy a ver.

Gracias.

Saludos.
Reply With Quote
  #4  
05-17-2005, 11:06 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Hellfire
En realidad lo que probé es introducir los retrasos (interleave) dentro del VirtualDubMod y luego convertir con el HeadAC3he. Pero me parece que al convertir el archivo se pierden los retrasos introducidos.
El plazo es introducido por virtualdub durante el multiplexado, para convertir headache tiene necesidad de demultiplexar. ¡ no saldrás nunca así!
Reply With Quote
  #5  
05-17-2005, 11:12 AM
Hellfire Hellfire is offline
Free Member
 
Join Date: Apr 2005
Location: Argentina
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Pero tambien intenté introducir los retrasos directamente en HeadAC3he y tampoco me respeta los tiempos introducidos.
Reply With Quote
  #6  
05-17-2005, 12:48 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Hellfire
Pero tambien intenté introducir los retrasos directamente en HeadAC3he y tampoco me respeta los tiempos introducidos.
Probas besweet.
Reply With Quote
  #7  
05-17-2005, 01:15 PM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Has hecho algún cambio de norma pal a ntsc o visceversa?
Reply With Quote
  #8  
05-17-2005, 01:28 PM
Hellfire Hellfire is offline
Free Member
 
Join Date: Apr 2005
Location: Argentina
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
No. En realidad, la pelicula estaba en un avi y lo que yo he hecho, como lo hice tantas otras veces, fue separa el video del sonido con virtualdubmod, procesar el video (sin audio) para lograr un archivo .m1v (con TMPEnc). Luego, procesar el audio con HaedAC3he para obtener mi archivo .mp2 y luego multiplexarlo con TMPEnc. hasta ahora no habia tenido ningun problema con estao, más allá de subtitulos desfasados (Que generalmente se los pegaba, yo mismo con mi script .avs).

Por lo tanto la norma de ambos archivos es la que originalmente traian. Ya que ambos pertenecian al mismo .AVI.

Por eso es que estoy tan desconcertado. Lo unico que pude advertir es que cuando abro el archivo de sonido (extraido del .AVI) en formato mp3 para empezar a convertirlo en mp2, me da un mensaje el HeadAC3he como que el archivo tiene los ultimos frames corruptos (esto es cuando lo carga, ya que hace un scan automatico).

Lo que estoy haciendo es buscar otro archivo de sonido para esa pelicula para poder procesarlo y pegarlo a mi archivo m1v. Y rogar que el archivo que consiga pertenezca a la misma version del avi original.
Reply With Quote
  #9  
05-17-2005, 07:06 PM
maurus maurus is offline
Free Member
 
Join Date: Oct 2003
Location: Madrid
Posts: 387
Thanks: 0
Thanked 0 Times in 0 Posts
Hola amigo.

Me parece que Prodater64 puede tener razón. Seguramente sea un AVI cuyo video este codificado en NTSC que tiene un frametrate distinto del PAL y cuando esto pasa, y no tomas las precauciones necesarias a la hora de pasar el audio a MP2, de forma progresiva dicho audio se va desincronizando del video cada vez mas segun avanza la pelicula.

Para evitarlo, usa BeSweet en la conversion al mp2. Busca la documentacion de la herramienta, la clave esta en el parametro:

Code:
ota( -r 29970 25000) 

o

ota( -r 23976 25000)
según sea tu NTSC incluido en el AVI. Para ver si realmente es NTSC y cual de ellos es, abre el AVI con GSPot o AviCodec, que te dan toda la info.

También estate atento al delay si lo hubiera, lo cual se corrige con el parametro -d del BeSweet. Esto puede ocurrir con los AC3, pero en tu caso yo creo que es lo primero que te apuntamos.

Nunca te ocurrió porque tu proceso de conversión es correcto y totalmente ortodoxo, pero quizá no topaste con un AVI NTSC realizado por otra persona en cuyo pais esté vigente dicha norma.

Un saludo.

-Maurus
Reply With Quote
  #10  
05-18-2005, 09:48 AM
Hellfire Hellfire is offline
Free Member
 
Join Date: Apr 2005
Location: Argentina
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Maurus,

las veces que he hecho este proceso, utilicé todas la variantes. Es decir, que si el archivo era PAL, lo procesé como PAL. Si el archivo era NTSC (ya sea 23.976 o 29.970 FPS) lo procesé como NTSC y tambien como PAL. Y nunca tuve ese problema.

Voy a hacer la prueba que me sugieren para ver si es que se soluciona el problema o bien, es esperar a que termine de bajar un nuevo archivo de audio y procesarlo para ver si es que funciona.

Muchas gracias.

Saludos. Y estaremos en contacto en cuanto tenga los resultados.
Reply With Quote
  #11  
05-18-2005, 12:08 PM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Este hilo comienza a transcurrir por una zona gris. Si sigue en la misma temática no tendré más remedio que cerrarlo. Por ahora, como tengo una duda razonable sobre que tipo de material se está hablando, es que hago la advertencia, pero recuerdo, que cualquier mención a descargas de material copyrighted está TOTALMENTE PROHIBIDO.
No es necesario que contesten este post, simplemente sirva como único y último aviso, gracias.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Problemas na captura do audio cast34 Conversão e Codificação de Vídeo (Português) 2 12-06-2004 04:40 PM
DIKO - Problemas com audio AC3 samesdavis Conversão e Codificação de Vídeo (Português) 1 06-21-2004 04:04 AM
Ae blz! Problemas com audio AC3 5 Canais HOBBIT_SM Conversão e Codificação de Vídeo (Português) 3 01-12-2004 01:47 PM
Problemas com o audio Raivos Conversão e Codificação de Vídeo (Português) 0 12-11-2003 10:02 PM
Problemas con el audio XalaX Convertir y Codificar Video (Español) 11 09-22-2003 05:40 PM

Thread Tools



 
All times are GMT -5. The time now is 07:04 PM  —  vBulletin © Jelsoft Enterprises Ltd