Quantcast Desincronizzazione Dell'Audio Rispetto al Video - digitalFAQ.com Forums [Archives]
  #1  
04-26-2004, 04:11 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Salve a tutti.
Grazie a DIKO (al momento uso la versione 0.43), sono riuscito anche io a creare alcuni kvcd con piena soddisfazione.
Tuttavia, ho notato che per alcuni film si verifica un probelma di desincronizzazione dell'audio rispetto al video di parecchi secondi. Cosa posso fare?

Grazie a tutti in anticipo e continuate così!!!
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
04-28-2004, 03:39 AM
logan555 logan555 is offline
Free Member
 
Join Date: Nov 2002
Location: Italy
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to logan555
Non uso dico, ma lo sfasamento lo hai su file di dvd o divx o entrambi?
__________________
Resistence is futile.
Reply With Quote
  #3  
04-29-2004, 12:20 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Sul divx è ok, mentre su dvd (o, meglio, dovrei dire su kvcd) c'è uno sfasamento notevole fra l'audio e il video (sicuramente più di 10 secondi).
La cosa strana è che con alcuni film in divx, seguendo esattamente la stessa procedura, la conversione è andata ok: ma allora da cosa può dipendere?

Ciao e grazie della risposta.
Reply With Quote
  #4  
05-03-2004, 02:22 AM
logan555 logan555 is offline
Free Member
 
Join Date: Nov 2002
Location: Italy
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to logan555
Succede spesso che i divx siano stati multiplexati ( miscelata cioè la traccia audio e video in un solo file , che sarebbe l'avi) conun o sfasamento di tempo fra audio e video per poter migliorare la sincronizzazione.
Quindi succede che la traccia audio e la traccia video non iniziano allo stesso istante ma devono essere allineate in qualche modo.
Ecco che convertendo quindi l'audio e il video separatamente e riunendo insieme le 2 tracce bisogna considerare che all'origine erano sfasate.
Questo succede poche volte per fortuna.
Per riallineare il tutto devi demultiplexare con tmpgenc l'audio dal video , e rimultiplexarli con bbmpeg specificando di quanto sfasare l'audio dal video.
Per capire di quanto effettuare questo sfasamento puoi fare con bbmpeg solo pochi secondi di multiplexing e verificare finchè non ottieni il risultato voluto.
__________________
Resistence is futile.
Reply With Quote
  #5  
05-03-2004, 03:05 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts

mmmm... sono un pò confuso: dove posso trovare qualche guida che mi spieghi come fare questo lavoro?

E poi scusa, ma mi sorge un dubbio: lo sfasamento avviene solo dopo che ho fatto la conversione; l'allineamento audio/video quindi lo devo rifare sul file .mpg creato (prima di masterizzarlo) o devo comnunque farlo sul file .avi?

Grazie comunque per la risposta.
Reply With Quote
  #6  
05-04-2004, 01:33 AM
logan555 logan555 is offline
Free Member
 
Join Date: Nov 2002
Location: Italy
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to logan555
Sono stato un po' frettoloso nella spiegazione.
Vediamo di fare un punto.
Allora ogni file di tipo video è composto da 2 parti
1) parte video
2) parte audio
Per poter avere un unico file ( avi,mpeg,mov,etc...) si procede ad effettuare un multiplexing ( unione ) delle 2 tracce video e audio.
Questo praticamente porta a scrivere nel file alternate un pezo di video ed un pezzo di audio, di nuovo un pezzo di video e un pezzo di audio. Una volta creato il file avi o mpeg il lettore comincia a leggere il file e lo rimette correttamente insieme leggendo un pezzo video il suo pezzo audio e facendoli vedere e sentire insieme. Può succedere che in questa fase di multiplexing per allineare il video con l'audio , una delle due tracce venga sfasata di alcuni millisecondi. In questo modo avrò le 2 tracce video e audio non allineate mentre il file multiplexato finale lo sarà.
Se quindi dopo avere ottenuto il file mpeg questo risultasse sfasato allora si deve demultiplexare il file mpeg per ottenere le 2 tracce video e audio ( da tmpgenc mpeg tools).
Con bbmpeg poi le puoi multiplexare nuovamente indicando di quanto sfasare l'audio rispetto al video.
Per capire di quanto è il ritardo o l'anticipo da inserire , se hai fatto un kvcd MPEG1 puoi aprire il file mpeg da virtual dub ed impostare in Audio->interleaving in delay audio track by un valore partendo da 250 o -250 a seconda cha l'audio venga prima o no. E poi fai la preview. Cerca il valore giusto finchè non è sincronizzato. Segnati il valore.
Apri bbmpeg e nel program stream settings togli o aggiungi al valore presente nel campo audio1 il valore che hai trovato in virtual dub.
Questo dovrebbe risolvere la questione.
Se poi il file mpeg fosse mpeg2 allora non puoi usare virtualdub.
Però puoi , una volta avute le 2 tracce video e audio, multiplexare un solo pezzo con bbmepg impostando un delay nell'audio di multiplidi 250 ( + o -) e mettendo nel general setting la conversione di 1 min di filamto .
Ma il divx su cui hai questo problema viene da una conversione dvd o no?
__________________
Resistence is futile.
Reply With Quote
  #7  
05-04-2004, 07:38 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Decisamente no.. il file l'ho scaricato da emule e sto cercando di provarlo a vedere sul lettore di casa: lo sfasamento inoltre, non è di alcuni millisecondi ma, a occhio e croce, è pari ad almeno una quarantina di secondi!!!
In ogni caso seguirò la procedurta che mi hai consigliato e poi ti farò sapere.

Ciao e grazie ancora
Reply With Quote
  #8  
05-04-2004, 11:49 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Ciao Logan... allora....
ho creato il mio solito .mpeg con DIKO e ho verificato l'esistenza dello sfasamento dell'audio rispetto al video (circa un quarantina di secondi).
Ho provato ad aprire il file .mpeg con il Virtual Dub e mi da questo errore: "MPEG Import Filter: pack synchronization error".
Allora ho provato ad aprire con Bbmpeg: per la verità i file eseguibili di questo programma sono due (avi2mpg.exe e avi2mpg2_vfw.exe) di cui non conosco la differenza, In ogni caso mi funziona solo con il secondo ed anche in questo caso, l'uncia cosa che riesco ad ottenere è una semplice anteprima del filmato ma senza audfio: di conseguneza non ho la possibilità di regolare l'AUDIO DELAY (ms) dall'avisitnh monitor. Cosa mi consigli di fare? Dove sto sbagliando?

Ciao e grazie ancora della pazienza dimostrata
Reply With Quote
  #9  
05-08-2004, 06:40 AM
logan555 logan555 is offline
Free Member
 
Join Date: Nov 2002
Location: Italy
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to logan555
Avevo già risposto un po' di giorni fa! Ma non so come non c'è il mio post!
Comunque ecco qua!
Ti ricordo che diki converte in formato mpeg2.
Prova con questa guida fatta all'occasione. Non so se c'è già qualcosa in giro in rete ma così è come faccio io.
http://logan555.spaziofree.net/bbmpeg.html
Buona fortuna!!
__________________
Resistence is futile.
Reply With Quote
  #10  
05-09-2004, 08:58 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Ecco perchè avevo tutti quei problemi con bbmoeg... non immaginavo che ci fosse questo piccolo bug. In ogni caso domani farò una prova e tifarò sapere l'esito... anche se devo rifare prima la conversione con il diko.
Ciao e grazie ancora
Reply With Quote
  #11  
05-10-2004, 04:15 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Ciao Logan,
grazie ai tuoi suggerimenti ora posso lavorarci su quel famoso file, ma mi risulta comunque difficile riuscire a trovare la sincronizzazione giusta.
Tu come ti regoli? Voglio dire, 250ms di audio (o video) a quanti secondi del filmato dovrebbero corrispondere?

Un'ultima cosa: come mai quando provo a collegarmi al link che mi hai dato nel tuo post (quello relativo alla tua guida sul bbmpeg) mi chiede sempre di scaricare un file? Per sicurezza gli rispondo sempre di no, ma mi sorge il dubbio se tu ne fossi informato o meno.

Ciao e a presto
Reply With Quote
  #12  
05-10-2004, 11:27 AM
logan555 logan555 is offline
Free Member
 
Join Date: Nov 2002
Location: Italy
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to logan555
250 ms sono 0,2 secondi.
Grazie per la dritta sul file da scaricare ora verifico . FAi bene comunque a rispondere sempre no!
__________________
Resistence is futile.
Reply With Quote
  #13  
05-19-2004, 02:56 AM
Fabio77 Fabio77 is offline
Free Member
 
Join Date: Mar 2004
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Scusami se non mi sono fatto più sentire ma ho passato un periodo di intenso lavoro che mi ha tenuto lontano dal pc. Comunque sono riuscito a risolvere il mio problema grazie ai tuoi suggerimenti.
Ancora grazie e a presto.

Ciao.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux: Sweet old dell dimension xps r400 with a fast CPU heyitsme Computers 0 08-04-2006 03:32 PM
Desicronização do audio/video !!!!!! cazuza Conversão e Codificação de Vídeo (Português) 6 09-15-2004 06:18 PM
HeadAC3he: Music video DVD audio only, and burning as an audio cd? vdk_au Audio Conversion 1 01-29-2004 07:26 AM
Audio e video DigoBrow Conversão e Codificação de Vídeo (Português) 2 11-04-2003 10:27 AM
KVCD has Audio, But No Video? skullkid51 Video Encoding and Conversion 3 06-11-2002 12:25 PM

Thread Tools



 
All times are GMT -5. The time now is 09:06 PM  —  vBulletin © Jelsoft Enterprises Ltd