Quantcast CCE + um Problema - digitalFAQ.com Forums [Archives]
  #1  
06-03-2004, 07:47 AM
el34 el34 is offline
Free Member
 
Join Date: Sep 2003
Posts: 233
Thanks: 0
Thanked 0 Times in 0 Posts
Olá pessoas,

alguem aqui que usa o CCE já teve problemas com aquele efeito tipo arco-ires em que aparecem degradês, ou seja linhas de contraste separando as diferentes tonalidades de uma mesma cor ou cor próxima será que deu pra entender nunca tinha percebido isto quando usava o TMPEG mas em tres filmes (DVDs) que converti com o CCE esta proplema aconteceu, inicialmente o CCE apresentou um erro : "can´t find apropriate codec for YV12" (ou coisa parecida) então eu acrescentei no script (converttoYUY2), será que é esta a causa?
Detalhe: quando uso o diko (AVI-KDVD) o problema não ocorre.

Help
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
06-03-2004, 09:34 AM
BJ BJ is offline
Invalid Email / Banned / Spammer
 
Join Date: Mar 2004
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Eh problema com seu script.
Posta para nos podermos ver!
Abraços!
Reply With Quote
  #3  
06-03-2004, 09:54 AM
el34 el34 is offline
Free Member
 
Join Date: Sep 2003
Posts: 233
Thanks: 0
Thanked 0 Times in 0 Posts
Blz, óia ela aí:

Quote:
## DLL Section ##
#
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\MPEG2Dec3.dll")
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\GripFit_YV12.dll")
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\STMedianFilter.dll")
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\asharp.dll")
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\unfilter.dll")
LoadPlugin("C:\Arquivos de Programas\Avisynth 2.5\plugins\undot.dll")
#
####

## Defined Variables and Constants ##
#
MaxTreshold = 1.50
nf = 0 # Current frame.
#
####

## Main section and static filters ###
#
Mpeg2Source("D:\filme.d2v")
#
#anamorphic=true se for 16/9 e false se for 4/3
undot()
Limiter()
asharp(1, 4)
GripCrop(720, 480, overscan=0, source_anamorphic=true)
GripSize(resizer="BicubicResize")
STMedianFilter(8, 32, 0, 0 )
MergeChroma(blur(MaxTreshold))
MergeLuma(blur(0.1))
#
#

## Linear Motion Adaptive Filtering ##
#
# ( Portions from AviSynth's manual ) - This will apply temporalsoften to
# very static scenes, and apply variable blur on moving scenes.
# We also assign a variable - and this is why a line break is inserted:

SwitchThreshold = (Width<=352) ? 4 : (Width<=480) ? 3 : 2
ScriptClip("nf = YDifferenceToNext()"+chr(13)+ "nf >= SwitchThreshold ? \
unfilter( -(fmin(round(nf)*2, 100)), -(fmin(round(nf)*2, 100)) ) : \
TemporalSoften( fmin( round(2/nf), 6), round(1/nf) , round(3/nf) , 1, 1) ")

#
#
#

GripBorders()
#LetterBox( Your_Values_Here ) # Depends on situation. Use MovieStacker!
Limiter()

#
#
## Functions ###

function fmin( int f1, int f2) {
return ( f1<f2 ) ? f1 : f2
}

#
####

converttoyuy2()

#Sampler(Length=15)

BJ, obrigado pela ajud!
Reply With Quote
  #4  
06-03-2004, 04:46 PM
zakimart zakimart is offline
Free Member
 
Join Date: Jul 2003
Location: Sao Paulo
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
Oi El!
Vc inseriu a linha converttoyuy2() e não resolveu?
Abraço
Reply With Quote
  #5  
06-03-2004, 07:47 PM
el34 el34 is offline
Free Member
 
Join Date: Sep 2003
Posts: 233
Thanks: 0
Thanked 0 Times in 0 Posts
Já fiz isso sim, antes nem abria o script, depois que acrescentei converttoyuy2 passou a funcionar porem com estes degrades, mas agora a pouco fiz um teste adaptando o script movie.avs que o diko gera e encodou legal com bem menos tempo do que o script que postei,e e aí Vmesquita, o script do diko (para avi) pode funfar bem para d2v?

[]'s

el34
Reply With Quote
  #6  
06-04-2004, 01:10 PM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by el34
Já fiz isso sim, antes nem abria o script, depois que acrescentei converttoyuy2 passou a funcionar porem com estes degrades, mas agora a pouco fiz um teste adaptando o script movie.avs que o diko gera e encodou legal com bem menos tempo do que o script que postei,e e aí Vmesquita, o script do diko (para avi) pode funfar bem para d2v?

[]'s

el34
tenta um script usando só o source:

Mpeg2Source("D:\filme.d2v")
converttoyuy2()
trim(5000,6000)#ajuste estes valores à vontade para teste..1000frames= ~41 segundos

codifique e veja se aparecem as manchas,assim saberemos se o problema é o CCE!
Reply With Quote
  #7  
06-05-2004, 10:26 AM
BJ BJ is offline
Invalid Email / Banned / Spammer
 
Join Date: Mar 2004
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Tah estranho isso!
Aparentemente seu script esta correto.
Tenta o que Jorel falou e posta para nós@
Abraços!
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Problema com som wcellabr Conversão e Codificação de Vídeo (Português) 3 08-27-2004 10:27 AM
Problema con el d2v Bombai Convertir y Codificar Video (Español) 5 11-21-2003 06:15 AM
Problema en ACP indeter Convertir y Codificar Video (Español) 1 09-27-2003 05:33 PM
Problema con PAL Sethi Convertir y Codificar Video (Español) 1 09-26-2003 06:34 PM
Problema CaLaFaT Convertir y Codificar Video (Español) 10 08-19-2003 05:59 AM

Thread Tools



 
All times are GMT -5. The time now is 10:38 PM  —  vBulletin © Jelsoft Enterprises Ltd