Quantcast Avisynth Não Reconhece Funções.. o que Pode Ser? - digitalFAQ.com Forums [Archives]
  #1  
10-29-2004, 09:32 PM
Lord_Marcellus Lord_Marcellus is offline
Free Member
 
Join Date: Jul 2004
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Galera... hj to naqueles dias q nada da certo.. mas vamos lá...Vamos ver se vcs matam a xarada :P Configurei um script para converter um DVDrip, e o avisynth me traz a seguinte mensagem de erro "there is no function named "BlindPP", line 71" isso que, se não estou enganado, o plugin para esta função eh o mpg2dec, que está devidamente instalado na pasta do avisynth. ok... aí vou no script e "comento" a linha do blindPP (#) e ele da o memso erro pro "Blockbuster"e pro Convolution3D nas linhas seguintes, sendo que seus arquivos Dlls estão todos na pasta plugins do avisynth...

O que pode ser????????

PS: este está sendo meu primeiro KSVCD depois de eu ter formatado o PC a três dias... antes ia numa boa.. o que pode ser galera????

Qualquer ajuda agradeço mto.. valew
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-29-2004, 10:47 PM
muaddib muaddib is offline
Free Member
 
Join Date: Jun 2002
Location: São Paulo - Brasil
Posts: 879
Thanks: 0
Thanked 0 Times in 0 Posts
Se vc formatou o micro e somente manteve os diretórios do AviSynth, é esse o problema. O AviSynth procura o caminho para o diretório de plugins no registro do windows. E se vc formatou o micro então apagou tb o registro. Re-instale o AviSynth que resolve o seu problema.

Se bem que eu prefiro não colocar nada no diretório de plugins e carregar individualmente apenas os filtros que irei usar no script. Isso pq pode acontecer de duas ou mais dlls conter filtros com o mesmo nome.

Por exemplo, vamos supor que vc tenha o mpeg2dec2, mpeg2dec3 e o mpeg2dec3dg (ou dgdecoder). Bom todos esses dlls possuem um filtro chamado mpeg2source. Se todos eles estiverem no diretório de plugins, todos eles serão carregados na memória. Agora eu pergunto... de qual dll será usado o filtro mpeg2source

Isso sem falar em otimização de memória...
Reply With Quote
  #3  
10-29-2004, 11:25 PM
jorel jorel is offline
Invalid Email / Banned / Spammer
 
Join Date: Aug 2002
Location: Brasil - MG - third stone from the sun
Posts: 5,570
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by muaddib
Agora eu pergunto... de qual dll será usado o filtro mpeg2source
já aconteceu comigo e é facil de resolver muaddib.se estivermos usando o "autoload" do avisynth sem as linhas de comando "loadplugin,,,etc" simplesmente carrego um script no vdubmpeg2 ,retiro uma das dlls e carrego o script novamente. se por acaso eu retirar a dll que está sendo usada,simplesmente dá erro ao tentar carregar a script(lógico)

o principal: não vejo razão para termos mais de uma dll deste tipo na pasta plugins do avisynth, simplesmente uso a mpeg2dec3.dll de 28/07/03 (Nic) sem usar linhas com loadplugin no script e tudo funciona normalmente.
fiz backup da outras outras versões em outra pasta e, se for necessário,
aí sim, uso o "loadpugin" no script para carregar mas nunca foi preciso!

@ Lord_Marcellus
faça o download da versão que mencionei acima e coloque na pasta "plugins" do avisynth e teste se ainda terá erros.
você encontra o link do warpenterprises para fazer o download da dll dentro do link de downloads aqui do forum português.
poste o resultado após o teste.
Reply With Quote
  #4  
10-29-2004, 11:48 PM
muaddib muaddib is offline
Free Member
 
Join Date: Jun 2002
Location: São Paulo - Brasil
Posts: 879
Thanks: 0
Thanked 0 Times in 0 Posts
Tá certo jorel, isso não é problema... quando vc sabe o que está fazendo. E concordo com vc que não tem necessidade de deixarmos mais de um dll desse tipo dentro da pasta de pluguins. Eu nunca deixei! Mas esse não é o único exemplo de dlls que possuem filtros com o mesmo nome, e tem gente que simplesmente coloca 50 filtros lá e pronto. Carregar todos esses 50 filtros (mesmo que vc só va usar 3 ou 4) toda hora que vc usa o AviSynth é que pode gerar problema.

Mas volto a dizer, se vc souber o que está fazendo e deixar apenas os filtros necessários ou somente os que vc mais usa no autoload... não vai dar nenhum problema.
Reply With Quote
  #5  
10-31-2004, 02:17 PM
Lord_Marcellus Lord_Marcellus is offline
Free Member
 
Join Date: Jul 2004
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Galera... valew a ajuda... bom.. o que eu fiz:

Reinstalei o Avisynth como o vc muaddib falow... baixei esse novo mpeg2dec3 que o vc jorel mencionou... adicionei a linha do loadplugin e funcionou!!

Um grande abraço a vcs dois pela ajuda.. valew!!
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Moviestacker nao reconhece audio? valdmirva Conversão e Codificação de Vídeo (Português) 1 04-12-2005 02:14 AM
AMD 900 não reconhece o filtros Joâo Nova Conversão e Codificação de Vídeo (Português) 4 06-29-2004 08:22 AM
Meu Player não reconhece KVCD? Billldubrasil Conversão e Codificação de Vídeo (Português) 8 05-23-2004 01:26 AM
VCDEasy Funções >> & << MR.Maker Conversão e Codificação de Vídeo (Português) 2 05-08-2004 04:52 PM
CCE não reconhece AVS jscorrea Conversão e Codificação de Vídeo (Português) 1 01-19-2004 08:30 PM

Thread Tools



 
All times are GMT -5. The time now is 04:53 AM  —  vBulletin © Jelsoft Enterprises Ltd