Quantcast Mencoder: Assemble AVIs - digitalFAQ.com Forums [Archives]
  #1  
06-03-2004, 08:59 AM
cedric.picard cedric.picard is offline
Free Member
 
Join Date: Jun 2004
Location: Nancy France
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
I try to assemble avi
so i saw that that command can do it :
cat 1.avi 2.avi | mencoder -noidx -ovc copy -oac copy -o film.avi -

but in fact it doesn't
it just copy 1.avi

maybe this will be able to help you to help me

when i use this command i have this result :

m0186:/enregistrement# cat 1.avi 2.avi | mencoder -noidx -ovc copy -oac copy -o film.avi -
MEncoder 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 800.3 MHz (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
File not found: 'frameno.avi'
Failed to open frameno.avi
Reading config file /root/.mplayer/mencoder: No such file or directory
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Reading from stdin...
success: format: 0 data: 0x0 - 0x0
AVI file format detected.
VIDEO: [XVID] 720x576 24bpp 25.000 fps 1096.1 kbps (133.8 kbyte/s)
[V] filefmt:3 fourcc:0x44495658 size:720x576 fps:25.00 ftime:=0.0400
videocodec: framecopy (720x576 24bpp fourcc=4449565
audiocodec: framecopy (format=55 chans=2 rate=48000 bits=0 bps=21076 sample=0)
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Pos: 7.4s 186f (99%) 0fps Trem: 0min 1mb A-V:0.039 [1093:168]
Writing AVI index...
Fixing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream: 1093.158 kbit/s (136644 bps) size: 1016637 bytes 7.440 secs 186 frames

Audio stream: 168.604 kbit/s (21075 bps) size: 167424 bytes 7.944 secs


can someone help me ???
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
06-03-2004, 11:05 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
I think that the problem is with the index. I don't know exactly the syntax but as you use '-noindx' mencoder does not regenerate the index corresponding to the entire movie. As index include a "eof" marker, perhaps there is your problem.

Check the manual to see how the index can be rebuild on the fly by mencoder.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
AVIs com 2 Audios no DIKO 0.76 B2 cazuza Conversão e Codificação de Vídeo (Português) 3 09-13-2004 02:17 PM
MAKE AVIS. ONDE ? JACK WADE Conversão e Codificação de Vídeo (Português) 5 05-04-2004 06:56 AM
Problem converting two or More AVIs to 1 KVCD p2phunter Video Encoding and Conversion 2 03-18-2004 01:01 PM
combine avis with ac3 audio? canon Video Encoding and Conversion 1 12-10-2003 09:14 AM
JUNTAR 2 AVIS PARA KVCD Gimenes Conversão e Codificação de Vídeo (Português) 2 09-12-2003 10:22 AM

Thread Tools



 
All times are GMT -5. The time now is 03:56 AM  —  vBulletin © Jelsoft Enterprises Ltd