Quantcast Any Good Encoders for the PSP to Make MP4 Files ? - Page 2 - digitalFAQ.com Forums [Archives]
  #21  
01-27-2006, 09:28 PM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
i definatly have the right codecs to play the video as when i play mp4 files using media player classic from other psp encoding programs it works fine. and made sure i have all the relavant exe. files for encoding

Heres my avs file i created for the encodes:

AviSource("D:\Mpegs\xvid movies\Test.avi",TRUE)
BlindPP(cpu=4)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.1,seed=1)
Convolution3D(1, 6, 12, 6, 8, 2.8, 0)
LanczosResize(368,20
Undot()
TemporalSoften(2,7,7,3,2)
DCTFilter(1,1,1,1,1,1,0.5,0)
assumefps(29.00)

Im using megui.exe 0.2.3.2033 to encode with psp profile.

Under settings iv chosen x-264 encoder : x-264 exe
xvid encoder : mencoder

On the main window for meGui i have opened the avs into the avisynth script section, and just below i have opened the avs for the audio input part as well. Video codec is AVC, Audio codec is NAAC

Its a 18 second clip.

When iv encoded (2 pass 1st pass) i get a .stats file (38.7kb) and a besweet log. NO MP4 . Heres the log

BeSweet v1.5b31 by DSPguru.
--------------------------
Error 59: Failed to sync to payload's start position : "D:\Mpegs\episodes\PSP Test script 360 208.avs"Using hip.dll v1.19 by Myers Carpenter <myers@users.sf.net>
Using Shibatch.dll v0.25 by Naoki Shibata & DSPguru (shibatch.sourceforge.net).
Using bsn.dll v0.24 by DPeshev,Richard,E-Male,DSPguru (DSPguru.Doom9.org).

Logging start : 01/28/06 , 02:14:36.

D:\Mpegs\sound apps\besweet\BeSweet.exe -core( -input D:\Mpegs\episodes\PSP Test script 360 208.avs -output D:\Mpegs\episodes\PSP Test script 360 208.mp4 -logfile D:\Mpegs\episodes\PSP Test script 360 208.besweet.log ) -bsn( -2ch -cbr 128 ) -ota( -g max )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : D:\Mpegs\episodes\PSP Test script 360 208.avs
[00:00:00:000] | Output: D:\Mpegs\episodes\PSP Test script 360 208.mp4
[00:00:00:000] | Floating-Point Process: No
Error 84: error configuring bsn!
Quiting...
[00:00:00:000] Conversion Completed !

Logging ends : 01/28/06 , 02:14:36.


In 2 pass 2nd pass mode i get my test .mp4 (okb) and another besweet log

In Automated 2 pass i get .stats file and my test.mp4 (744kb), i open it using media player classic its a black screen 15 seconds long i press play it wont play


Now what i did was try changing settings so both x264 and xvid encoding use mencoder.exe, i run 2 pass 2nd pass, its running then at the end of first pass it fails and says '

'The instruction at ...... refernced memory at.... the memory could not be read...''
what is that about ( this has happened on another program Psp Enc which seemed good but two pass fails)

Heres all the info i can give at present my friends brain is fried

Now is Megui supposed to create one mp4 file ( sound and video) or two that you mux urself
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #22  
01-28-2006, 03:21 AM
digitall.doc digitall.doc is offline
Free Member
 
Join Date: Jul 2003
Location: Valencia (España)
Posts: 741
Thanks: 0
Thanked 0 Times in 0 Posts
This is going to be difficult for me, since I'm not there with you....
Quote:
Originally Posted by khusru
i definatly have the right codecs to play the video as when i play mp4 files using media player classic from other psp encoding programs it works fine.
Well, this seems OK, but did you try to play x264 sagittaire sample?. There wouldn't be any problem as you stated, just in case...

Quote:
Originally Posted by khusru
Heres my avs file i created for the encodes:
Does this script play well in media player?... Can you preview it in MeGUI?...

Quote:
Originally Posted by khusru
...and just below i have opened the avs for the audio input part as well. Video codec is AVC, Audio codec is NAAC
So you're processing audio trough avisynth... I never did that. I usually process the ac3 demuxed file. Remember that for Nero audio encoding you need to have Nero installed.In earlier Nero versions, it was enough to have some dll libraries in besweet folder, but now it needs to be installed (it checks in registry )

Quote:
Originally Posted by khusru
[00:00:00:000] | Floating-Point Process: No
Error 84: error configuring bsn!
Quiting...
[00:00:00:000] Conversion Completed !
Encoding audio is not working!! (you'd already realised it, didn't you?). I bet it's a problem with Nero encoding engine not properly installed...
I can't see anything related to video encoding part. Can you see it queued in tasks tab?. Can you see the command line MeGUI generates?. Can you post it?.

Quote:
Originally Posted by khusru
Now is Megui supposed to create one mp4 file ( sound and video) or two that you mux urself
If you want MeGUI to mux your resulting files in a mp4 file, you need to download MP4Box (see in the same page as MeGUI, and how to make it work).
Reply With Quote
  #23  
01-28-2006, 08:22 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Well, this seems OK, but did you try to play x264 sagittaire sample?. There wouldn't be any problem as you stated, just in case...
Im looking for it right now, are these the samples u spoke of

http://forum.doom9.org/showthread.php?p=756445
Quote:
Does this script play well in media player?... Can you preview it in MeGUI?...
Yes it plays perfectly and i also can preview in megui

Quote:
So you're processing audio trough avisynth... I never did that. I usually process the ac3 demuxed file. Remember that for Nero audio encoding you need to have Nero installed.In earlier Nero versions, it was enough to have some dll libraries in besweet folder, but now it needs to be installed (it checks in registry)
Im going to give it a go, il demux the audio from the avi and try encode that way. I downloaded a whole load of.dll files yesterday and copied them to the besweet directory, what is the full name of the nero app that i must have?

Already got mp4 box installed

Quote:
Encoding audio is not working!! (you'd already realised it, didn't you?). I bet it's a problem with Nero encoding engine not properly installed...
I can't see anything related to video encoding part. Can you see it queued in tasks tab?. Can you see the command line MeGUI generates?. Can you post it?.
It definatly ques up on the task part, i just tried encoding the audio seperate from the avs as a wav. 'Oh my god major revelation in terms of sound', i just changed audio codec from NAAC to MP3 and it encoded sound and i can hear it fine. As u suggested it is the nero problem, what is the full name of the nero package i need?

That just leaves the video, why do i get .stats files at times?
i will try to get the sample u said and try that out and get back to you


Thanks again for your help


[/quote]
Reply With Quote
  #24  
01-28-2006, 08:40 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Have u been to the link above, are those the x264 samples you were talking of because i cannot play them, just tried. I have x264 installed in my program files ( i assumed all the codecs were given with it), i have ffdshow installed too. I dont understand what i need?
Reply With Quote
  #25  
01-28-2006, 11:11 AM
digitall.doc digitall.doc is offline
Free Member
 
Join Date: Jul 2003
Location: Valencia (España)
Posts: 741
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by khusru
Im looking for it right now, are these the samples u spoke of...
No, I refered to the ones posted here at KVCD.net: H264-Sagittaire

Quote:
Originally Posted by khusru
Yes it plays perfectly and i also can preview in megui
So avs script is OK.

Quote:
Originally Posted by khusru
...I downloaded a whole load of.dll files yesterday and copied them to the besweet directory, what is the full name of the nero app that i must have?
No, no. You don't need loads of dll. Just those in Besweet, and a couple of the ones in Nero folder (follow instructions in MeGUI page). You need Nero Digital, Nero 6, or Nero 7 installed or it won't encode. (I think I'm begining to understand why nothing seems to work well...)

Quote:
Originally Posted by khusru
That just leaves the video, why do i get .stats files at times?
Once again, post the command-line MeGUI generates when you queue video encoding (there's a checkbox to show command.line). Maybe this way we can see what is going wrong.
Reply With Quote
  #26  
01-28-2006, 11:57 AM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
major breakthrough, as u said earlier. The demo h264 sagittaire does not run, its 12 secs black and wont play, this means im missing codec right but which codec is it im missing?

I have nero 6 and have just downloaded nero showtime trial.In my besweet folder i have added the following a couple of days ago to help with this :

aacenc32.exe
faad.exe
faac.exe
bse_FAAC.dll
AheadAACEnc.dll

Even with the showtime installed i still can not create NAAC sound



Heres log 2 pass 2nd pass and audio:


Log for job job1

desired video bitrate of this job: 400 kbit/s - obtained video bitrate: 0 kbit/s
--------------
Starting job job2 at 17:18:38
Job is an audio job. Commandline:
-core( -input "D:\Mpegs\xvid movies\jlh.wav" -output "D:\Mpegs\xvid movies\jlh.mp4" -logfile "D:\Mpegs\xvid movies\jlh.besweet.log" ) -bsn( -2ch -cbr 128 ) -ota( -g max )
successfully started encoding
Processing ended at 17:18:38
--------------

Log for job job2

BeSweet v1.5b31 by DSPguru.
--------------------------

[00:00:00:000] Initializing...
[00:00:00:000] -- Initializing...

--------------
Starting job job1 at 17:19:49
Job is a video job. encoder commandline:
--pass 2 --bitrate 400 --stats "D:\Mpegs\episodes\PSP Test script 360 208.stats" --analyse p8x8,b8x8,i4x4 --sar 368:208 --progress --no-psnr --output "D:\Mpegs\episodes\PSP Test script 360 208.mp4" "D:\Mpegs\episodes\PSP Test script 360 208.avs"
successfully started encoding
Processing ended at 17:19:49
--------------

Log for job job1

desired video bitrate of this job: 400 kbit/s - obtained video bitrate: 0 kbit/s
--------------

2pass 1st pass w :


Starting job job1 at 17:20:52
Job is a video job. encoder commandline:
--pass 1 --bitrate 400 --stats "D:\Mpegs\episodes\PSP Test script 360 208.stats" --analyse p8x8,b8x8,i4x4 --sar 368:208 --progress --no-psnr --output NUL "D:\Mpegs\episodes\PSP Test script 360 208.avs"
successfully started encoding
Processing ended at 17:21:14
--------------

Log for job job1

avis [info]: 368x208 @ 29.00 fps (445 frames)
x264 [info]: using SAR=23/13
x264 [info]: using cpu capabilities MMX MMXEXT SSE SSE2
x264 [info]: slice I:8 Avg QP:18.75 size: 12297
x264 [info]: slice P:437 Avg QP:21.73 size: 1562
x264 [info]: mb I I16..4: 17.4% 0.0% 82.6%
x264 [info]: mb P I16..4: 2.3% 0.0% 1.2% P16..4: 36.4% 18.6% 7.5% 0.0% 0.0% skip:34.1%
x264 [info]: final ratefactor: 20.21
x264 [info]: kb/s:407.2

Actual bitrate after encoding without container overhead: 407.60

--------------
Starting job job2 at 17:21:14
Job is an audio job. Commandline:
-core( -input "D:\Mpegs\xvid movies\jlh.wav" -output "D:\Mpegs\xvid movies\jlh.mp4" -logfile "D:\Mpegs\xvid movies\jlh.besweet.log" ) -bsn( -2ch -cbr 128 ) -ota( -g max )
successfully started encoding
Processing ended at 17:21:14
--------------

Log for job job2

BeSweet v1.5b31 by DSPguru.
--------------------------

[00:00:00:000] Initializing...
[00:00:00:000] -- Initializing...

--------------

Reply With Quote
  #27  
01-28-2006, 12:34 PM
Sagittaire Sagittaire is offline
Free Member
 
Join Date: May 2003
Posts: 97
Thanks: 0
Thanked 0 Times in 0 Posts
1) Well MeGui use x264 encoder CLI and not CO-DEC. You must use DSFilter like Core AVC or other to decode MPEG4 AVC or VLC player.

2) Use simply Nero Recode : there are complete and simple profil for PSP encoding ...
__________________
Le Sagittaire
--------------------
Inutile de discuter avec moi ... j'ai toujours raison ... en tous cas j'en suis convaincu et c'est le principal ...
Reply With Quote
  #28  
01-28-2006, 01:45 PM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Updates

okay digitall.doc i can finally play the sample, its working, (nero definatly helped).

Now automated two pass i get an mp4 file which i can actually view now, looks good, but no sound

2pass 2nd pass i still get a okb mp4

2 pass frist pass i get just stats file

All i need now is for the sound to encode, and to work out why the video isnt in the other modes, please Digitall.doc can u see my logs and see if u can make any sence from it?
Reply With Quote
  #29  
01-28-2006, 02:55 PM
digitall.doc digitall.doc is offline
Free Member
 
Join Date: Jul 2003
Location: Valencia (España)
Posts: 741
Thanks: 0
Thanked 0 Times in 0 Posts
It's great you can finally play x264 videos. They advise to use ffdshow and your favourite directshow mediaplayer. Try ffdshow builds by Sharktooth, and set it to play h264

Related to he-aac encoding, you need aac.dll and aacenc32.dll from your Nero installation (usually at c:\program files\common files\ahead\AudioPlugins)

I think that getting a stats file in first pass is the normal behaviour (output in first pass is NUL). I don't think it will be of a help, but I would like to take a look at your command-line (I can see some parameters in log, but just in case...).
You could also make a simple .bat file (something like x264.exe -h) to see if x264 is runing OK. I guess is OK, since there's no error in log.

I don't see any error in log, I mean, I see first pass is done well, but then 2nd pass starts and ends immediatelly with a 0kbps file, no error. I don't know what's wrong, maybe you could try with a shorter file name for your video...
Reply With Quote
  #30  
01-28-2006, 03:45 PM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Digital.doc thank u so much, sound is good now , encoding and i can hear it. followed ur instructions for were to locate the codecs, due to it being trial ware i have 50 encodes left.

il look into getting the command line for you

Just`one mor step to go.... fingers crossed
Reply With Quote
  #31  
02-05-2006, 08:44 PM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Here you go Digital

This is the command line i got, encoded at 2 Pass- 2nd Pass,
400 kbps

C:\Program Files\x264\x264.exe --pass 2 --bitrate 400 --stats ".
stats" --ref 2 --mixed-refs --bframes 3 --b-rdo
--weightb --subme 6 --trellis 1 --analyse p8x8,b8x8,i4x4,p4x4
--sar 360:208 --progress --no-psnr --output
"D:\PSP Test script 360 208.mp4"
"D:\PSP Test script 360 208.avs"

Unfortunatly still not able to do 2 pass
Reply With Quote
  #32  
02-15-2006, 04:27 PM
khusru khusru is offline
Free Member
 
Join Date: Jan 2004
Location: Southgate, North London
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
Finally got it working the other day digital. I ran the command line from cmd mode, and the error showed up no stats file? straight awsay i knew what the problem was.

i assumed 2 pass first pass you get an mp4 at the end, but you dont you get a stats and then it is your job to manually do 2 pass 2nd pass, 2 pass 2nd pass can only run when it has a stats file (from 2 pass first pass). i didnt know this, and thats why i kept gettin a stats file which id delete in the end, and thats why 2 pass 2nd pass id get a 0kb mp4.

Automated 2 pass is just an automatic way of running both passes ( again i must have been retarded to not work this out from the start), and thats why i got mp4 at the end of that mode.

Thanks for all the help guys on this one. x264 is slowly becoming my favourite codec, quality for psp is so much more clearer and vivid than ffmpeg, and you can use low bit rates and get smaller sized files without sacrificing on the quality.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i make kvcd by cue/bin files? qib Video Encoding and Conversion 4 11-10-2006 03:08 AM
How to use.sub and .idx files to make subtitles? WOWIEGURL Subtitles 7 06-11-2004 11:16 AM
Mini guide to make GOOD mp3s! azel Audio Conversion 0 10-03-2003 03:54 PM
how to make good quality VCD? EnNiS Video Encoding and Conversion 4 06-18-2003 07:44 PM
How to make KVCD from Only VOB files? KVCDboy Video Encoding and Conversion 1 06-08-2002 02:31 PM

Thread Tools



 
All times are GMT -5. The time now is 01:32 PM  —  vBulletin © Jelsoft Enterprises Ltd