Quantcast KVCD: Subtitles Going Too Fast? - digitalFAQ.com Forums [Archives]
  #1  
02-20-2003, 03:06 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
Oke I tried to add the subtitle with avisynth . I followed this guide: http://www.dvdrhelp.com/forum/userguides/87065.php#4 Avisynth and TextSub, Scenario 4 --AVISYNTH-- . Thats what I followed. It was'nt hard but when I played the new avs. script in WMP it happend something weird The subtitle was playing on the movie (divX). But after a while the subs was going to fast, I hope you know what I mean... The subs had already been showed when they should have on the movie Maybe you call it, out of sync or something Oke hope you understnd me "the subs was to fast for the movie" . And please I could need some help,I'm stuck as usual

//Wolfi
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
02-20-2003, 03:24 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
By the way, this is my script

LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Patch och Mods\Filters\Dll\MPEG2DEC.dll")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\VDu b\plugins\textsub.vdf")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\Fit CD\GripFit_preview.dll")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\Fit CD\LegalClip.dll")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\Fit CD\Sampler.dll")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\Fit CD\DustV5.dll")
LoadPlugin("C:\Documents and Settings\Lars\Skrivbord\Tobias\Program\Blandat\Fit CD\TemporalCleanerOld.dll")

AviSource("C:\Documents and Settings\Lars\Skrivbord\Tobias\American Pie 2 [DVD DivX] .avi")
ConvertToYUY2()

LegalClip()
GripCrop( width= 352, height=576, overscan=1 )
GripSize()
SpaceDust()
TemporalCleaner()
GripBorders()
LegalClip()
#Sampler(length=24)
## MPEG size = ((Total frames/MovieTimeInMinutes)/24) * MPEG sample file size ##
TextSub("C:\Documents and Settings\Lars\Skrivbord\Tobias\_newAP2.srt")
Reply With Quote
  #3  
02-21-2003, 01:09 AM
Boulder Boulder is offline
Free Member
 
Join Date: Sep 2002
Location: Lahti, Finland
Posts: 1,652
Thanks: 0
Thanked 0 Times in 0 Posts
A simple problem: the framerate of your subs is larger than the video's. You probably have a 23.976fps video and 25fps subs. You'll have to slow the subs down, Google will find several tools for this.
Reply With Quote
  #4  
02-21-2003, 01:37 AM
muaddib muaddib is offline
Free Member
 
Join Date: Jun 2002
Location: So Paulo - Brasil
Posts: 879
Thanks: 0
Thanked 0 Times in 0 Posts
Hey!! I DID look at it!!

http://www.kvcd.net/forum/viewtopic.php?t=2952
Reply With Quote
  #5  
02-21-2003, 03:17 AM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
When I checked the file imformation in VDub it showed that the movie wad PAL 25fps. I had the FPS on 25fps when the sub was going to fast... So this time I tried with 23.976fps and it was better only a bit to slow... IS it anything to do about it?

One more thing. The subs came up as 5 lines above each other instead of two lines above each other Anyway to correct this problem

//Wolfi
__________________
Nice site!
Reply With Quote
  #6  
02-21-2003, 07:46 AM
Boulder Boulder is offline
Free Member
 
Join Date: Sep 2002
Location: Lahti, Finland
Posts: 1,652
Thanks: 0
Thanked 0 Times in 0 Posts
You can set the timings manually with SubResync.
Reply With Quote
  #7  
02-21-2003, 07:54 AM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
But Boulder it's a looong list of sentences Wont it take years to set the timings manualy

One more thing. The subs came up as 5 lines above each other instead of two lines above each other Anyway to correct this problem, with a program or something

//Wolfi
Reply With Quote
  #8  
02-21-2003, 09:33 AM
Boulder Boulder is offline
Free Member
 
Join Date: Sep 2002
Location: Lahti, Finland
Posts: 1,652
Thanks: 0
Thanked 0 Times in 0 Posts
No, you don't have to enter the time manually in each point. Set the time for the first subtitle and the rest shall be corrected accordingly. If your problem is that the subs appear let's say 5 seconds too late, you'd just set the time for the first subtitle to be 5 seconds earlier than it is.
Reply With Quote
  #9  
02-21-2003, 09:57 AM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
The first subtitle IS correct but when the movie have played for a while, it's then the sub comes up before the voice.

25fps=before
23.976fps=after

Should I try with 24fps

And no one have no idea why the subs comes up more then 2 lines above each other?

//Wolfi
Reply With Quote
  #10  
02-21-2003, 10:05 AM
kwag kwag is offline
Free Member
 
Join Date: Apr 2002
Location: Puerto Rico, USA
Posts: 13,537
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Wolfi

And no one have no idea why the subs comes up more then 2 lines above each other?

//Wolfi
Because you're puting the subs line in your .avs script AFTER the resizing. Change your .avs to read like this:

Code:
AviSource("C:\Documents and Settings\Lars\Skrivbord\Tobias\American Pie 2 [DVD DivX] .avi") 
ConvertToYUY2() 
TextSub("C:\Documents and Settings\Lars\Skrivbord\Tobias\_newAP2.srt")
LegalClip() 
GripCrop( width= 352, height=576, overscan=1 ) 
GripSize() 
SpaceDust() 
TemporalCleaner() 
GripBorders() 
LegalClip() 
#Sampler(length=24) 
## MPEG size = ((Total frames/MovieTimeInMinutes)/24) * MPEG sample file size ##
-kwag
Reply With Quote
  #11  
02-21-2003, 10:32 AM
Boulder Boulder is offline
Free Member
 
Join Date: Sep 2002
Location: Lahti, Finland
Posts: 1,652
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Wolfi
The first subtitle IS correct but when the movie have played for a while, it's then the sub comes up before the voice.

25fps=before
23.976fps=after

//Wolfi
Well, this looks like a framerate thing to me. The subs and the movie simply do not have the same framerate.

Is the original movie clip 25fps or 23.976fps? The latter would make much more sense. The thing you are seeing is most likely that your subs are 25fps and the movie goes at 23.976. Or someone has really screwed up the subs, that's an option too.

You can sync the subs with SubResync but it will require a lot of work. Adjust the timings manually in several points and it might work out fine. Remember to change the timing direction icon, you'll want to replace that green thingie with a red triangle pointing downwards. This way the sync point affects the timings below it until a next sync point comes up, which will then affect the timings below that point.
Reply With Quote
  #12  
02-21-2003, 12:47 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
Oke, I've decited to encode and watch the movie without subs Well, I tried to add a subtitle to an other movie and the result was great But it's one thing thats troubleing me with every movie I cant watch the movie if the subs is lined 5 times above each other Maybe you dont understand me so I'll just give you an example (in swedish words)

Movie screen: Behind enemy lines
________________________________________
| |
| |
| |
| |
| |
| |
| |
| Alla tror de ska |
| f en chans att |
| klippa till ngra |
| Nazister vi |
| Normandie |
|________________________________________|

I really CANT watch the movie when it looks like this
It's lines 5 sentence above each other!

//Wolfi
Reply With Quote
  #13  
02-21-2003, 12:51 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
Ops, it should be a tv screen ,something went wrong when I posted But the lines are lined so, but in the middle of the screen.

Alla tror de ska
f en chans att
klippa till ngra
Nazister vi
Normandie
Reply With Quote
  #14  
02-21-2003, 02:48 PM
muaddib muaddib is offline
Free Member
 
Join Date: Jun 2002
Location: So Paulo - Brasil
Posts: 879
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Wolfi
Ops, it should be a tv screen ,something went wrong when I posted But the lines are lined so, but in the middle of the screen.

Alla tror de ska
f en chans att
klippa till ngra
Nazister vi
Normandie
Isn't it just a "TOO BIG" font problem?
Reply With Quote
  #15  
02-21-2003, 05:25 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
Please tell me muaddib, what is a "TO BIG" font problem
Reply With Quote
  #16  
02-21-2003, 11:26 PM
muaddib muaddib is offline
Free Member
 
Join Date: Jun 2002
Location: So Paulo - Brasil
Posts: 879
Thanks: 0
Thanked 0 Times in 0 Posts

It's just when the font used in the subs are so big that a long sentence has to be splited in 3... 4... or more lines!
To solve this, just open SubResynch and set the font size to a small number.
Reply With Quote
  #17  
02-22-2003, 04:03 PM
Wolfi Wolfi is offline
Free Member
 
Join Date: Oct 2002
Location: Sweden
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Wolfi Send a message via MSN to Wolfi Send a message via Yahoo to Wolfi
Easy done Thank you :P
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
KVCD: plays fast forward? mma01 Players, DVRs, Media Centers 10 06-29-2004 04:54 AM
Subtitles: Adding .srt subtitles to a KVCD movie xpronic Subtitles 13 06-12-2004 09:33 PM
KVCD: Movie plays too fast? nkhxv Video Encoding and Conversion 12 07-04-2003 12:10 PM
KVCD: PLayback too fast?? won hung tu lo Video Encoding and Conversion 2 04-30-2003 12:57 AM
KVCD: Another success, lot of fast motion! eldend Video Encoding and Conversion 0 08-05-2002 12:49 AM

Thread Tools



 
All times are GMT -5. The time now is 03:55 AM  —  vBulletin Jelsoft Enterprises Ltd