Quantcast Bitrates: CQmatic CQ_VBR - Still can't get it! - digitalFAQ.com Forums [Archives]
  #1  
05-14-2004, 10:48 PM
arana arana is offline
Free Member
 
Join Date: Mar 2004
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
ok i thought i had understood but i obviously didnt
i used to just use the templates as they were , but ive started to TRY to use the whole CD for my videos

i tried acp and it did a good job i think, results were good and it used cq_vbr of 50 (dunno if thats what it was supposed to do) except on one of the videos, no problem there, but i want to try other method in order to learn what is actually happening.

i got cqmatic and im trying to findout how to calculate cq for CQ and how to for CQ_VBR, dont see any option in cqmatic to select wich method i want, i dont even know if cqmatic is working as it should, since it opens and closes tmpgenc really fast.

where do i select what kind of method will i use for encoding? (cq or cq_vbr)
just selecting cq or cq_vbr in tmpgenc and saving the project gave me 89 as the cq result for cq or for cq_vbr, so i guess im not doing it right.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
05-15-2004, 09:46 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by arana
i got cqmatic and im trying to findout how to calculate cq for CQ and how to for CQ_VBR, dont see any option in cqmatic to select wich method i want
You don't need: CDMatic reads this info in your tmpgenc project. Just set the parameters of your job as you want (using CQ or CQ_VBR) in tmpgenc and save the project.

Quote:
since it opens and closes tmpgenc really fast.
So you DIDN'T do all you read in other posts.

You probably forgot to reset the cut editing and/or the source range selection in tmpgenc.
Reply With Quote
  #3  
05-15-2004, 10:46 AM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
HI Phil,i've asked this before and never got an answer that worked for me .When i use cqmatic or tok(altered)for cq vbr it starts at 20 and continues to go up to about 90 and the picture gets worse every time.

I know it probably should bot go over 30 or so but it always goes way to high

I know its vague but any ideas
Reply With Quote
  #4  
05-15-2004, 12:16 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Do you mean that you manage to use CQMatic in CQ mode but always fail when you try in CQ_VBR ?

I can help if you have a log to post corresponding to that problem.
Reply With Quote
  #5  
05-15-2004, 12:25 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Phil
Do you mean that you manage to use CQMatic in CQ mode but always fail when you try in CQ_VBR ?
Exactly

Quote:
can help if you have a log to post corresponding to that problem.
I do not only because i haven't tried for a long while becuase i can never get it to work

I will try later and see how it goes
Reply With Quote
  #6  
05-20-2004, 09:06 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
OK here is the log from cqmatic

Code:
http://www.kvcd.net
CQMatic Version 1.2.06
Copyright Softronex Corporation, 2003.
All rights reserved.
Time: 20:56:18 Date: 05/20/2004
Ready!
Project: C:\Video Encoding\movie.tpr

Creating: CQMatic.tpr

C:\Video Encoding\movie.m1v
Project resolution: 352x240
Execute.
Movie Time: 70
Average Bitrate: 1394_anamorphic=false)
Full Encode mode
Executing Prediction Phase...
Process started at 20:57:20
On 05/20/2004
CQ_VBR set for prediction.
Setting up initial sampling.
Using CQ_VBR of 15.00
Prediction cycle #1
Encoder started...
Process time: 7.90 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 15.000000
High fence: 90.000000
Last CQ = 15.00
Current CQ = 52.50
CQ difference = 37.500000
Using CQ_VBR of 52.50
Prediction cycle #2
Encoder started...
Process time: 7.85 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 52.500000
High fence: 90.000000
Last CQ = 52.50
Current CQ = 71.25
CQ difference = 18.750000
Using CQ_VBR of 71.25
Prediction cycle #3
Encoder started...
Process time: 7.87 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 71.250000
High fence: 90.000000
Last CQ = 71.25
Current CQ = 80.63
CQ difference = 9.375000
Using CQ_VBR of 80.63
Prediction cycle #4
Encoder started...
Process time: 7.83 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 80.625000
High fence: 90.000000
Last CQ = 80.63
Current CQ = 85.31
CQ difference = 4.687500
Using CQ_VBR of 85.31
Prediction cycle #5
Encoder started...
Process time: 7.85 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 85.312500
High fence: 90.000000
Last CQ = 85.31
Current CQ = 87.66
CQ difference = 2.343750
Using CQ_VBR of 87.66
Prediction cycle #6
Encoder started...
Process time: 7.83 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 87.656250
High fence: 90.000000
Last CQ = 87.66
Current CQ = 88.83
CQ difference = 1.171875
Using CQ_VBR of 88.83
Prediction cycle #7
Encoder started...
Process time: 7.87 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 88.828125
High fence: 90.000000
Last CQ = 88.83
Current CQ = 89.41
CQ difference = 0.585938
Using CQ_VBR of 89.41
Prediction cycle #8
Encoder started...
Process time: 8.08 minutes.
Encoder end.
File size difference  = 6.614736
Low fence: 89.414063
High fence: 90.000000
Last CQ = 89.41
Current CQ = 89.71
CQ difference = 0.292969
Using CQ_VBR of 89.71
Prediction cycle #9
Encoder started...
The video is horrible(very blocky)
Full screen and using V4 Avi script
This is why i never get cq vbr to work
Reply With Quote
  #7  
05-21-2004, 08:01 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
There should be a bug in the CQ_VBR mode because :

1/ a 70 minute video at 352*240 fit easily on a CD WHATEVER THE QUALITY.
I mean that at this resolution you can put 2h30 on a CD in CQ mode at CQ70 and 70 minutes can be done at CQ=90 and you will sitll have space on the CQ (100 or 200 MB free may be)

and

2/ CQ=70 is equivalent (in words of quality) to CQ_VBR=18. CQ=80 -> CQ_VBR=22. So normaly, above CQ_VBR=25 you should reach the maximum quality.

But here, as even with CQ_VBR > 25 you don't fit the entire CD, the program still continue to try higher value. And there ios where the bug occurs : it seems that a CQ_VBR of 89 gives you an horrible result

It's like if this mode was never designed to be used with values above, let say, 30. You understand me ?

What you have to do :

1/ try the exact same video with a resolution of 544*480. Just for testing the tool. You will see how that it works very well.
Or try a longer video (1h45 - 2h). Or why not, try that video but with a target size of 400 MB insteed of all the CD.

or

2/ encode the video at 352*240 and CQ_VBR=25 and you will see that what I explained to you just above is true.


Edit: I just saw that line in your log :
Code:
Average Bitrate: 1394_anamorphic=false)
It is very stange, as you can guess.
I never saw if I have the same in my logs...
Reply With Quote
  #8  
05-21-2004, 01:32 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Thanx Phil

Code:
Average Bitrate: 1394_anamorphic=false)
as you might guess this was a copy and paste error on my part

I will try the other things you suggest

How do i go about adjusting for 400 mb size ,just changing the bitrate
Reply With Quote
  #9  
05-21-2004, 08:13 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by bigggt
How do i go about adjusting for 400 mb size ,just changing the bitrate
Yes.
In calcumatic, insteed of "CD 80 Min", choose "custom ssize" and enter 400 MB in the entry field.
Reply With Quote
  #10  
05-21-2004, 09:12 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Thanx Phil,i will give it a try

BTW i didd resoultion of 544x480 and i let it go through a few tries and same thing

First try was cq vbr 15 and then the next one was 52,also the one at 15 looked very bad also,it seems i can't get cq vbr to work at all
Reply With Quote
  #11  
05-21-2004, 10:03 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Let CQ_Matic start the try with 15, and CLOSE it; Let tmpgenc finish it's work. Open the encoded video... how is it ?

Note : Did you set correctly the min and max bitrates in cq_vbr mode ???
Reply With Quote
  #12  
05-22-2004, 12:20 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
thanx again Phil

what are the main max bitrate in cq vbr mode i just used the same as cq mode 300 and 1800
Reply With Quote
  #13  
05-22-2004, 01:06 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by bigggt
what are the main max bitrate in cq vbr mode i just used the same as cq mode 300 and 1800
You can use the same but by default in the template KWAG changed them to 0-0, that is why you have to check the values

Note: I stil don't knwo if you can't use CQ_VBR or jsut "CQmatic in CQ_VBR mode" ?

Did you even do a sample test with CQ_VBR set to 15, without CQMatic?
Reply With Quote
  #14  
05-22-2004, 01:27 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Phil ,i did test at 15 and result was horrible but then i checked the min and max and it was 0,i didn't know that with cq vbr Kwag had them like this.

Anyway i am doing a test with proper values and will let you know
Reply With Quote
  #15  
05-22-2004, 04:38 PM
bigggt bigggt is offline
Free Member
 
Join Date: Mar 2003
Location: IamCanadian
Posts: 848
Thanks: 0
Thanked 0 Times in 0 Posts
Well thanx for your help Phil

It was the min and max bitrate

I got 50 as my final cq and it looks really good

I have not been able to use cq vbr for some time now and its only because of the min and max bitrate (stupid me for not looking or reading)

Reply With Quote
  #16  
05-22-2004, 04:41 PM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by bigggt
(stupid me for not looking or reading)
. You won't be catched two times
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Bitrates: CQMatic 1.4.08 Metabodom Video Encoding and Conversion 2 05-22-2005 07:01 AM
Bitrates: CQ_VBR mode Dialhot Video Encoding and Conversion 4 01-14-2005 11:36 PM
TMPGEnc: Cq_vbr and min/max bitrates. Fluffbutt Video Encoding and Conversion 5 07-05-2004 05:03 PM
Bitrates: CQMatic Log Aielman Video Encoding and Conversion 8 03-18-2004 10:36 PM
Bitrates: KDVD bitrates with CQMatic nicksteel Video Encoding and Conversion 10 08-06-2003 08:44 AM

Thread Tools



 
All times are GMT -5. The time now is 04:37 AM  —  vBulletin © Jelsoft Enterprises Ltd