Quantcast MPEG Dá Tempo Errado - digitalFAQ.com Forums [Archives]
  #1  
09-19-2004, 07:47 AM
HC_Pensador HC_Pensador is offline
Free Member
 
Join Date: May 2004
Location: São Luís
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to HC_Pensador Send a message via MSN to HC_Pensador
Bem galera, eh o seguinte, peguei um filme q estava em bin/cue e converti pra mpeg usando o vcdgear, transformei o filme usando o script abaixo, mas ele encodou apenas 3 minutos de filme, abri o mpeg original no WMP e ele soh tem 16:28 mas quando xega nesse tempo, o filme contiua e o tempo naum passa, jah aconteceu isso com vcs? aih pra encodar, eu axo q o tmpgec soh enxerga q o filme tem 3 minutos.

Como resolver?

Code:
####################################################################### 
#    SCRIPT de otimização para a transformação de AVI para K(S)VCD    # 
# Compatível com AviSynth 2.5x e TMPGEnc.                             # 
# De Dialhot (v.4) | Organizado por Ginoboy e revisado por vmesquita. # 
####################################################################### 

######################### 
#  Plugins Necessários  # 
######################### 
# ATC.dll               # 
# Blockbuster.dll       # 
# Convolution3DYV12.dll # 
# DctFilter.dll         # 
# Deen.dll              # 
# GripFit_YV12.dll      # 
# MPEG2Dec3.dll         # 
# Sampler.dll           # 
# UnDot.dll             # 
# VSFilter.dll          # 
######################### 

############################ 
# Legenda -> Arquivo (SMI) # 
############################ 

subtitle="F:\legenda.smi" 

# (Comentário: Coloque um # na frente do comando acima caso você NÃO 
# precise de legendas). 

####################### 
# Filme -> Arquivo(s) # 
####################### 

## [AVI com um arquivo só] 

#AviSource("nome_do_filme.avi",false) 

## [AVI com dois arquivos] (Descomente a linha abaixo caso for usar o mesmo) 

#AviSource("nome_do_filme_parte1.avi",false)++AviSource("nome_do_filme_parte2.avi",false) 

## [MPG com um arquivo só] (Descomente as duas linhas abaixo caso for usar o mesmo) 

DirectShowSource("F:\filme.mpg").Killaudio() 
Converttoyv12() 

## [MPG com dois arquivos] (Descomente as duas linhas abaixo caso for usar o mesmo) 

#DirectShowSource("nome_do_filme_parte1.mpg").Killaudio()++DirectShowSource("nome_do_filme_parte2.mpg").Killaudio() 
#Converttoyv12() 

# (Comentário: Para colocar só o nome do arquivo direto, o filme a ser 
# transformado deve estar no mesmo diretório que esse script está, 
# caso contrário você deve por o caminho do diretório em que se encontra 
# o filme. Exemplo: "C:\Filmes\nome_do_filme.avi"). 
# Para usar um dos comandos acima, os demais devem estar desabilitados. 

######################## 
# SCRIPT de otimização # 
######################## 

BlindPP(cpu=4) 
Blockbuster(method="noise",detail_min=1,detail_max=3,variance=0.1,seed=1) 
Convolution3D(1, 6, 12, 6, 8, 2.8, 0) 

# Na linha abaixo, mude o XXX e YYY conforme as suas necessidades de acordo 
# com a resolução do template que você está usando. E no comando "overscan", 
# use valores de 0 a 3 para ver o máximo que você pode colocar. Quanto maior, 
# melhor a qualidade, mas valores muito grandes podem fazer sua TV mostrar 
# bordas indesejáveis ao redor da imagem. 

GripCrop(352, 240, overscan=2, source_anamorphic=false) 
GripSize(resizer="LanczosResize") 
Undot() 
TemporalSoften(2,7,7,3,2) 
DCTFilter(1,1,1,1,1,1,0.5,0) 
#Blockbuster(method="noise",detail_min=1,detail_max=10,variance=0.3,seed=5623) 

# (Comentário: Na linha acima, descomente (apague) o "#" da linha acima caso o 
# filme esteja com muitos blocos DCT). 

GripBorders() 
TextSub(subtitle) 

# Comente com um # no inicio da linha acima caso você não precise de legendas. 

##################################################### 
# Sampler -> Amostra de Vídeo para achar o CQ ideal # 
##################################################### 

#Sampler(length=24) 

# Descomente (apague) o "#" para fazer amostras do vídeo.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
09-19-2004, 08:13 AM
ginoboy ginoboy is offline
Free Member
 
Join Date: Apr 2004
Posts: 922
Thanks: 0
Thanked 0 Times in 0 Posts
Quanto a aparecer 16 minutos no WMP e continuar depois desse tempo é normal, acontece com alguns arquivos MPG, não significa que existe problema algum no arquivo..

Agora perae, dexa eu ver se eu entendi, qdo vc poem pra encodar no tmpgenc, ele encoda e o arquivo fica com apenas 3 minutos? ou da algum erro ?

Abra no virtualdub pra ver se aparece algum erro... e posta aqui
Reply With Quote
  #3  
09-19-2004, 08:42 AM
HC_Pensador HC_Pensador is offline
Free Member
 
Join Date: May 2004
Location: São Luís
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to HC_Pensador Send a message via MSN to HC_Pensador
Passei o arquivo no virtualdubMOD, e naum apresentou nenhum erro, eu jah extrai o audio desse arquivo, e o audio aparece com 1:26:13, isso ker dizer q de alguma forma esse arquivo tem os tais 86 minutos, soh naum sei como fazer pro tmpgenc reconhecer isso
Reply With Quote
  #4  
09-19-2004, 08:45 AM
ginoboy ginoboy is offline
Free Member
 
Join Date: Apr 2004
Posts: 922
Thanks: 0
Thanked 0 Times in 0 Posts
Certo, o video tem 86 min.

Mas ainda não continuo entendo o que voce quer dizer:

-> Eu disse pra vc abrir o SCRIPT no virtualdub e ver se aparece ERROS.. (acho que você não fez isso né, vc abriu o arquivo de origem direto)

-> Como assim o tmpgenc "não reconhece" ? vc manda encodar e vai até 3 min e para ? como q é ?
Reply With Quote
  #5  
09-19-2004, 08:56 AM
HC_Pensador HC_Pensador is offline
Free Member
 
Join Date: May 2004
Location: São Luís
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to HC_Pensador Send a message via MSN to HC_Pensador
se o script tivesse algum erro, ele teria acusado na hora de abrir no tmpgenc, mas isso nauma conteceu, eu mando encodar o video, aih ele leva apenas 10 minutos pra encodar, quando abro o arquivo gerado em algum player, ele tem apenas 3 minutos, eh isso
Reply With Quote
  #6  
09-19-2004, 09:04 AM
ginoboy ginoboy is offline
Free Member
 
Join Date: Apr 2004
Posts: 922
Thanks: 0
Thanked 0 Times in 0 Posts
Hum.. mas qdo vc abre esse arquivo gerado tem o q? os 3 minutos iniciais ?

Faça o seguinte (tomara q vc nao tenha teletado a imagem (bin/cue) ainda), abra no vcdgear denovo e selecione a opção "fix mpeg erros" (acho q é isso) e mande extrair o MPG...

Ai vc tenta denovo...
Reply With Quote
  #7  
09-19-2004, 12:31 PM
danpos danpos is offline
Free Member
 
Join Date: May 2004
Location: Rio de Janeiro - Brasil
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ginoboy
Hum.. mas qdo vc abre esse arquivo gerado tem o q? os 3 minutos iniciais ?

Faça o seguinte (tomara q vc nao tenha teletado a imagem (bin/cue) ainda), abra no vcdgear denovo e selecione a opção "fix mpeg erros" (acho q é isso) e mande extrair o MPG...

Ai vc tenta denovo...
Dependendo da versão do VCDGear isto pode dar mer ... no áudio. Por alguma razão "metafísica" o VCDGear "acha" que uma parte da stream de áudio é criptografada, resultando em um arquivo de áudio menor (em tempo) do que o que seria o áudio original (me lembro que postei isso e aqui no fórum ninguém sabia, procurei na internet e nada ... desconfiei dessa opção, desabilitei-a e "voilà !", corrigi o problema ...

[]´s
Reply With Quote
  #8  
09-19-2004, 06:58 PM
ginoboy ginoboy is offline
Free Member
 
Join Date: Apr 2004
Posts: 922
Thanks: 0
Thanked 0 Times in 0 Posts
Eu tb uso SEM essa opção danpos, mas o problema q ele esta usando sem (provavelmente) e falei pra ele testar "com" pra ver no q dá, se a caso ja estive habilitado, tente fazer "sem" p/ ver se corrigi este problema..

[]'s
Reply With Quote
  #9  
09-19-2004, 08:25 PM
danpos danpos is offline
Free Member
 
Join Date: May 2004
Location: Rio de Janeiro - Brasil
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ginoboy
Eu tb uso SEM essa opção danpos, mas o problema q ele esta usando sem (provavelmente) e falei pra ele testar "com" pra ver no q dá, se a caso ja estive habilitado, tente fazer "sem" p/ ver se corrigi este problema..

[]'s
Fala, Gino ! OK, o colega tem que especificar como ele tá fazendo a recuperação do MPEG do bin/cue ... Só postei porque quando tive o problema foi fod ... pois foi um fenômeno bizarro, fiquei "maluquinho" atrás da resposta ... Então me sinto no dever de compartilhar esse conhecimento com os demais (para que este fórum continue sendo 10 )

[]´s
Reply With Quote
  #10  
09-19-2004, 08:29 PM
Marciovzg Marciovzg is offline
Free Member
 
Join Date: Jun 2004
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to Marciovzg
Tenta extrair do .bin ou do .iso, do .cue também dava erro aki!
Reply With Quote
  #11  
09-19-2004, 10:16 PM
HC_Pensador HC_Pensador is offline
Free Member
 
Join Date: May 2004
Location: São Luís
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to HC_Pensador Send a message via MSN to HC_Pensador
eu fiz assim dessa vez, selecionei o "fix mpeg erros" e fui em bin/cue --> mpeg e continua dando o mesmo erro
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
O q fiz de errado? imagem pequena.... Homer_s Conversão e Codificação de Vídeo (Português) 16 10-05-2004 10:37 PM
DIKO Gold - Recodificando MPEG - Áudio com tempo menor danpos Conversão e Codificação de Vídeo (Português) 13 08-22-2004 08:45 PM
Mesquita o que ta de errado alexeram Conversão e Codificação de Vídeo (Português) 2 12-23-2003 08:02 AM
Vmesquita, o que deu errado? DrStein Conversão e Codificação de Vídeo (Português) 7 12-09-2003 11:23 PM
Ouq pode estar errado? mcmagoobr Conversão e Codificação de Vídeo (Português) 1 09-13-2003 05:43 PM

Thread Tools



 
All times are GMT -5. The time now is 03:46 PM  —  vBulletin © Jelsoft Enterprises Ltd