Quantcast Problema No Mencode-Me - digitalFAQ.com Forums [Archives]
  #1  
05-02-2004, 02:46 AM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Estou com um problema no que diz respeito ao Mencode-me.

Estava usando a ver. 0.22 e ontem atualizei para a versão 0.23 e me deparei com uma perda brusca na velocidade do encode.

Estou usando o makeavis certinho, sem nenhum problema e script do mr.maker para filmes e animes.

Antes encodava a uma velocidade de 35fps + ou-, usando a resolução 352x240 e agora fico nos 10fps, como se estivesse encodando no tmpgenc.

Tenho um P4 1.8 gHz, 256 RAM.

O que será que está acontecendo?? Já fiz e refiz o processo várias vezes e continuo nos 10fps e tenho certeza que estou fazendo tudo ok, como fazia antes do problema.

Log:

Quote:
Mencoder.exe -include temp.conf -lavcopts vbitrate=528:vpass=1 "C:\video.avi" -o "C:\video.mpv" MEncoder dev-CVS-040430-00:00-3.3.1 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 1832 MHz (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
Can't open '//.mplayer/codecs.conf': No such host or network path
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Compiled with runtime CPU detection - WARNING - this is not optimal!
File not found: 'frameno.avi'
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Failed to open frameno.avi
Reading //.mplayer/codecs.conf: Reading /usr/local/etc/mplayer/codecs.conf: Using built-in default codecs.conf.
: No such host or network path
Reading config file //.mplayer/mencoderReading config file temp.conf
font: can't open file: //.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
success: format: 0 data: 0x0 - 0x560E00
AVI file format detected.
AVI_NI: No audio stream found -> no sound.
VIDEO: [AVIS] 352x288 16bpp 25.000 fps 0.8 kbps ( 0.1 kbyte/s)
[V] filefmt:3 fourcc:0x53495641 size:352x288 fps:25.00 ftime:=0.0400
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
================================================== ========================
Opening video decoder: [vfw] Win32/VfW video codecs
Loaded DLL driver ffvfw
VDec: vo config request - 352 x 288 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 9.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
videocodec: libavcodec (352x288 fourcc=3167706d [mpg1])
Selected video codec: [makeavis] vfm:vfw (FFvfw makeavis)
New_Face failed. Maybe the font path is wrong.
================================================== ========================
Please supply the text font file (~/.mplayer/subfont.ttf).
Writing AVI header...
subtitle font: load_sub_face failed.
Pos: 0.1s 3f ( 0%) 1fps Trem: 0min 0mb A-V:0.000 [0:0][mpeg1video @ 0x9b50a0]rc buffer underflow
Pos: 39.0s 975f ( 0%) 10fps Trem: 333min 476mb A-V:0.000 [496:0]
Script

Quote:
AviSource("C:\video.avi", false)
Blockbuster(method="noise",detail_min=1,detail_max =3,variance=0.5,seed=1) #aumente ou diminua a variance para adquirir a qualidade desejada
ATC(2,3,5,0.5,false)
TemporalSoften(2,7,7,3,2)
Blockbuster(method="noise",detail_min=1,detail_max =10,variance=0.8,seed=5823) #aumente ou diminua a variance para adquirir a qualidade desejada
Deen()
Undot()
LumaFilter(-1,1.0) #Para Vídeos escuros (geralmente filmes)
LanczosResize(336, 270, 2, 0, 636, 480)
AddBorders(8, 9, 8, 9)
TextSub("C:\legenda.smi")

Bj
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
05-02-2004, 07:01 AM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Bom, a perda de velocidade descrita por vc realmente é muito grande. Na 0.22 sem querer eu mandei uma versão do mencode otimizada para SSE, mas isso aumenta a performance um pouquinho, não tanto assim. Bom, vc pode utilizar o mencoder.exe do 0.22 na 0.23 que funciona (na verdade vc pode usar qq binario do mencoder e qq binario do Mplayer, desde q tenha directx compilado). Isso deve ajudar.
Reply With Quote
  #3  
05-02-2004, 09:31 AM
Prodater64 Prodater64 is offline
Free Member
 
Join Date: Mar 2003
Location: Palma de Mallorca - España
Posts: 2,925
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by fabiana
Estava usando a ver. 0.22 e ontem atualizei para a versão 0.23 e me deparei com uma perda brusca na velocidade do encode.
O mesmo aqui.
Reply With Quote
  #4  
05-02-2004, 12:38 PM
fabiana fabiana is offline
Free Member
 
Join Date: Sep 2003
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Obrigada pela rápida resposta Vmesquita.

Mas onde eu posso encontrar a ver. 0.22? Não está mais disponível.
Eu não possuo mais o installer.

Alguém poderia me enviar essa versão?

Bjão
Reply With Quote
  #5  
05-03-2004, 02:11 AM
Luciano Cabrera Luciano Cabrera is offline
Free Member
 
Join Date: Mar 2004
Location: Brazil, RS
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Olá,
aqui também notei uma diminuição na velocidade do meu encode.
Na verdade, usando o avisynth+makeAVIS caiu pela metade.

Existe alguma maneira de dar uma otimizada na velocidade, Vmesquita?

Bom, vou testar trocar os binários pelos da versão anterior.


Té++
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
CDZ no Mencode-me e D.I.K.O ikhonus Conversão e Codificação de Vídeo (Português) 3 07-16-2004 11:05 AM
Problema com Mencode sozinhoslz Conversão e Codificação de Vídeo (Português) 1 06-04-2004 08:33 PM
:: Mencode-me :: BJ Conversão e Codificação de Vídeo (Português) 6 05-26-2004 11:02 AM
CCE VS. MENCODE XBart Convertir y Codificar Video (Español) 4 05-24-2004 05:21 PM
:: Mencode-me :: BJ Conversão e Codificação de Vídeo (Português) 14 04-27-2004 01:53 AM

Thread Tools



 
All times are GMT -5. The time now is 12:12 PM  —  vBulletin © Jelsoft Enterprises Ltd