Quantcast Mon Film est de Mauvaise Qualité (...Suite) - digitalFAQ.com Forums [Archives]
  #1  
10-24-2003, 02:31 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Bonjour à tous,

Pour répondre à Diahlot, je me suis trompé dans le dernier topo, lorsque je lance Windows Media Player et ouvre un script avs contenant juste un avisource, l'image est de bonne qualité.

Par contre, j'ai remarqué que si je lance le script optimal avec toujours le même fichier avi et toujours sous Windows Media Player l'image est saccadée (j'ai que des séquences arrétées).

Sinon, comme Diahlot m'a dit, j'ai lancé mon encodage avec une image pas trés belle à regardé sous l'onglet "vidéo" de Tok.

La procedure d'encodage s'est déroulée correctement à mon sens (test sous Tmpgenc du CQ, encodage sous format m1v et puis pour finir sous mpg).

Temps pour l'encodage environ 7h.
CQ environ 51.

Tout content d'avoir attendu 7h , je me précipite sur mon mpg et la surprise, j'ai que 25 minutes de films, l'image est nulle (comme avant l'encodage) et en plus ça me prend 700 Mo.

Par contre mon m1v est d'une durée de 2h, environ 700 Mo mais aussi d'une mauvaise qualité.

Si quelqu'un pouvais m'aider :P , ça serait vraiment sympa.

A bientôt.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #2  
10-24-2003, 03:01 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by edouard
Par contre, j'ai remarqué que si je lance le script optimal avec toujours le même fichier avi et toujours sous Windows Media Player l'image est saccadée (j'ai que des séquences arrétées).
Lol. Ca c'est normal : les filtres, tu ne penses pas qu'ils prennent du temps a faire leur travail ? A moin d'avoir un P4 3.06Ghz et d'encoder en temps reel, il y a des arrets.

Quote:
CQ environ 51.
C'est TRES faible. En dessous de 60 personellement, je ne lance meme pas l'encodage. J'essaie de me maintenir vers 65.

Quote:
j'ai que 25 minutes de films, l'image est nulle (comme avant l'encodage) et en plus ça me prend 700 Mo.
Non tu n'as pas que 25 minutes, tu as tout ton film, je te rassures. Le MPEG1 VBR n'etant pas standard, les players y perdent les pedales et n'arrivent plus a determiner la longueur de la video. Et tu sais quoi ? Ca sera pareil sur l'afficheur de ton lecteur de DVD lorsque tu auras enfin reussis a aller jusqu'au bout

Quote:
Par contre mon m1v est d'une durée de 2h, environ 700 Mo
Tu vois

Quote:
mais aussi d'une mauvaise qualité.
Bon alors maintenant, si tu me decrivais cette mauvaise qualite. A quel niveau ce se situe ?

Quote:
Si quelqu'un pouvais m'aider :P , ça serait vraiment sympa.
Deja ne lance jamais un encodage avec une CQ de 51. Si elle est si faible, il faut retravailler le script ou se resigner a utiliser 2 CD.
Quel script as tu utilise ?
Quel bitrate pour le son as tu mis ?
Reply With Quote
  #3  
10-24-2003, 03:30 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Encore une fois diahlot je te remercie pour tou soutien.

Je suis acharné mais j'y arriverai

Pour simplifier la réponse, concernant le son, je m'en préoccupe pas trop pour l'instant je préfére me concentrer sur la vidéo et sur ce m1v de trés mauvaise qualité.

Pour te décrire simplement cette mauvaise qualité, c'est comme si je travaillé sous 256 couleurs. Je n'ai pas de problème de pixelisation mais juste des vagues de couleurs autour des personnages ou sur les fonds de couleurs comme si tu avais un arc-en-ciel et que tu voyais bien les changement de couleur.

J'ai exactement la même définition qu'avant d'encoder qu'aprés encodage, comme si je n'avais jamais encoder .

Pour moi, j'étais pratiquement sûr qu'en encodant, j'aurai la même image que sous Tok, je ne sais pas pourquoi mais bon .

Rassure-moi sur tous les films que tu encodes tu as aussi cette mauvaise qualité (sous Tok où Tmpgenc).

Mon script est le suivant :
Code:
unfilter(50,50) 
GripCrop( X, Y ) 
GripSize(resizer="BicubicResize") 
STMedianFilter(8, 32, 0, 0, 8, 32) 
# SpaceDust() # Optional - for some "not so clean" DVDs. 
temporalsmoother(1,2) 
mergechroma(blur(1.50)) 
mergeluma(blur(0.2)) 
# Convolution3d or DCTFilter for extreme worse cases. 
GripBorders()
Reply With Quote
  #4  
10-24-2003, 04:25 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by edouard
Pour simplifier la réponse, concernant le son, je m'en préoccupe pas trop pour l'instant je préfére me concentrer sur la vidéo et sur ce m1v de trés mauvaise qualité.
Mais c'est lie ! Plus tu prevois de place pour le son, moins tu en as pour la video. Et vu que tu as une CQ de 56, tu devrais SERIEUSEMENT envisager de sacrifier un peu le son. Un bitrate de 112 Ko/s pour le son suffira. Tu as choisi quoi dans Tok ? 128 ?

Quote:
Pour te décrire simplement cette mauvaise qualité, c'est comme si je travaillé sous 256 couleurs. Je n'ai pas de problème de pixelisation mais juste des vagues de couleurs autour des personnages ou sur les fonds de couleurs comme si tu avais un arc-en-ciel et que tu voyais bien les changement de couleur.
Question : as tu regle ton probleme de RGB32 ?
Question2: as tu deja regarde un mpg descendu du net ? Etait-il de bonne qualite ?

Quote:
Pour moi, j'étais pratiquement sûr qu'en encodant, j'aurai la même image que sous Tok, je ne sais pas pourquoi mais bon .
Tu es a 2 doigts de dire que je te racontes de conneries la. Appreciable...

Quote:
Rassure-moi sur tous les films que tu encodes tu as aussi cette mauvaise qualité (sous Tok où Tmpgenc).
Tu parles de la PREVIEW ? Je t'ai deja donne la reponse.

Quote:
Mon script est le suivant :
Code:
unfilter(50,50) 
GripCrop( X, Y ) 
GripSize(resizer="BicubicResize") 
STMedianFilter(8, 32, 0, 0, 8, 32) 
# SpaceDust() # Optional - for some "not so clean" DVDs. 
temporalsmoother(1,2) 
mergechroma(blur(1.50)) 
mergeluma(blur(0.2)) 
# Convolution3d or DCTFilter for extreme worse cases. 
GripBorders()
Lorsque je te demandes le script que tu as employe, je voudrais le script que tu as employe, pas le script generique que tu as pris sur le forum.
Autrement dit : la ligne GripCrop, tu as quoi dedans ?
Reply With Quote
  #5  
10-24-2003, 04:55 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Une autre petite chose qui pourra faire gagner du temps :

Peux tu essayer d'ajouter la ligne "ConvertToYUY2()" juste apres l'avisource(...) dans ton script ?

Et pour faire des tests plus rapides : ne demande pas a Tok de faire la prediction, fixe la CQ a 70, lance l'encodage, laisse tmpgenc encoder une minute de video et stoppe le. Tu peux alors ouvrir le m1v qui a commence a etre encode dans wmp et voir de suite ce que ca donne. Inutile d'attendre 7h pour ca
Reply With Quote
  #6  
10-24-2003, 04:59 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Pour le RGB, je ne travaille plus dessus car c'est le PC de mon bureau donc le problème est sur ma bécane (chez moi). Mais il me semble de te l'avoir dit.

Alors je n'ai pas le script sous les yeux mais il me semble qu'en Gripcrop j'ai mis 528,576 ou 544,576, d'ailleurs je ne comprends pas trop cette histoire de résolution.

Apparement il faut des chiffres proche de la résolution du film, là je suis Ok. Pour trouver la bonne résolution sans faire de plantage du script, j'utilise l'onglet Destination sous Moviestacker et choisi entre VCD, SVCD ... jusqu'à tomber sur une résolution proche de mon film et je recopie ces chiffres dans mon script.

C'est juste comme cela ?

Sinon, encore une petite question :

Pour faire mes essais d'encodage plus vite, est-ce que je peux arréter la procédure d'encodage dans Tmpgenc 10 minutes environs aprés les tests de CQ pour voir la qualité de mon m1v créer dans le repertoire work ?

@ ++
Reply With Quote
  #7  
10-24-2003, 05:08 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by edouard
Pour le RGB, je ne travaille plus dessus car c'est le PC de mon bureau donc le problème est sur ma bécane (chez moi). Mais il me semble de te l'avoir dit.
Sur ce point c'est toi qui a raison. Je ne sais plus qui me dis quoi a force

Quote:
Alors je n'ai pas le script sous les yeux mais il me semble qu'en Gripcrop j'ai mis 528,576 ou 544,576, d'ailleurs je ne comprends pas trop cette histoire de résolution.
Justement c'est tres important : vu que ta CQ est desesperement faible, il faut diminuer la resolution a 480*576 par exemple.
Et il me faudrait aussi la suite de la ligne, car il ne doit pas y avoir que ca.

Quote:
Apparement il faut des chiffres proche de la résolution du film, là je suis Ok.
Ah non, pas du tout ! La seule recommandation est de ne jamais aggrandir une image, donc tjs prendre une reso inferieure a celle de la source. Mais rien ne t'intderdit de faire du 352*288 sur une source en 640*480.

Quote:
C'est juste comme cela ?
La technique est bonne, mais comme je te dis tu es libre de choisir VCD tout le temps si ca te chantes.

Note: en plus il faut faire attention avec les resol 3/4DVDfull (544*576) et small(528*576) : tous les lecteurs de DVD ne supportent pas les 2. Il faut faire un essai.

Quote:
Pour faire mes essais d'encodage plus vite, est-ce que je peux arréter la procédure d'encodage dans Tmpgenc 10 minutes environs aprés les tests de CQ pour voir la qualité de mon m1v créer dans le repertoire work ?
Il semble que nos posts se soient croises
Voir reponse juste au dessus.
Reply With Quote
  #8  
10-24-2003, 05:35 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Merci pour tout. Je sens que je vais faire plein d'essai ce week-end, je te tiendrai au courant.


Bon week-end et à bientôt.
Reply With Quote
  #9  
10-24-2003, 07:08 AM
Dialhot Dialhot is offline
Free Member
 
Join Date: May 2003
Posts: 10,463
Thanks: 0
Thanked 0 Times in 0 Posts
N'oublie pas de faire ton test avec la ligne "ConverToYuY2()" comme dit plus haut.

Et avant meme de commencer, reponds a cette autre question que tu as saute plus haut : as tu deja telecharger un mpeg du net et etait-il de bonne qualite ou as tu le meme probleme de couleurs ?

Parce que si tu as le meme prob avec tous les mpeg, c'est que tu as un codec de m.... sur ton disque
Reply With Quote
  #10  
10-24-2003, 07:32 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
OK, je vais essayer tout ça ce soir (téléchargement d'un mpeg...).

Je te tiendrai informé

A bientôt
Reply With Quote
  #11  
10-28-2003, 02:06 AM
edouard edouard is offline
Free Member
 
Join Date: Oct 2003
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
J'ai résolu mon problème en changeant de version avisynth, je suis passé à la 2.5.

Et là plus de probléme sous Tok ou TmgpenC, image nickel .

Voilà pour l'info.

Bon vent
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Qualité kdvd = processeur ? le_barbu Conversion et d'Encodage de Vidéo (Français) 2 11-06-2006 09:22 AM
Pour obtenir meilleure qualité en DVD elora2502 Conversion et d'Encodage de Vidéo (Français) 30 09-06-2004 06:36 AM
Qu'utiliser pour trouver la qualité prevision avec cce? tamahome Conversion et d'Encodage de Vidéo (Français) 3 08-03-2004 11:35 AM
Mon film est de mauvaise qualité en lançant le script avs edouard Conversion et d'Encodage de Vidéo (Français) 3 10-23-2003 04:23 AM
Mauvaise qualite WaSaBi Conversion et d'Encodage de Vidéo (Français) 4 10-14-2003 08:39 AM

Thread Tools



 
All times are GMT -5. The time now is 10:26 AM  —  vBulletin © Jelsoft Enterprises Ltd