Quantcast DIKO Free 0.76/Gold 1.46 Beta 1 Bug Report - Page 2 - digitalFAQ.com Forums [Archives]
  #21  
09-13-2004, 01:55 PM
GFR GFR is offline
Free Member
 
Join Date: May 2002
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Oi vmesquita,

Testando o DIKO pela primeira vez (v 0.76).

Primeiro, parabéns, o software é muito simples de usar e bem eficiente !!! Adorei a parte de escolha automática de resolução.

Tive um problema com o áudio, o source é um avi com áudio mp3 VBR. Passei para ac3 com o SoftEncode, ficou tudo em sincronia, mas... perdeu o estéreo, ficou como se os dois canais fossem cópia de um mesmo canal do source. Como o source era um vídeo de show com a guitarra toda mixada de um lado só, além de perder ambiência, perdi também a maior parte do som de guitarra (sobraram os vazamentos na gravação dos outros instrumentos). Refiz o áudio manualmente (demuxei com VDubmod, passei pra wav com o foobar e mandei pro softencode) e ficou tudo legal.

Talvez este problema não seja tão perceptível com filmes normais, já que o diálogo está presente nos dois canais.

edit: neste thread
http://www.kvcd.net/forum/viewtopic....ght=softencode
parece que alguém teve o mesmo problema...
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Site Staff / Ad Manager
 
Join Date: Dec 2002
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
  #22  
09-13-2004, 02:32 PM
FlavioMetal FlavioMetal is offline
Free Member
 
Join Date: Dec 2003
Posts: 935
Thanks: 0
Thanked 0 Times in 0 Posts
Nossa! Olha só quem voltou!

E aí, GFR, blz?
Reply With Quote
  #23  
09-13-2004, 04:43 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Oi GFR,

Obrigado pelos elogios.
Estranho isso, nunca aconteceu comigo... Veja o que foi feito com seu audio:
1) extraido com AVI2WAV
2) decodificado em WAV com o MadPlay. (o decoder mais confiável segundo muita gente, o mesmo usado pelo DVD2SVCD)
3) Passou pelo BeSweet, para mudar a frequencia ou Framerate se necessário
4) WAVs codificados com BeSweet.

Acredito que o MadPlay ou BeSweet não se deu muito bem com seu audio... Se vc tiver com paciência, pode testar executar os comandos no log e descobrir exatamente em que etapa o audio "virou" Monoestereo.
Reply With Quote
  #24  
09-13-2004, 07:55 PM
FlavioMetal FlavioMetal is offline
Free Member
 
Join Date: Dec 2003
Posts: 935
Thanks: 0
Thanked 0 Times in 0 Posts
Aí, V, só pra conhecimento: pq ele extrai o WAV e depois decodifica pra WAV mesmo com o Mad Play? Qual o risco de fazer WAV --> MP2 direto com o WAV extraído pelo AVI2WAV?
Reply With Quote
  #25  
09-13-2004, 08:30 PM
GFR GFR is offline
Free Member
 
Join Date: May 2002
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Valeu vmesquita,

Infelizmente, marquei pra apagar os temp files então não dá pra procurar as pistas...

Vou tentar refazer salvando os temp files, aí eu testo cada wav no meio do caminho! (comparando com o log).

Flavio:

Acho que os passos são os seguintes:

1) O AVI2WAV extrai o stream de áudio, seja lá o que for (wav, mp2, no meu caso mp3);
2) O MAD converte o mp? pra um wav, propriamento dito (se o avi tivesse audio wav, não precisava).
3) O besweet acerta frequência de amostragem, normalização etc. (redundante no meu caso, o áudio já era 48KHz).
4) Aí o Softencode codifica o wav para ac3.
Reply With Quote
  #26  
09-14-2004, 12:10 PM
FlavioMetal FlavioMetal is offline
Free Member
 
Join Date: Dec 2003
Posts: 935
Thanks: 0
Thanked 0 Times in 0 Posts
É...eu já tinha mesmo reparado q o AVI2WAV (ou o VD) extrai um WAV "falso"...o tamanho era muito pequeno pra ser um MP3 "descompactado" pra WAV!

Blz...vou usar o Mad Play pra testar...

Valeu, GFR!
Reply With Quote
  #27  
09-14-2004, 07:42 PM
GFR GFR is offline
Free Member
 
Join Date: May 2002
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
VMesquita:

saida do avi2wav -> o "wav" e o "mp2" estão OK;
saida do MAD -> OK
saida do Beswet -> OK
saida do SoftEncode-> MONO (e bem baixa)

A linha do log é esta:

20:27:27 - "C:\Program Files\Sonic Foundry Soft Encode\SFTENCDD.EXE" -A -P D:\temp\softenc.ini -o D:\temp\movie0.ac3 -L D:\temp\movie0.wav -R D:\temp\movie0.wav -N

Minha suspeita é que a linha de comando espera dois arquivos mono diferentes, um para L outro para R. Usando o mesmo arquivo estereo para L e R, acabou pegando o mesmo canal do source pros dois canais do target.

Bom, de qualquer forma refiz o áudio manualmente, seguindo as recomendações nesta thread do doom9:

Sticky:GUIDE: How To Properly Encode Dolby Digital Audio (AC3)

http://forum.doom9.org/showthread.ph...threadid=56020

O volume fica bem mais razoáel...

Não sei se dá pra automatizar este processo de casar o dialnorm com o rms usando ferramentas freeware de linha de comando... talvez com alguma implemantação do ReplayGain e o Besweet...

Um abraço,

GFR
Reply With Quote
  #28  
09-15-2004, 08:58 AM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
O BeSweet era pra achar o ganho máximo (opção -g) e normalizar por ele, estranho não ter funcionado...
Quanto ao SoftEncode, eu acho estranho que ele estava codificando mono sempre. Eu lembro que eu mesmo converti um filme em que o Dolby 2.0 foi mantido (e estava em 1 CD com som MP3), quando converti para MPEG2 com som AC3, os canais surround estavam lá. Obviamente, canais surround não existem se os dois canais não forem diferentes (e contiverem as informações necessárias). Será que não é o SoftEncode que vc está usando que está com algum problema?
Quanto a thread, eu li há muito tempo atrás... Realmente não tem como automatizar estes parametros (ou pelo menos não tinha 4 meses atras, hehehe). O que eu fiz foi testar com alguns encodes e utilizar um valor médio, mas claro que não é o ideal.
Reply With Quote
  #29  
09-15-2004, 10:30 AM
GFR GFR is offline
Free Member
 
Join Date: May 2002
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vmesquita
O BeSweet era pra achar o ganho máximo (opção -g) e normalizar por ele, estranho não ter funcionado...
Quanto ao SoftEncode, eu acho estranho que ele estava codificando mono sempre. Eu lembro que eu mesmo converti um filme em que o Dolby 2.0 foi mantido (e estava em 1 CD com som MP3), quando converti para MPEG2 com som AC3, os canais surround estavam lá. Obviamente, canais surround não existem se os dois canais não forem diferentes (e contiverem as informações necessárias). Será que não é o SoftEncode que vc está usando que está com algum problema?
Quanto a thread, eu li há muito tempo atrás... Realmente não tem como automatizar estes parametros (ou pelo menos não tinha 4 meses atras, hehehe). O que eu fiz foi testar com alguns encodes e utilizar um valor médio, mas claro que não é o ideal.
Bom, o Soft Encode pode até ter algum "problema"..., mas então é só na linha de comando, porque usando o GUI fica legal.

Quanto à normalização... Na página do ReplayGain.org tem um aplicativo chamado wavgain, linha de comando, com sources, que imprime o RG para uma wave.

Como o RG, LAeq e RMS são todos estimativas do volume aparente (umas mais elaboradas, como o RG, outras mais simples como o RMS), pode ser que o RG seja uma aproximação pelo menos razoável para o dialnorm.

Como -20db (RMS) equivale a 83db (referência do RG), para estimar o dialnorm basta uma pequena aritmética. Por exemplo, se o RG de uma wav der 4dB, significa que faltam 4db para chegar a 89db (target do RG), ou seja o "loudness" do seu arquivo é 85db(RG), 2db acima da referência (85-83), o que daria -18dB (RMS) (-20+2), e o dialnorm poderia ser estimado como -18db. Simplificando o cálculo:
dialnorm = -RG-14

Obviamente isto teria que ser bastante testado, porque talvez (ao contrário da minha expectativa) o RG seja uma estimativa de dialnorm muito pior do que o RMS.
Reply With Quote
  #30  
09-16-2004, 05:24 PM
vmesquita vmesquita is offline
Invalid Email / Banned / Spammer
 
Join Date: May 2003
Posts: 3,726
Thanks: 0
Thanked 0 Times in 0 Posts
Isso me parece uma idéia interessante! Talvez fosse legal postar no forum de Audio para o pessoal comentar.
Reply With Quote
  #31  
09-17-2004, 06:52 AM
GFR GFR is offline
Free Member
 
Join Date: May 2002
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Putz...

Fiz um teste com o ReplayGain, usei o mesmo source (show) que eu estava testando.

Pelo RMS do CoolEdit, daria um dialnorm de -18dB.
Pelo RG, daria um dialnorm de -10db!

Muito diferente!

Acho melhor "engavetar" esta idéia, até testar com outros materiais - filmes com diálogos, documentários, shows de outros estilos (este era do Led Zeppelin), etc.

De qualquer forma vou postar no forum de áudio a sugestão, mais gente testando sempre é melhor e mais rápido.
Reply With Quote
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
D.I.K.O. 0.76 Beta 3 e Gold 1.46 Beta 3 - Reportem os Bugs! vmesquita Conversão e Codificação de Vídeo (Português) 3 10-14-2004 06:10 PM
ERRO COM AVISYNTH encodando com O DIKO FREE beta 2 gabrielbrito Conversão e Codificação de Vídeo (Português) 3 09-22-2004 01:43 PM
D.I.K.O. 0.76 Beta 2 e Gold 1.46 Beta 2 - Reportem os Bugs! vmesquita Conversão e Codificação de Vídeo (Português) 23 09-20-2004 02:54 PM
Como configuro a lengenda usando o DIKO FREE 0.76 BETA gabrielbrito Conversão e Codificação de Vídeo (Português) 1 09-19-2004 09:27 PM
DIKO Gold 1.46 bug report danpos Conversão e Codificação de Vídeo (Português) 2 08-30-2004 05:36 PM

Thread Tools



 
All times are GMT -5. The time now is 01:24 PM  —  vBulletin © Jelsoft Enterprises Ltd