05-25-2020, 08:18 AM
dmwesq dmwesq is offline
Free Member
Join Date: May 2020
Posts: 12
Thanked 0 Times in 0 Posts
My WP editor is acting very oddly, and some of my content is not publishing correctly.

I use the classic editor and have not moved to Guttenberg, and until recently had no issues. I canít pinpoint when this started, but as of late when I try to edit existing pages that are in draft mode, the editor box does not appear at all when the page is opened in the admin dashboard. If I publish the page and then go to edit the page then the editor is there, but of course I donít want to have to publish a page in order to edit it.

On top of that, even when I do this, text I add to the page saves on the admin end but does not appear in the published page. However, if I add a new page and copy and paste the material from the page that is not displaying properly, then the page renders as it should.

No recent changes to speak of, and I have gone through disabling plugins, and nothing seems to make any difference.

Iíve tried to do some searches online but have not found this particular problem. I donít know if the recent WP updates somehow caused this issue.

As a follow-up, some of my active pages are not working properly with the editor either. I went to edit a page, which yesterday I edited and had only one item in the editor, a button created through a third-party app called Everbutton. So if you went to the page, the only thing that showed up was the page title and the button. Today I added one line of text, but despite saving the page several times the text does. not appear. When I inspected the page, it showed there was no ďsectionĒ class within the main div, and that section class is where the article body would reside. There is only the header within the div which contains the page title, and the button container and the footer container. So something is preventing or stripping any text from the page itself.

I copied all the text from this page and added a new page. Once I saved that draft, I could no longer access the editor, but when I viewed the page, the added text was there, and the button I had styled but that did not appear correctly now showed up with the proper styling (I have this question as part of another thread I had reactivated).

The page I need help with: https://www.leadershiprockland.org/donate-old/
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Ads / Sponsors
Join Date: ∞
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
05-29-2020, 11:39 AM
kpmedia's Avatar
kpmedia kpmedia is offline
Site Staff | Web Hosting, Photo
Join Date: Feb 2004
Posts: 4,315
Thanked 372 Times in 341 Posts
Some years ago, I experienced something similar. The WP update was seemingly partial, and I had to manually re-upload WordPress, overwriting files. Just be careful, make a backup, in case you need to restore something. WordPress is great, but can be finicky.

Another issue is local browser cookies messing with the editor. Have you tried another? If that works, then it may be time to flush the main browser, at least for that site.

- Did my advice help you? Then become a Premium Member and support this site.
- Please Like Us on Facebook | Follow Us on Twitter

- Need a good web host? Ask me for help! Get the shared, VPS, semi-dedicated, cloud, or reseller you need.
Reply With Quote

classic editor, wordpress

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audigy 2 ZS Video Editor, Creative Video Blaster Editor for capture? fujrer Capture, Record, Transfer 3 02-01-2019 06:21 PM
WordPress editor gone after jQuery Colorbox plugin activated? kpmedia Website and Server Troubleshooting 1 09-27-2012 04:36 AM
WordPress visual editor blank? Cannot edit or make posts! [Solved] kpmedia Website and Server Troubleshooting 0 09-24-2012 01:50 AM
Problem editing pages in WordPress, visual editor is not opening! faustine Website and Server Troubleshooting 9 06-05-2012 11:02 PM
cPanel 'switch accounts' menu disappears, refreshes to client panel [FIXED] kpmedia cPanel 0 02-13-2011 07:52 PM

Thread Tools

All times are GMT -5. The time now is 11:04 AM