#1  
04-24-2015, 12:31 AM
admin's Avatar
admin admin is offline
Site Staff | Web Development
 
Join Date: Jul 2003
Posts: 4,310
Thanked 654 Times in 457 Posts
Somewhere between version 11.44 and the current 11.48 version of cPanel, something has changed in the way that servers roll back (or "restore") domains. You'll get a yellow warning, but that's glossing over the issues. Unless you look at the logs, as prompted, you'll miss seeing all the errors.

For example, at the top of the log page:

Code:
Transfer Log
Warning: Unable to copy home directory for user: abc
Warning: Removed empty DB for failed restore of “abc_wordpress”.
Warning: The system has saved the database archive data in the directory “/home/abc/cpmove_failed_mysql_dbs.1429790115”. You may use this directory’s contents to restore your data manually.
Warning: The system failed to reinstall the MySQL database “abc_wordpress” as “abc_wordpress” because of an error: The system failed to connect to the MySQL server as “abc” because of an error: Access denied for user 'abc'@'localhost' (using password: YES)
The cPanel restore process is corrupt, and the permissions are fubar.

Further down, you may see others:

Code:
Homedir
Restoring Homedir…
/bin/gtar: public_html: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-content: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-content/plugins: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-content/plugins/revslider: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-content/plugins/revslider/temp: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-content/plugins/revslider/temp/update_extract: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes/js: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes/js/tinymce: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes/js/tinymce/plugins: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes/js/tinymce/plugins/wpgallery: Cannot unlink: Permission denied
/bin/gtar: public_html/wp-includes/js/tinymce/plugins/wpgallery/img: Cannot unlink: Permission denied
/bin/gtar: Exiting with failure status due to previous errors
Unable to copy home directory for user: abc
Thankfully, the solution to this is rather easy.

Step 1: Terminate the domain. Just remove the entire thing.
Step 2: Now go back and restore the desired backup.


NOTE: A stock cPanel server should NOT remove the older backups, although the domain is now gone. If you're using some sort of cPanel plugin that removes "unneeded" backups (ie, domains no longer hosted on the server), then you're going to have a nightmare. You'll have deleted everything! In this instance, login to the server via SSH, and copy the domain backup out of the /backup folder into the /home folder. IF you're not a server admin, then ask your host for help.

That's all the is to it!


Need a good web host? — Read our 2018 Review of the Best Web Hosts
Quite often, problems with web sites are caused by having a rotten web host. Worse yet, many hosts try to blame you (the customer) for the problems! So dump that lousy company. Say goodbye to slow sites, unresponsive support techs, and downtime. Find yourself a new host today. Whether you need shared, reseller, VPS, semi-dedicated, cloud, or dedicated hosting, something on our list should be a good upgrade for you.


- Did this site help you? Then upgrade to Premium Member and show your support!
- Also: Like Us on Facebook for special DVD/Blu-ray news and deals!
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Ads / Sponsors
 
Join Date: ∞
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup domain redirects in cPanel Brent Web Hosting 0 08-25-2013 08:46 PM
How to park a domain in cPanel Brent Web Hosting 0 08-25-2013 08:45 PM
How to create an addon domain in cPanel Brent Web Hosting 0 08-25-2013 08:44 PM
How to disable Munin in cPanel/WHM, but not remove it [SOLVED] kpmedia Website and Server Troubleshooting 0 09-17-2012 09:13 AM
JVC DR-MH30 problem, eject stuck? [Solved] lordsmurf Videography: Cameras, TVs and Players 0 12-25-2009 01:59 AM

Thread Tools



 
All times are GMT -5. The time now is 11:40 AM