06-12-2023, 10:56 AM
tbird97 tbird97 is offline
Free Member
Join Date: Dec 2015
Posts: 18
Thanked 0 Times in 0 Posts
I have been trying to solve a nagging problem and am reaching out in hopes someone can help me with a capturing/editing issue.

I am capturing vhs (ntsc) using huffyuv codec. When I go to run it through QTGMC to deinterlace it, with an FFMPEGSOURCE2 script, I sometimes get good results. Other times, my audio is out of sync.

I’ve tried substituting AVISOURCE in the script rather than FFMPEGSOURCE2 and my the audio remains in sync, but the video has some frames which appear green.

I tried using a Lagarith codec capture, and my Virtualdub 2 gave an error message,
“AVISource couldn’t locate a decompressor for fourcc LAGS”

That is the summary of my issue.
I will run through my entire process below.


I have an old computer. I know it. It runs Windows Vista, 32 bit.
Not ideal, I know. I am capturing a few home videos and then 79 episodes of a favorite sci-fi show from vhs to digital capture to preserve the original mono soundtracks.
While my PC isn’t ideal, this is the extent of what I wish to capture, so it’s not enough to justify a newer PC just for that.

Windows Vista PC. 2.20 GHz, 32-bit
2 physical cores/2 logical cores
AviSynth+ 3.7.2
Hauppauge USB Live 2 capture card.

Huffyuv version 2.1.1
AVISynth+ 3.7.2
QTGMC 3.383
MaskTools2 2.223
RGTools 1.0.7
MVTools 2.7.31
Nnedi3 0-9_4_60
Zs_RF_Shared 1.157

I believe all the above is 32-bit software.
When I ran AVIsynth Info Tool the only error or warning I got was
Function duplicates:
“undefined” : “[InternalFunction]”
“Undefined” : “C:\Program Files\AVISynth+\plugins+\Zs_RF_Shared.avsi”


I capture using AmarecTV and the Huffyuv codec.
I have a Sanyo vcr running through Panasonic DMR-ES15 as a video stabilizer.
From the Panasonic to the Hauppauge USB Live 2 via composite video cable.
My settings seem to indicate I’m capturing video at: 720 x 480, fps=29.97 (AmarecTV says 30 fps), fcc=YUY2, bit =16
Audio is 48000, 16 bit, 2 channels.

I am capturing using AmarecTV as I tried to capture in Virtrualdub (1) previously and my audio was always out of sync.


Once I capture a video (.avi file), I make any trims using Virtualdub2. Audio and Video are both set to Direct Processing mode.


Once I have my video trimmed down to the correct beginning and end, I’d like to run QTGMC to deinterlace it.
I open a script in Virtualdub2.

I have a script:

FFMPEGSOURCE2(“F:\amarectv310\captures\stvhs1.avi” ,atrack=1)

As stated, sometimes results are great, other times, the audio is out of sync.

When I moved from FFMPEGSOURCE2 to AVISOURCE, I changed that line of the script.

AVIsource(“F:\amarectv310\captures\stvhs1.avi”,atr ack=1)

In Virtualdub2, I select Full Processing mode for audio.
For video, when I load this script in VirtualDub 2, I select for the compression Huffyuv codec
4:2:2 YCbCr (YUYV, YUY2)
I left color space and component range to “no change”
It tells me the source is YUV422.


If I get this sorted out where I’m not getting results with audio out of sync or the flashing video, I’ll then take the QTGMC file and put it through handbrake to compress it to an .mkv (or .mp4) container.
Just trying to sort that issue and, am I doing any unnecessary color conversions?
I’ve tried doing this without the Convert to YV12 line in the script and it looks to me like it works.

I feel like I’m close. It’s just so frustrating that some of my captures come out just fine in FFMPEGSOURCE2 and others have the audio out of sync. I thought switching to AVIsource would fix that and it did, only to add the video issue which seems to occur with every capture I’ve tried to run through it.

I wondered if I could figure out why my Virtualdub doesn’t like Lagarith, that might solve it.
However, of note (I think), I also tried a video capture using the UTvideo codec. It game the same green flash on some frames when run through the AVISource QTGMC script above.
Reply With Quote
Someday, 12:01 PM
admin's Avatar
Ads / Sponsors
Join Date: ∞
Posts: 42
Thanks: ∞
Thanked 42 Times in 42 Posts

avisource, avisynth, qtgmc, vhs

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't run Avisynth script, FFindex failed? chrisbati Restore, Filter, Improve Quality 4 04-03-2021 10:45 AM
Perfect my Avisynth script? geordie10 Restore, Filter, Improve Quality 7 10-23-2020 10:31 AM
Line TBC with Avisynth script? jjdd Restore, Filter, Improve Quality 3 11-14-2019 01:43 AM
Problem with custom script in Avisynth to stabilize video? benzio Restore, Filter, Improve Quality 0 03-07-2018 11:27 AM
Avisynth script to fix offset interlacing? lordsmurf Restore, Filter, Improve Quality 4 02-10-2018 05:34 PM

Thread Tools

All times are GMT -5. The time now is 09:22 AM